Which version of MySQL is required?

Results 1 to 7 of 7
  1. #1
    Member zhongtiao1 is offline
    MemberRank
    Jul 2020 Join Date
    Jan MayenLocation
    33Posts

    Which version of MySQL is required?

    Which version of MySQL is required?
    Using MySQL 8.0 (The latest), it screams that a socket error is occurring due to no charset found.

    The fixes all say that its due to the application needing an ancient version. A fix is supposedly rebuilding the database as latin1 instead of utf-8. Unfortunately, that did not work (unless I did something wrong).

    I am using the compatibility settings version of 8.0, so it defaults to MySQL 5.7 based databases.

    It doesn't seem like an application issue since it's giving a charset error.

    In other news, I can get SkaterGirl8's installer to the login screen, so maybe that can now work with the server if I can get it running


  2. #2
    Libre Software Developer PyroSamurai is offline
    ModeratorRank
    Sep 2012 Join Date
    USALocation
    651Posts

    Re: Which version of MySQL is required?

    Keep in my that the libmySQL.dll in server files is from 2004. So if it indeed used MySQL, it was version 4.0 .

    Getting to the login screen is not related to compatibility to the server.
    All clients can reach the login screen without a server to connect to.
    Happy Hacking!
    "Unless someone like you cares a whole awful lot, nothing is going to get better. It's not."-Dr. Seuss

    I don't want admiration. I want you to follow my example.
    The best way to bring moderator attention to a post is to use the report button (⚠️).

    Like my releases or want to thank me? -> give me rep. (✶ at bottom left)
    For other displays of affection -> use the like button.
    Moderator of Trickster Online & f168
    RZ Dev


  3. #3
    Member zhongtiao1 is offline
    MemberRank
    Jul 2020 Join Date
    Jan MayenLocation
    33Posts

    Re: Which version of MySQL is required?

    Quote Originally Posted by PyroSamurai View Post
    Keep in my that the libmySQL.dll in server files is from 2004. So if it indeed used MySQL, it was version 4.0 .
    Are you sure the libmySQL.dll is from 2004? The server files themselves seem to be from 2009. HKO didn't even exist until 2008.

    Getting to the login screen is not related to compatibility to the server.
    All clients can reach the login screen without a server to connect to.
    Good to know, thanks.

  4. #4
    Libre Software Developer PyroSamurai is offline
    ModeratorRank
    Sep 2012 Join Date
    USALocation
    651Posts

    Re: Which version of MySQL is required?

    I am sure that is the last time they were modified. May 13, 2004 and June 07, 2004.
    Like I said, if those dll are actually used then the version would be 4.0 . Verify here
    Happy Hacking!
    "Unless someone like you cares a whole awful lot, nothing is going to get better. It's not."-Dr. Seuss

    I don't want admiration. I want you to follow my example.
    The best way to bring moderator attention to a post is to use the report button (⚠️).

    Like my releases or want to thank me? -> give me rep. (✶ at bottom left)
    For other displays of affection -> use the like button.
    Moderator of Trickster Online & f168
    RZ Dev


  5. #5
    Member zhongtiao1 is offline
    MemberRank
    Jul 2020 Join Date
    Jan MayenLocation
    33Posts

    Re: Which version of MySQL is required?

    So, I figured out that 4.1 and the latest 5.7 versions all work. 8.0 had some changes that make it unusable

  6. #6
    Registered damidesu is online now
    MemberRank
    May 2018 Join Date
    12Posts

    Re: Which version of MySQL is required?

    so is the server working at least with MySQL 4.1? how did you do it??? I mean by changing the config files to point your local mysql server and that's it?

  7. #7
    Member zhongtiao1 is offline
    MemberRank
    Jul 2020 Join Date
    Jan MayenLocation
    33Posts

    Re: Which version of MySQL is required?

    Quote Originally Posted by damidesu View Post
    so is the server working at least with MySQL 4.1? how did you do it??? I mean by changing the config files to point your local mysql server and that's it?
    I'm still working it out. The database seems really flexible, the application only looks for the tables themselves, not a specific version of MySQL (Which is great for us). This means that theoretically, MySQL 8.x can work too.

    Opening up port 5500 for the game might actually be a hard requirement, but I'm not sure yet. More work needs to be done to figure everything out.
    Last edited by zhongtiao1; 26-07-20 at 10:06 PM.



Advertisement