unable to connect to account server (4.0.02.42)

Results 1 to 2 of 2
  1. #1
    Newbie sasawawa is offline
    MemberRank
    Jul 2017 Join Date
    2Posts

    unable to connect to account server (4.0.02.42)

    all thing is so good but shard give this error :(
    {unable to connect to account server}

    those are my settings
    Code:
    shard
    
    Code:
    <?xml version="1.0" encoding="utf-8"?>
    <config name="Ragezone Forever" comment="" maxUsers="10" build="Debug">
    <net basePort="10000" consoleAccessPort="9856"/>
    <resourceSystem restrictedMapsLoading="true" storeXdbLinks="true" checkResourceSystemIndex="false"/>
    
    <territory>Russia</territory>
    
    <monetization>F2P</monetization>
    
    <logging kind="local">
    <local format="csv"/>
    <remote host="localhost" port="8888"/>
    </logging>
    
    <shard role="LocalShard" memory="6144" ip="127.0.0.1">
    <frontEnd ip="127.0.0.1" port="9322" timeout="60000"/>
    <db database="allods_online_RC_4_0_02" host="127.0.0.1" user="allods_online" password="spm123"/>
    <http host="127.0.0.1" port="8080"/>
    <xmpp port="5222" domain="allods.ru" certificate="keys/xmpp.p12" password="secret" />
    <indicator/>
    <doorway/>
    </shard>
    
    
    <itemMallServer>
    <net ip="127.0.0.1" port="9321"/>
    <assortment banners-config="banners.cfg"/>
    </itemMallServer>
    
    <billingServer>
    <accounter accounterOneWay="billingserver.AccounterOneWayFakeImpl"/>
    <net host="127.0.0.1" port="9320"/>
    <api host="127.0.0.1" port="8080"/>
    <billing-api-url>http://emp2.allods.mail.ru/actions.php</billing-api-url>
    </billingServer>
    
    <accountServer>
    <approve ip="127.0.0.1" port="9346"/>
    <auth ip="127.0.0.1" port="9340" timeout="30000"/>
    <api host="127.0.0.1" port="9356" protocol="http"/>
    </accountServer>
    
    <masterServer>
    <net ip="127.0.0.1" port="9513"/>
    <api ip="127.0.0.1" port="10500"/>
    </masterServer>
    
    <resourceErrorsEnabled>false</resourceErrorsEnabled>
    
    <gameMechanics>
    <characterCreation allowDiffFactions="true"/>
    <shipRate build="1" buildReduce="1"/>
    <mobExpRate>10</mobExpRate>
    <questExpRate>10</questExpRate>
    </gameMechanics>
    
    <!-- use fake address of gametool - 127.0.0.2 - to avoid same ip as local shard -->
    <gametoolEAR ip="127.0.0.2" lang="rus">
    <standard-gametool-config>
    <mode name="slave"/>
    <instance name="Trunk shard"/>
    <database-defaults>
    <default-gametool-database port="5432" database="gametool" login="gametool" password="gametool"/>
    <default-logserver-database host="127.0.0.1" port="5432" database="logserver" login="logserver" password="logserver"/>
    </database-defaults>
    <master address="127.0.0.1" login="*" password="*"/>
    <shard id="trunk_local" name="trunk_local" address="127.0.0.1"                         login="*" password="*"/>
    </standard-gametool-config>
    </gametoolEAR>
    
    <enableDynamicMapServices>true</enableDynamicMapServices>
    </config>
    account server :
    Code:
    <?xml version="1.0" encoding="utf-8"?><config name="test_trunk_shard" build="Debug" serversNeed="1" mapServicesAmount="1">
    <net basePort="9000" datagramPort="8000" bindPortsRange="15"/>
    <logging kind="none"/>
    
    <accountServer maxUsersOnShard="10" clientsLimit="10" build="builds/standard.xml" versionOnLogin="-1" ip="127.0.0.1">
    <approve ip="127.0.0.1" port="9347"/>
    <auth ip="127.0.0.1" port="9340" timeout="30000"/>
    <api protocol="http" host="127.0.0.1" port="9357"/>
    <db host="127.0.0.1" user="postgres" password="spm123" />
    
    <authenticator>
    <api host="127.0.0.1" port="9399"/>
    </authenticator>
    
    </accountServer>
    </config>
    master server :
    Code:
    <?xml version="1.0" encoding="utf-8"?>
    <config name="AllodsBR" build="FinalRelease">
    
    <masterServer memory="1024" ip="127.0.0.1" lang="eng">
    <db host="127.0.0.1" user="allods_online" password="spm123" />
    <net ip="127.0.0.1" port="9513"/>
    <api ip="127.0.0.1" port="10500"/>
    </masterServer>
    
    </config>
    the photo and server log are in the attachments i hope anyone can help me :)
    Attached Files Attached Files


  2. #2
    Registered Tayaro is offline
    MemberRank
    Apr 2015 Join Date
    13Posts

    Re: unable to connect to account server (4.0.02.42)

    Hey,

    it looks like you set two different ports in your shard and accountserver config

    shard
    Code:
    <accountServer>
    <approve ip="127.0.0.1" port="9346"/>
    accountserver
    Code:
    <approve ip="127.0.0.1" port="9347"/>
    Just set the same port in both configs.

    There is another error in your log later. It seems there's not enough memory on your host.
    Set the value in the shard config lower and load only a few maps for testing

    Hope it helps



Advertisement