[HELP] Pre-Server--Wrong DB Password

Results 1 to 9 of 9
  1. #1
    Registered Masileus is offline
    MemberRank
    Jun 2017 Join Date
    13Posts

    [SOLVED] Pre-Server--Wrong DB Password

    [HELP] Pre-Server--Wrong DB Password
    Hello everyone,

    I downloaded source from St34lth links, compiled with VS2013, created folders for everything, setted the config. files, deleted old atum user from db, created a new one, activadet TCP/IP, changed ports on TCP/IP on IP2/3 and also changed IP with my Local one.

    I thought everything was done, but no. Still got this error.

    Can someone help me please?

    This is PRESERVER log:


    Code:
    08-28 15:54:03|[Notify] elapsed time after turn on !!  0Day  0h:24m:36s 
    
    08-28 15:54:03|Pre Server Start
    
    08-28 15:54:03|CVMem::AllocVMem VirtualAlloc() success, TypeSize[ 1508] PoolCnt[  100] CommitSize[  151552] vectorSize[1] Address Range(0x7EF50000 ~ 0x7EF75000)
    
    08-28 15:54:03|CVMem::AllocVMem VirtualAlloc() success, TypeSize[ 1528] PoolCnt[  101] CommitSize[  155648] vectorSize[1] Address Range(0x7EF20000 ~ 0x7EF46000
    
    08-28 15:54:03|CVMem::AllocVMem VirtualAlloc() success, TypeSize[ 1552] PoolCnt[15001] CommitSize[23281664] vectorSize[1] Address Range(0x7D8E0000 ~ 0x7EF14000)
    
    08-28 15:54:03|    ServerGroup:                  Ace, Enable(1) MGameServerID(10061)
    
    08-28 15:54:04|  [Notify] CPreGlobal::OnPacketNotifyOfSPToMPWinSoc# 10000 CWinSocket::WS_CONNECTED wParam(1) 
    
    08-28 15:54:04|  [Notify] CPreGlobal::InitServerSocket# Starting... 
    
    08-28 15:54:04|  [Notify] CPreIOCP::IOCPInit# 10000 
    
    08-28 15:54:04|  [Notify] CPreIOCP::IOCPInit# 11000 updated version files !
    
    08-28 15:54:04|  [Notify] CPreIOCP::IOCPInit# 12000 arranged version list !
    
    08-28 15:54:20|[DB Error] fail to connect DBServer(CPreIOCP::IOCPInit_) !! 192.168.1.240,1433 atum2_db_account : Wrong DB Password 
    
    08-28 15:54:22|[Error] PreServer IOCPInit Error08-28 15:54:23|[ERROR] CPreGlobal::OnPacketNotifyOfSPToMPWinSoc_ InitServerSocket_ error !!
    
    08-28 15:54:24|  [Notify] CPreGlobal::EndServerSocket# 
    08-28 15:54:24|CGlobalGameServer::EndServerSocket_1
    08-28 15:54:24|########################    Server IOCPClean    ########################
    
    08-28 15:54:24|[Notify] CVMem::FreeAllVMem_ TypeSize[ 1508] TotalCommitedObjCnts(   100) CurrentObjCnts(   100)
    
    08-28 15:54:24|[Notify] CVMem::FreeAllVMem_ TypeSize[ 1528] TotalCommitedObjCnts(   101) CurrentObjCnts(   101)
    
    08-28 15:54:24|[Notify] CVMem::FreeAllVMem_ TypeSize[ 1552] TotalCommitedObjCnts( 15001) CurrentObjCnts( 15001)
    
    08-28 15:54:24|Pre Server End0
    8-28 15:54:24|CGlobalGameServer::EndServerSocket_1
    Last edited by Masileus; 12-09-18 at 09:24 AM.


  2. #2
    Account Upgraded | Title Enabled! inetpub is offline
    True MemberRank
    Oct 2012 Join Date
    223Posts

    Re: [HELP] Pre-Server--Wrong DB Password

    Maybe id/pass not xored? If you have src then modify log to show currently used id/pass

  3. #3
    [HELP] Pre-Server--Wrong DB Password Future is offline
    LegendRank
    Dec 2011 Join Date
    2,275Posts

    Re: [HELP] Pre-Server--Wrong DB Password

    It would've been an idea to tell what you tried so far and which results you got as you seem to have done a bit of research on the issue already. The latter makes me question if you really found no useful information for this issue as it's something half the forum has run into already.

    I think I've summed everything to say about this error up pretty nicely in a post from 2017, I would highly suggest reading it, especially the bullet points at the end of it:

    Quote Originally Posted by Future View Post
    That error is actually logged each time the connection fails for whatever reason that is.

    Related code in the Pre Server:

    Code:
    BOOL bRet = odbcStmt.Init(g_pGlobalGameServer->GetDBServerIP(), g_pGlobalGameServer->GetDBServerPort(), g_pGlobalGameServer->GetDBServerDatabaseName(), (char*)g_pGlobalGameServer->GetODBCUID(), (char*)g_pGlobalGameServer->GetODBCPASSWORD(), g_pGlobalGameServer->GetMainWndHandle());
    if (!bRet)
    {
    	// 2008-09-05 by cmkwon, DBServer ¿¬°á ½ÇÆÐ ½Ã½ºÅÛ ·Î±× ³²±â±â - 
    	g_pGlobal->WriteSystemLogEX(TRUE, "[DB Error] fail to connect DBServer(CPreIOCP::IOCPInit_) !! %s,%d %s : Wrong DB Password \r\n"		// 2012-09-24 by jhseol, ¼Ò½ºÁ¤¸® - ÁÖ¼® Á¤¸® ID / PW ¹ÌÃâ·Â
    		, g_pGlobalGameServer->GetDBServerIP(), g_pGlobalGameServer->GetDBServerPort(), g_pGlobalGameServer->GetDBServerDatabaseName());	// 2012-09-24 by jhseol, ¼Ò½ºÁ¤¸® - ÁÖ¼® Á¤¸® ID / PW ¹ÌÃâ·Â
    
    	MessageBox(NULL, "DB connect CPreIOCP::IOCPInit()", "ERROR - SpaceCowboy PreServer", NULL);
    	return FALSE;
    }
    Their logging is as usual not of any help unless you really wrote a wrong password.

    Try to connect to your SQL serv with the Management Studio using the credentials that you put in the global.cfg and see what error the Management Studio gives you.

    Common reasons for this are:
    • TCP is not configured correctly for the SQL server (check in the Configuration Manager)
    • The server does not allow SQL authentication
    • The username is wrong
    • The password is wrong
    • You did or did not XOR the credentials in the global.cfg (depends on the bins)


    Quote Originally Posted by A Wise Man
    P-Servers are NOT dead. Bugs need squishing. Quests need fixing. Unfortunately, majority of people don't know the difference between a computer and a toaster so...

  4. #4
    Registered Masileus is offline
    MemberRank
    Jun 2017 Join Date
    13Posts

    Re: [HELP] Pre-Server--Wrong DB Password

    Thank you for your answer.
    I have already read this post @Future. I tried your solutions:
    - As i said, i checked my TCP/IP configs;
    -SQL mixed is checked (as explained in St34lth guide);
    -To start i used atum and callweb ID/PASS (already checked configs and src , they are ok);
    -i tried configs with XORED and not XORED credentials.

    i also checked Bins configs to make me sure there is nothing uncorrect, but everything seems to be Ok.

    Maybe im doing something wrong with the encoding of credentials? Any suggestion to do this in the correct way?

    Thank you for your help :D
    Last edited by Masileus; 29-08-18 at 04:00 PM.

  5. #5
    Registered Masileus is offline
    MemberRank
    Jun 2017 Join Date
    13Posts

    Re: [HELP] Pre-Server--Wrong DB Password

    Can someone help me please?

  6. #6
    Member vinleprince is offline
    MemberRank
    Feb 2015 Join Date
    48Posts

    Re: [HELP] Pre-Server--Wrong DB Password

    Quote Originally Posted by inetpub View Post
    Maybe id/pass not xored? If you have src then modify log to show currently used id/pass
    i suggest you to follow inetpub word.

    put this line for debug your db id and password first
    (Address: gameserver/preserver/main/PreIOCP.cpp / find this this word "BOOL bRet = odbcStmt.Init" then add this below that line)
    g_pGlobal->WriteSystemLogEX(TRUE, "[DB PreIOCP DEBUG] %s, %s \r\n", (char*)g_pGlobalGameServer->GetODBCUID(), (char*)g_pGlobalGameServer->GetODBCPASSWORD());

  7. #7
    [HELP] Pre-Server--Wrong DB Password Future is offline
    LegendRank
    Dec 2011 Join Date
    2,275Posts

    Re: [HELP] Pre-Server--Wrong DB Password

    But have you actually tried connecting to the SQL Server via the SQL Server Management Studio using the IP, User ID and Password you've set in the configs? If that doesn't connect, there is no chance your game servers will. + SSMS' error reporting is a ton better than masang's. You might get some useful information out of that.


    Quote Originally Posted by A Wise Man
    P-Servers are NOT dead. Bugs need squishing. Quests need fixing. Unfortunately, majority of people don't know the difference between a computer and a toaster so...

  8. #8
    Account Upgraded | Title Enabled! inetpub is offline
    True MemberRank
    Oct 2012 Join Date
    223Posts

    Re: [HELP] Pre-Server--Wrong DB Password

    Its solved on TV. It was fault of wrongly configured SQL server.

  9. #9
    Newbie Davide55 is offline
    MemberRank
    Dec 2018 Join Date
    1Posts

    Re: [HELP] Pre-Server--Wrong DB Password

    Can you tell what the problem was?



Advertisement