[ELP PO] Kaswynn Launcher, Login Server Connection failure.

Results 1 to 4 of 4
  1. #1
    Member H4TE is offline
    MemberRank
    Nov 2008 Join Date
    93Posts

    [ELP PO] Kaswynn Launcher, Login Server Connection failure.

    Hey folks. I am using Kaswynn Giga 4 E2 server files, and Kaswynn client patched with Cora21's patch. I have everything running perfectly on my internal ip address. Port 1072, 27780 are forwarded and I can connect fine using my 192. IP in the launcher. But I can not connect to my public IP address. Always says "login server connection failure." when I attempt to login. ODBC is set to internal ip. ini's set to internal IP except Gatway IP is my public IP.

    What could I be missing here?

    - - - Updated - - -

    Firewall is off, and enabling DMZ host on host PC is in effective.
    Last edited by H4TE; 12-01-18 at 05:39 PM.


  2. #2
    rf-dev.net Ron is offline
    The OmegaRank
    Apr 2005 Join Date
    Location
    9,292Posts

    Re: [ELP PO] Kaswynn Launcher, Login Server Connection failure.

    Your router may not support loopback connections (connecting to your on WAN IP). I always run in to the same issue.

    Unfortunately I've not found a proper work-around. Either the server works fine locally and no one else can connect, or everyone can connect except me. This happens regardless of IP configuration, so its nothing you're doing wrong.

    Install telnet client, set up the server for your WAN IP, then run the following command in the command prompt to test:

    telnet WAN_IP_HERE 27780

    Example:

    telnet 12.34.56.78 27780


    You won't be able to connect ingame until this test works. Maybe try looking up info for "your specific router model" + "loopback configuration" on google.
    RF-Dev Team

  3. #3
    Member H4TE is offline
    MemberRank
    Nov 2008 Join Date
    93Posts

    Re: [ELP PO] Kaswynn Launcher, Login Server Connection failure.

    I am not having this exact issue, but I did with 2.2.3.2..

    I can connect on my internal IP reguardless of configuration lol! and 27780 via telnet is letting me connect with no issues, howerver on Port in Loginserver ini file it says "1072" is my login server port. I can not however connect through that with telnet. I've tried looking for STRS for Giga4 loginserver.exe but to no avail. and can't find port 1072, 10001 or 10007 in Hex Editor either.

    - - - Updated - - -

    From looking at this thread.

    I can only conclude that maybe I'm missing something? Wish the little bastage told us how he fixed it. Normal Account cannot Connect when Running Launcher.

    Eyeballing this right now:

    [BILLING NETWORK]
    SERVER_NAME = RF_BILLING_LOGIN
    IP = 192.168.1.3
    PORT = 1072
    CP_ID = 1
    GROUP_NUM = 1
    SERVER_NUM = 1
    GAME_ID = 1

    - - - Updated - - -

    THANKS AGAIN RON! I grew a brain and used TCPVIEW and forwarded the ports on the loginserver.exe wich is "53346, 53344 and 10110" I can now achieve an external connection!
    Last edited by H4TE; 16-01-18 at 06:39 PM.

  4. #4
    rf-dev.net Ron is offline
    The OmegaRank
    Apr 2005 Join Date
    Location
    9,292Posts

    Re: [ELP PO] Kaswynn Launcher, Login Server Connection failure.

    Hey, glad you fixed it. Happy to help in some way.
    RF-Dev Team



Advertisement