[Release] Legend.mu client & server source code S16 1.1

Page 10 of 41 FirstFirst ... 2345678910111213141516171820 ... LastLast
Results 136 to 150 of 615
  1. #136
    Ultimate Member Sam3000 is online now
    MemberRank
    Oct 2007 Join Date
    MoscowLocation
    187Posts

    Re: [Release] Legend.mu client & server source code S16 1.1

    Quote Originally Posted by ispyder View Post
    Also, I didn't compile the older version of Boost and I just downloaded the latest compiled version for Boost 1.75.0 - MSVC 14.2 (32 bit) to use with the latest Visual Studio (2019) and C++17:
    - https://sourceforge.net/projects/boo...2.exe/download

    The problem with that is that in the latest version of Boost the boost::asio::io_service got deprecated and replaced by boost::asio::io_context (https://github.com/boostorg/asio/issues/110).

    I just want the server to start so I just blindly replaced io_service with io_context but I don't know if that replacement is the only necessary change related to this io_service deprecated API.

    Anyway, here's a temporary patch to compile the project and get to see the Servers List:
    - Attachment 169322
    I think, this line of code is useless. If you check all other Socket class usage you can find that no one is using this protected method by any kind.
    Btw, if i'm googled right, proper way to get io_context now is
    _socket.get_executor().context()
    - - - Updated - - -

    Dunno what i'm doing wrong.
    Updated serverlist.bmd, settings, encdec, version and serial, but still getting disconnect.

    Btw, about settings table.
    So server = -1 it's default values. If you need to set to specific server, like server = 0 and GameServer.Active.
    Add in table
    insert into settings (`server_id`, `key`, `value`) values (0, 'GameServer.Active', 1)
    p.s. why 0.75 client didnt got disconnect then?
    I think it's problem with client
    Last edited by Sam3000; 10-03-21 at 09:40 PM.

  2. #137
    Hardcore Member Pyke is offline
    MemberRank
    Sep 2007 Join Date
    PolandLocation
    106Posts

    Re: [Release] Legend.mu client & server source code S16 1.1

    How to create account? Now i didnt have disconnect, but i doing something wrong with create account because account invalid...

  3. #138
    Member ispyder is offline
    MemberRank
    Aug 2015 Join Date
    75Posts

    Re: [Release] Legend.mu client & server source code S16 1.1

    Quote Originally Posted by sam3000 View Post
    p.s. Why 0.75 client didnt got disconnect then?
    I think it's problem with client
    Quote Originally Posted by ispyder View Post
    note:
    i have added my local ip: 192.168.1.150 in offset.h.
    No updates for: clientversion and clientserial

    if i use 127.0.0.1 i get disconnected when i open main.exe and the servers list is not displayed and i get this muerror.log:

    used client:
    - handrey04 - full client (test) - http://forum.ragezone.com/f197/relea...1/#post9068930

    used main.exe: (without this main nothing happened on execution)
    - posted by myheart
    - http://forum.ragezone.com/f197/relea...ml#post9070569
    - https://mega.nz/file/3bsdeqoy#vqnc5iij7wurlyavaucw0x5ymwmjebfwgqim5zvaaa4
    What IP have you set in Offset.h? 127.0.0.1 or your local IP? With 127.0.0.1 I also got disconnected so I had to add my local IP to the client DLL.

    Note: I didn't edit any config file from: Lgd-Server-git\Release\*.conf except the MySQL user and password. So, the IPs in those configs are the default ones (127.0.0.1)

  4. #139
    Mulegend Server Mulegend is offline
    True MemberRank
    May 2006 Join Date
    Montevideo - UruguayLocation
    461Posts

    Re: [Release] Legend.mu client & server source code S16 1.1

    Quote Originally Posted by Pyke View Post
    How to create account? Now i didnt have disconnect, but i doing something wrong with create account because account invalid...

    PHP Code:
    INSERT INTO `mu_login`.`accounts` ( `account`, `password`, `email`, `security_code`, `register`, `golden_channel`, `secured` )
    VALUES
        
    (
        
    'user234',
        
    SHA2 CONCAT"user234"":""password" ), 256 ),
        
    'user@email.com',
        
    '12digitsphra',
        
    NOW( ),
        
    1500434821,
        

        
    ); 

  5. #140
    Hardcore Member Ale[!] is online now
    MemberRank
    Feb 2008 Join Date
    ArgentinaLocation
    129Posts

    Re: [Release] Legend.mu client & server source code S16 1.1

    I'm getting this error at log files when trying to run server, i don't know what can be wrong, maybe someone can give me a hint or a tip.


    Code:
    2021-03-11_03:25:39 INFO Opening DatabasePool 'database_characters'. Asynchronous connections: 1, synchronous connections: 2.
    
    ERROR Could not connect to MySQL database at 127.0.0.1: Authentication plugin 'caching_sha2_password' cannot be loaded: The specified module can not be found.
    
    2021-03-11_03:25:39 ERROR DatabasePool database_characters NOT opened. There were errors opening the MySQL connections. Check your SQLDriverLogFile for specific errors.
    - - - Updated - - -

    Now, i need help with gameserver, it closes right after it open
    I changed server code in db and gameserver config, i cant even see logs to know what's wrong

    - - - Updated - - -

    thanks to metallica i know where the crashlog for gameserver is, but i dont know why it gives me this error, because LoginServer, ConnectServer and ServerLink connects to the database...

    \GameServer_Log\System\GameServer

    Code:
    ERROR Cannot connect to GameServer database 127.0.0.1;3306;root;root;database_game
    My databases are

    database_game
    database_login
    database_log
    database_characters


    maybe i'm missing anything?

    i'm using db from ispyder
    Last edited by Ale[!]; 11-03-21 at 08:00 AM.

  6. #141
    Ultimate Member Sam3000 is online now
    MemberRank
    Oct 2007 Join Date
    MoscowLocation
    187Posts

    Re: [Release] Legend.mu client & server source code S16 1.1

    Ok, so... Main.exe or something dont like 127.0.0.1. It working with local ip.

    ps. got auto crash when waiting on server select...

    - - - Updated - - -

    Quote Originally Posted by Ale[!] View Post
    Now, i need help with gameserver, it closes right after it open
    I changed server code in db and gameserver config, i cant even see logs to know what's wrong
    Because of this code...
    Code:
    void GameServer::LoadCommonSettings()
    {
        sLog->outInfo(LOG_DEFAULT, "Loading Common Settings...");
        uint32 oldMSTime = getMSTime();
    
        sMain->Load();
    
            this->SetMaxConnectionsPerIP(sMain->GetInt32("Network.MaxConnectionPerIP", 0));
    
        std::string temp_client_version = sMain->GetString("GameServer.Version", "");
        char temp_client_version_buff[8];    
        memset(temp_client_version_buff, 0, 8);
        memcpy(temp_client_version_buff, temp_client_version.c_str(), temp_client_version.size() > 8 ? 8 : temp_client_version.size());
    
        Tokens tokens(temp_client_version_buff, '.');
    
        this->SetGameServerVersion(0, tokens[0][0]);
        this->SetGameServerVersion(1, tokens[1][0]);
        this->SetGameServerVersion(2, tokens[1][1]);
        this->SetGameServerVersion(3, tokens[2][0]);
        this->SetGameServerVersion(4, tokens[2][1]);
    sMain->GetString("GameServer.Version", "") - we want here setting GameServer.Version and second argument is default value if we dont get anything from db

    - - - Updated - - -

    Ok, so in gameserver.conf we have GameServer.Code = 0.
    Then in void MainApplication::Load() we load default settings for all servers
    QueryResult result1 = GameServerDatabase.Query("SELECT `key`, `value` FROM settings WHERE server_id = -1");
    and than settings for current server
    QueryResult result2 = GameServerDatabase.PQuery("SELECT `key`, `value` FROM settings WHERE server_id = '%u'", sGameServer->GetServerCode());
    - - - Updated - - -

    Click image for larger version. 

Name:	photo_2021-03-11_11-14-52.jpg 
Views:	109 
Size:	84.0 KB 
ID:	169329
    Ok, it's working, w8 a couple minutes i will upload all i have

    - - - Updated - - -

    My repo https://github.com/samik3k/mu_online_lgnd
    With my current db, files and other.
    Account in database user 123456

    - - - Updated - - -
    @Mulegend btw, can you give us any item_bag value? Or server by himself can make example?

    - - - Updated - - -

    2021-03-11_11:46:14 ERROR [ CHARACTER SELECT ] [SRV 0 -- 1501 - IP: 192.168.1.60 - MAC: B4:2E:99:C7:D5:A3 - Account: 1-user - Character: 1-test] has wrong world 0.
    Oh ok... thinking :D
    So, it's about character_base table
    Last edited by Sam3000; 11-03-21 at 11:00 AM.

  7. #142
    Member wermanhme1990 is offline
    MemberRank
    Aug 2011 Join Date
    26Posts

    Re: [Release] Legend.mu client & server source code S16 1.1

    Quote Originally Posted by Sam3000 View Post
    - - - Updated - - -

    My repo https://github.com/samik3k/mu_online_lgnd
    With my current db, files and other.
    Account in database user 123456
    thank you for share, i can't run file main_test.exe in link here:
    https://github.com/samik3k/mu_online...Source/Release
    because windows defender of windows 10 delete main_test.exe, please fix it.
    https://www.virustotal.com/gui/file/...050c/detection
    thank you.

  8. #143
    Ultimate Member Sam3000 is online now
    MemberRank
    Oct 2007 Join Date
    MoscowLocation
    187Posts

    Re: [Release] Legend.mu client & server source code S16 1.1

    Quote Originally Posted by wermanhme1990 View Post
    thank you for share, i can't run file main_test.exe in link here:
    https://github.com/samik3k/mu_online...Source/Release
    because windows defender of windows 10 delete main_test.exe, please fix it.
    https://www.virustotal.com/gui/file/...050c/detection
    thank you.
    I cant fix it, coz it packed with themida. Just add to excludes.
    Anyway, if this main have any virus, i cant fix that nether, coz i dont have sources of main. Just main.dll

    DB is empty, only schema, so it's not very good worknig server.
    You cant download it, run it and play for fun for now.

    Current progress:
    I can login,
    I can create character,
    Can't enter world

    PS. if you changing anything in game db you need to restart gameserver, coz it cached data on start

    - - - Updated - - -
    @Mulegend, help me please a little.
    I added character_base for DK, but server everytime says [ CHARACTER SELECT ] %s has wrong world %d
    What i missing?

    - - - Updated - - -

    Ok, i found that i need to input data in game.world_template and game.gate_template
    Last edited by Sam3000; 11-03-21 at 10:59 AM.

  9. #144
    Registered dudusiao is offline
    MemberRank
    Dec 2020 Join Date
    12Posts

    Re: [Release] Legend.mu client & server source code S16 1.1

    you need to add world (map) entry into world_template table. For Lorencia (default map for DK):

    Code:
    INSERT INTO `mu_online_game`.`world_template` (`entry`, `display_entry`, `state`, `file`, `name`, `spawn_gate`, `experience`, `zen_rate`, `flags`) VALUES ('0', '0', '0', 'terrain1.att', 'Lorencia', '17', '1', '1', '0');
    Also, there is a bug in world_area_attribute table (wrong name of column, causes GS crash on startup after adding world). Run this query:

    Code:
    ALTER TABLE `mu_online_game`.`world_area_attribute` CHANGE COLUMN `world` `world_id` SMALLINT UNSIGNED NOT NULL ;

  10. #145
    Ultimate Member Sam3000 is online now
    MemberRank
    Oct 2007 Join Date
    MoscowLocation
    187Posts

    Re: [Release] Legend.mu client & server source code S16 1.1

    Quote Originally Posted by dudusiao View Post
    Also, there is a bug in world_area_attribute table (wrong name of column, causes GS crash on startup after adding world). Run this query:

    Code:
    ALTER TABLE `mu_online_game`.`world_area_attribute` CHANGE COLUMN `world` `world_id` SMALLINT UNSIGNED NOT NULL ;
    I know about this bugs. Need to fix some more db schemas in future.
    @dudusiao did you add something in gate_template?

  11. #146
    Mulegend Server Mulegend is offline
    True MemberRank
    May 2006 Join Date
    Montevideo - UruguayLocation
    461Posts

    Re: [Release] Legend.mu client & server source code S16 1.1

    Quote Originally Posted by Sam3000 View Post

    PS. if you changing anything in game db you need to restart gameserver, coz it cached data on start
    https://github.com/DimensionGamers/L...rver.cpp#L1428

    Reload data:
    Code:
    INSERT INTO `50x_mu_character`.`server_signal` 
    ( `server`, `signal`, `data_1`, `data_2`, `data_3` )
    VALUES
    	( 0, 5, 1, 0, 0 );

  12. #147
    Registered dudusiao is offline
    MemberRank
    Dec 2020 Join Date
    12Posts

    Re: [Release] Legend.mu client & server source code S16 1.1

    Quote Originally Posted by Sam3000 View Post
    I know about this bugs. Need to fix some more db schemas in future.
    @dudusiao did you add something in gate_template?
    https://www.mediafire.com/file/emnhn...plate.csv/file

  13. #148
    Ultimate Member Sam3000 is online now
    MemberRank
    Oct 2007 Join Date
    MoscowLocation
    187Posts

    Re: [Release] Legend.mu client & server source code S16 1.1

    Quote Originally Posted by Mulegend View Post
    https://github.com/DimensionGamers/L...rver.cpp#L1428

    Reload data:
    Code:
    INSERT INTO `50x_mu_character`.`server_signal` 
    ( `server`, `signal`, `data_1`, `data_2`, `data_3` )
    VALUES
        ( 0, 5, 1, 0, 0 );
    Thx for data :D

    - - - Updated - - -

    Yeah, thx.
    Do you have full world_template?

  14. #149
    Member ispyder is offline
    MemberRank
    Aug 2015 Join Date
    75Posts

    Re: [Release] Legend.mu client & server source code S16 1.1

    Quote Originally Posted by Sam3000 View Post
    Current progress:
    I can login,
    I can create character,
    Can't enter world
    With what you uploaded I can see the Create Character screen, but nothing happens when I try to create it.

    I only get an empty screen after I try to create the character.

    Any ideas on what could be missing?

    Click image for larger version. 

Name:	2021-03-11 14_56_53-MU.jpg 
Views:	60 
Size:	83.4 KB 
ID:	169330Click image for larger version. 

Name:	2021-03-11 14_57_01-MU.jpg 
Views:	59 
Size:	281.8 KB 
ID:	169331

    Used account:
    user / 123456

    Database:
    -DB-exported-2021.03.11-15.01-v3.rar

  15. #150
    Ultimate Member Sam3000 is online now
    MemberRank
    Oct 2007 Join Date
    MoscowLocation
    187Posts

    Re: [Release] Legend.mu client & server source code S16 1.1

    Quote Originally Posted by ispyder View Post
    With what you uploaded I can see the Create Character screen, but nothing happens when I try to create it.

    I only get an empty screen after I try to create the character.

    Any ideas on what could be missing?

    Click image for larger version. 

Name:	2021-03-11 14_56_53-MU.jpg 
Views:	60 
Size:	83.4 KB 
ID:	169330Click image for larger version. 

Name:	2021-03-11 14_57_01-MU.jpg 
Views:	59 
Size:	281.8 KB 
ID:	169331

    Used account:
    user / 123456

    Database:
    -DB-exported-2021.03.11-15.01-v3.rar
    Into mu_online_game.character_base
    "race";"strength";"agility";"vitality";"energy";"leadership";"life";"mana";"life_per_level";"mana_per_level";"life_per_vitality";"mana_per_energy";"world";"level";"points";"recovery_life";"recovery_mana";"recovery_shield";"recovery_stamina";"points_levelup";"points_levelup_plus";"points_levelup_master";"points_levelup_majestic"
    1;50;50;50;50;0;500;500;15.0;15.0;15.0;15.0;1;1;50;15.0;15.0;15.0;15.0;15;15;15;15
    I know that this is wrong values

    Current progress:
    Can login
    Can create character
    Can enter world
    Cant move
    Chat working

    Looking...
    @dudusiao your character can move?
    2021-03-11_15:58:48 INFO [ SERVER MOVE REQUEST ] [SRV 0 -- 1500 - IP: 192.168.1.60 - MAC: B4:2E:99:C7:D5:A3 - Account: 1-user - Character: 1-test] --- Server: 65535 [1 - 0/0]
    2021-03-11_15:58:48 INFO [ SERVER MOVE ERROR 2 ] [SRV 0 -- 1500 - IP: 192.168.1.60 - MAC: B4:2E:99:C7:D5:A3 - Account: 1-user - Character: 1-test] --- Server: 65535 [1 - 0/0]
    Last edited by Sam3000; 11-03-21 at 01:14 PM.



Advertisement