[Release] Legend.mu client & server source code S16 1.1

Page 9 of 44 FirstFirst 123456789101112131415161719 ... LastLast
Results 121 to 135 of 654
  1. #121
    Ultimate Member Sam3000 is offline
    MemberRank
    Oct 2007 Join Date
    MoscowLocation
    186Posts

    Re: [Release] Legend.mu client & server source code S16 1.1

    Quote Originally Posted by cualquier1 View Post
    I've the next error, i compiled it with Visual Studio 2019 but using Platform Toolset Visual Studio 2013 (v120)



    https://ibb.co/YXxjgfW
    Read thread, you need to change some in code: http://forum.ragezone.com/f197/relea...0/#post9069370
    Anyway, if you have some knowledge of c++ you can fix it by yourself

  2. #122
    0x4D696E68 myheart is online now
    True MemberRank
    Jun 2017 Join Date
    349Posts

    Re: [Release] Legend.mu client & server source code S16 1.1

    Quote Originally Posted by metallica View Post
    I tried to use full client of legend.mu + main.dll compiled by Jorge2016 from tuservermu and doesnt work
    I tried to use full client of legend.mu + main.exe (from @myheart) + main.dll compiled by Jorge2016 from tuservermu and doesnt work

    In both cases the main doesnt open

    How we can connect to our local server to continue working and fix some problems that we could have when we try to connect to 127.0.0.1?

    Srry If I ask some "newbie" questions, I'm web developer, it's my first time with C++/ mains/dlls compiled.. and a lot of new stuffs :P
    use this client: https://drive.google.com/file/d/1mZd..._F7RUwNOleOmUI
    and change IpAddress in Offset.h from the mesosa source

  3. #123
    Ultimate Member Sam3000 is offline
    MemberRank
    Oct 2007 Join Date
    MoscowLocation
    186Posts

    Re: [Release] Legend.mu client & server source code S16 1.1

    Quote Originally Posted by metallica View Post


    Boost_1_55_0 on windows10 64bits
    What version of VS you have installed? I didnt wanted to bother with console error when compiling boost 1.55 with vs2019, after i was getting errors with server. So i used newest version.

    It's seems that 1.55 boost doesnt know about my vs2019 or newest version from 2013 year and cant get proper tool set

    So you can find some workarounds:
    1) use mingw compiler
    2) change end-of-line symbol
    3) use some other hacks in .bat
    4) try boost 1.54
    That i found when googling

    - - - Updated - - -

    Quote Originally Posted by myheart View Post
    since Webzen switched to use themida, some people can't hooking dll. so i leave hooked main 1.19.46 here:
    https://mega.nz/file/3BsDEQoY#VqNc5I...BFWGqIm5zVAaA4
    Btw, its unpacked now?

    - - - Updated - - -

    Quote Originally Posted by metallica View Post
    I tried to use full client of legend.mu + main.dll compiled by Jorge2016 from tuservermu and doesnt work
    I tried to use full client of legend.mu + main.exe (from @myheart) + main.dll compiled by Jorge2016 from tuservermu and doesnt work

    In both cases the main doesnt open

    How we can connect to our local server to continue working and fix some problems that we could have when we try to connect to 127.0.0.1?

    Srry If I ask some "newbie" questions, I'm web developer, it's my first time with C++/ mains/dlls compiled.. and a lot of new stuffs :P
    Mine main.dll + main from @myheart is working, but i'm getting disconnected from server...

    - - - Updated - - -

    Code:
    ###### Log Begin ######
    -------------------------------------------------------------------------------------
    Mu online 1.19Ћ (Kor) executed. (1.19.46.0)
    2021/03/10 10:31
    ------------------------------------------------------------------------------------
    > To read config.ini.
    > gg init success.
    -------------------------------------------------------------------------------------
    > Screen size = 800 x 600.
    > Start window success.
    > OpenGL init success.
    -------------------------------------------------------------------------------------
    CGFxMBoxShop Not Found Model : 6174
    > Loading ok.
    [Connect to Server] ip address = 127.0.0.1, port = 44405
    Failed to connect. 
    2021/03/10 10:31
    [Send Packet Error] WSAGetLastError() != WSAEWOULDBLOCK
    [Socket Closed][Clear PacketQueue]
    [Socket Closed][Clear PacketQueue]
    > Login Scene init success.
    Destroy
    So, it's kinda working but getting disconnect. Will check port

    - - - Updated - - -

    Anyone who need muerror.log decrypt, use https://github.com/navossoc/MuError or http://forum.ragezone.com/f197/xor-d...or-log-717452/

    - - - Updated - - -

    https://mega.nz/file/geRSRDKR#kVRoBa..._N5Tx7L9kGXXD0
    My main.exe (from @myheart) and compiled main.dll by me.
    Last edited by Sam3000; 10-03-21 at 08:20 AM.

  4. #124
    Hardcore Member Pyke is offline
    MemberRank
    Sep 2007 Join Date
    PolandLocation
    104Posts

    Re: [Release] Legend.mu client & server source code S16 1.1

    I have same, all good but when main is load than it disconnect.
    Maybe some ports in config server side or its problem main?

  5. #125
    Ultimate Member Sam3000 is offline
    MemberRank
    Oct 2007 Join Date
    MoscowLocation
    186Posts

    Re: [Release] Legend.mu client & server source code S16 1.1

    Quote Originally Posted by Pyke View Post
    I have same, all good but when main is load than it disconnect.
    Maybe some ports in config server side or its problem main?
    I think server side we can check with any client, ConnectServer will get proper error in log or console.

    - - - Updated - - -

    Click image for larger version. 

Name:	photo_2021-03-10_14-55-48.jpg 
Views:	81 
Size:	5.5 KB 
ID:	169316
    And it's working, tested with 0.75 client, so main.exe + main.dll have wrong offsets i think

  6. #126
    Hardcore Member mesosa is offline
    MemberRank
    Aug 2010 Join Date
    138Posts

    Re: [Release] Legend.mu client & server source code S16 1.1

    There are some logs like "crashlog" that are useless.

    They were created for a purpose that we never finished.

    - - - Updated - - -

    This server does not require a specific client version.

    Just need to be sure that packets are the same for some features.

  7. #127
    Ultimate Member Sam3000 is offline
    MemberRank
    Oct 2007 Join Date
    MoscowLocation
    186Posts

    Re: [Release] Legend.mu client & server source code S16 1.1

    Quote Originally Posted by mesosa View Post
    There are some logs like "crashlog" that are useless.

    They were created for a purpose that we never finished.

    - - - Updated - - -

    This server does not require a specific client version.

    Just need to be sure that packets are the same for some features.
    Thx for reply, but i still dont know how to fix main.
    Mine cant connect to 127.0.0.1:44405

  8. #128
    Registered dudusiao is offline
    MemberRank
    Dec 2020 Join Date
    12Posts

    Re: [Release] Legend.mu client & server source code S16 1.1

    you need to set GameServer.Active to 1 in settings table (mu_online_game) and flag to 1 in server_list table (mu_online_login)

    also, i edited ServerList.bmd for server code 0 (original doesn't have entry for code 0).


  9. #129
    Member ispyder is offline
    MemberRank
    Aug 2015 Join Date
    75Posts

    Re: [Release] Legend.mu client & server source code S16 1.1

    Quote Originally Posted by dudusiao View Post
    also, i edited ServerList.bmd for server code 0 (original doesn't have entry for code 0).
    What Editor did you use to edit ServerList.bmd?

    I only have some older versions (for Season 8) and they don't seem to be able to decode the BMD of this client

    Edit:
    I found this editor MuEditor 1.9.25.zip:
    - http://forum.ragezone.com/f197/relea...r-eng-1148757/

    And updated the file using:
    - BMD Files -> ServerList.bmd -> S10

    Now I can see the Server but I get disconnected when trying to connect.

    Click image for larger version. 

Name:	2021-03-10 18_34_13-MU.png 
Views:	78 
Size:	554.4 KB 
ID:	169320

    Note:
    I have added my local IP: 192.168.1.150 in Offset.h.
    No updates for: ClientVersion and ClientSerial

    If I use 127.0.0.1 I get disconnected when I open main.exe and the Servers List is not displayed and I get this MuError.log:
    GFxMBoxShop Not Found Model : 6174> Loading ok.
    [Connect to Server] ip address = 127.0.0.1, port = 44405
    Failed to connect. 2021/03/10 18:40
    [Send Packet Error] WSAGetLastError() != WSAEWOULDBLOCK
    [Socket Closed][Clear PacketQueue]
    [Socket Closed][Clear PacketQueue]
    > Login Scene init success.
    Destroy
    Click image for larger version. 

Name:	2021-03-10 18_41_09-Main 2008 - Microsoft Visual Studio.png 
Views:	88 
Size:	17.8 KB 
ID:	169321

    ConnectServer log:
    ProtocolCore: C1,04,F4,06,
    ProtocolCore: C1,06,F4,03,00,00,
    MuError.log (with my local IP: 192.168.1.150)
    (decoded with: http://forum.ragezone.com/f197/xor-d...or-log-717452/)
    CGFxMBoxShop Not Found Model : 6174> Loading ok.
    [Connect to Server] ip address = 192.168.1.150, port = 44405
    > Login Scene init success.
    Send Request Server List.
    Success Receive Server List.
    Success Receive Server List.
    [ReceiveServerConnect][Socket Closed][Clear PacketQueue]
    [Connect to Server] ip address = 192.168.1.150, port = 55509
    ¼­¹ö¿ÍÀÇ Á¢¼ÓÁ¾·á.
    [Socket Closed][Clear PacketQueue]
    [Socket Closed][Clear PacketQueue]
    Destroy
    ##########

    Also, I didn't compile the older version of Boost and I just downloaded the latest compiled version for Boost 1.75.0 - MSVC 14.2 (32 bit) to use with the latest Visual Studio (2019) and C++17:
    - https://sourceforge.net/projects/boo...2.exe/download

    The problem with that is that in the latest version of Boost the boost::asio::io_service got deprecated and replaced by boost::asio::io_context (https://github.com/boostorg/asio/issues/110).

    I just want the server to start so I just blindly replaced io_service with io_context but I don't know if that replacement is the only necessary change related to this io_service deprecated API.

    Anyway, here's a temporary patch to compile the project and get to see the Servers List:
    - diff_c++17_io_context.txt

    The patch can be applied on the Teleport & Gates commit:
    - https://github.com/DimensionGamers/Lgd-Server/commit/793e6e44b008032a8288d822ddde08649a83a41c

    Here's the complete DB I exported. Use only for fast-testing and don't rely on it since this is a mix of everything that was posted in this thread:
    - DB-exported-2021.03.10-19.09-v1.zip

    ServerList.bmd with the first server (Legend x50) set to ID 0:
    - serverlist.zip

    Used client:
    - Handrey04 - Full Client (TEST) - http://forum.ragezone.com/f197/relea...1/#post9068930

    Used main.exe: (without this main nothing happened on execution)
    - posted by myheart
    - http://forum.ragezone.com/f197/relea...ml#post9070569
    - https://mega.nz/file/3BsDEQoY#VqNc5I...BFWGqIm5zVAaA4

    Tools: (posted by solarismu):
    - http://forum.ragezone.com/f197/relea...ml#post9070542
    - https://github.com/VD1988/MuClientTools

    Note:
    - WampServer can be used as the MySQL server - https://sourceforge.net/projects/wam...6.exe/download
    - MySQL Workbench can be used to edit the database - https://dev.mysql.com/downloads/workbench/

    To also update the version of MySQL, copy
    FROM:
    C:\wamp32\bin\mysql\mysql5.7.31\include
    TO:
    Lgd-Server-git\Dependencies\MySQL\include

    FROM:
    C:\wamp32\bin\mysql\mysql5.7.31\lib
    TO:
    Lgd-Server-git\Libraries
    and
    the MySQL DLL TO: Lgd-Server-git\Release
    Last edited by ispyder; 12-03-21 at 01:35 PM.

  10. #130
    Registered dudusiao is offline
    MemberRank
    Dec 2020 Join Date
    12Posts

    Re: [Release] Legend.mu client & server source code S16 1.1

    got login window :D


    to connect, you need to set (in settings table, mu_online_game):

    Account.ConnectCheckTime - 180
    GameServer.Serial -> same as serial in Offset.h (main.dll source)
    GameServer.Version -> same as version in Offset.h (main.dll source)
    Network.MaxConnectionPerIP - must be higher than 0

    also, u need to copy EncDec key (or set your own) in PacketEncDec.h (main.dll source) and EncDec.h (server source) (key_1 and key_2 arrays)

  11. #131
    Ultimate Member Sam3000 is offline
    MemberRank
    Oct 2007 Join Date
    MoscowLocation
    186Posts

    Re: [Release] Legend.mu client & server source code S16 1.1

    Nice guys, will try later when get home

  12. #132
    Member ispyder is offline
    MemberRank
    Aug 2015 Join Date
    75Posts

    Re: [Release] Legend.mu client & server source code S16 1.1

    Quote Originally Posted by dudusiao View Post
    got login window :D
    to connect, you need to set (in settings table, mu_online_game):

    Account.ConnectCheckTime - 180
    Can you export your complete database? Because mine is really trashed and I got missing tables. At the moment there's too many posts with incomplete and different tables. We need an export that works.

  13. #133
    Ultimate Member Sam3000 is offline
    MemberRank
    Oct 2007 Join Date
    MoscowLocation
    186Posts

    Re: [Release] Legend.mu client & server source code S16 1.1

    Quote Originally Posted by ispyder View Post
    Can you export your complete database? Because mine is really trashed and I got missing tables. At the moment there's too many posts with incomplete and different tables. We need an export that works.
    I will post working today later, full db

  14. #134
    Member ispyder is offline
    MemberRank
    Aug 2015 Join Date
    75Posts

    Re: [Release] Legend.mu client & server source code S16 1.1

    Quote Originally Posted by dudusiao View Post
    got login window :D

    to connect, you need to set (in settings table, mu_online_game):

    Account.ConnectCheckTime - 180
    GameServer.Serial -> same as serial in Offset.h (main.dll source)
    GameServer.Version -> same as version in Offset.h (main.dll source)
    Network.MaxConnectionPerIP - must be higher than 0

    also, u need to copy EncDec key (or set your own) in PacketEncDec.h (main.dll source) and EncDec.h (server source) (key_1 and key_2 arrays)
    I confirm this works.

    Updated database:
    - DB-exported-2021.03.10-20.06-v2.rar

    The entries in the database were updated to:
    static const char ClientVersion[8] = "1.07.17";
    static const char ClientSerial[17] = "jw45af7xf4wxj198";
    Update the Client PacketEncDec.h with the values from the Server EncDec.h
    static const uint8 key_1[MAX_KEY_1] = { 0x75, 0x99, 0x5C, 0xBA, 0x44, 0x2C, 0x87, 0x66 };
    static const uint8 key_2[MAX_KEY_2] = { 0xF3, 0xB3, 0x64, 0x36, 0xBE, 0xF6, 0x52, 0x01 };

    static const uint8 key_final[MAX_KEY_1][MAX_KEY_2] =
    {
    0x22, 0x8F, 0x3B, 0x0A, 0x8E, 0x6A, 0x51, 0x32,
    0xBA, 0xCC, 0xAA, 0xBF, 0xFB, 0x54, 0x24, 0x47,
    0x00, 0xA1, 0x21, 0x02, 0x02, 0x21, 0xAB, 0x9F,
    0xFE, 0x3A, 0xB0, 0x86, 0xBA, 0xAF, 0x34, 0x55,
    0xCB, 0x63, 0x8D, 0xEA, 0x56, 0xE8, 0x51, 0x29,
    0x7D, 0x2B, 0x5F, 0xC3, 0xB1, 0xE9, 0x8A, 0xFB,
    0xBC, 0x89, 0x9F, 0xB2, 0xE7, 0x23, 0xA8, 0x3A,
    0x6D, 0xFF, 0x5C, 0x58, 0x8B, 0x25, 0xAF, 0x62
    };

  15. #135
    Hardcore Member Pyke is offline
    MemberRank
    Sep 2007 Join Date
    PolandLocation
    104Posts

    Re: [Release] Legend.mu client & server source code S16 1.1

    Working, but after trying to connect to our account get disconnect.



Advertisement