¤ The Complete PW Package ¤

Page 315 of 318 FirstFirst ... 215265305307308309310311312313314315316317318 LastLast
Results 4,711 to 4,725 of 4769
  1. #4711
    Registered allserver2013 is offline
    MemberRank
    Apr 2021 Join Date
    22Posts

    Re: ¤ The Complete PW Package ¤

    Quote Originally Posted by 343 View Post
    Sorry for the delay, but as you'll soon see - I've been BUSY ..!



    - - - Updated - - -

    --add--

    Coming SOON™

    Torrent, and an update to my HTTrack of pwdatabase and ecatomb..!

    im always checking this post for the updates. lol

  2. #4712
    Account Upgraded | Title Enabled! Wrechid is offline
    True MemberRank
    Jan 2017 Join Date
    EMPTYLocation
    320Posts

    Re: ¤ The Complete PW Package ¤

    Quote Originally Posted by SrlyBeeto View Post
    Mega links are all offline. Cant get the client. the server files i got already. could anyone report a valir DL link for the 155 client? tysm
    To my knowledge there wasn't an official English client found with v156 elements... But you can use this one, I've been using as a base for quite some time now, and it's clean... I just posted the needed files to make it work...

    LINK
    This FORUM is poorly run, and suks...

  3. #4713
    Registered SrlyBeeto is offline
    MemberRank
    Apr 2021 Join Date
    13Posts

    Re: ¤ The Complete PW Package ¤

    Quote Originally Posted by 343 View Post
    Sorry for the delay, but as you'll soon see - I've been BUSY ..!



    - - - Updated - - -

    --add--

    Coming SOON™

    Torrent, and an update to my HTTrack of pwdatabase and ecatomb..!
    We should be the ones asking sorry..
    Take your time and thank you for all hard work on making this amazing gift for the community.
    I met my wife in pwi 10 years ago so for our anniversary i want to put up this server so we can have some fun.
    Hope i can make it work hehe

  4. #4714
    Psy Sins Psytrac is online now
    Alpha MaleRank
    Jul 2011 Join Date
    Hammond, INLocation
    1,872Posts

    Re: ¤ The Complete PW Package ¤

    Quote Originally Posted by Wrechid View Post
    To my knowledge there wasn't an official English client found with v156 elements...
    There is an official 156 elements client, but the build number on the client is wrong (in order to use it you would need to bypass the version check, it's not for inexperienced people)

  5. #4715
    Account Upgraded | Title Enabled! Wrechid is offline
    True MemberRank
    Jan 2017 Join Date
    EMPTYLocation
    320Posts

    Re: ¤ The Complete PW Package ¤

    Quote Originally Posted by Psytrac View Post
    There is an official 156 elements client, but the build number on the client is wrong (in order to use it you would need to bypass the version check, it's not for inexperienced people)
    got a link to a clean copy...?
    This FORUM is poorly run, and suks...

  6. #4716
    Registered allserver2013 is offline
    MemberRank
    Apr 2021 Join Date
    22Posts

    Re: ¤ The Complete PW Package ¤

    can we use the 1.5.7 client? my goal is to have this neverfall login. thank you. and how to do it?

  7. #4717
    Psy Sins Psytrac is online now
    Alpha MaleRank
    Jul 2011 Join Date
    Hammond, INLocation
    1,872Posts

    Re: ¤ The Complete PW Package ¤

    Quote Originally Posted by Wrechid View Post
    got a link to a clean copy...?
    not really, but got about as clean as you're going to find in a 7z on my pc

  8. #4718
    Registered Nigel728 is offline
    MemberRank
    Mar 2021 Join Date
    5Posts

    Re: ¤ The Complete PW Package ¤

    I did some poking about the MySQL DB, mostly for my own curiosity, can connect to this using JDBC and see the table list, see lists of users and so on no problem. Except that's not really the stuff I was looking for. Saw a list of tables like - auction, city, equipment, friends, and so on and after some more poking around, it seems those "tables" are managed by the gamedbd daemon and aren't MySQL tables at all. Presumably they're in some internal format and would not be wise to try to alter them directly. So then my question is, can we directly communicate with gamedbd with some kind of API to read/update the tables?

  9. #4719
    Psy Sins Psytrac is online now
    Alpha MaleRank
    Jul 2011 Join Date
    Hammond, INLocation
    1,872Posts

    Re: ¤ The Complete PW Package ¤

    Quote Originally Posted by Nigel728 View Post
    I did some poking about the MySQL DB, mostly for my own curiosity, can connect to this using JDBC and see the table list, see lists of users and so on no problem. Except that's not really the stuff I was looking for. Saw a list of tables like - auction, city, equipment, friends, and so on and after some more poking around, it seems those "tables" are managed by the gamedbd daemon and aren't MySQL tables at all. Presumably they're in some internal format and would not be wise to try to alter them directly. So then my question is, can we directly communicate with gamedbd with some kind of API to read/update the tables?
    we used to be able to it seems, look at the old 1.3.6 release and pwAdmin and you'll see what had functions back then, but I know of nothing that works directly now (I believe Wrechid released something, but I haven't tested it)

    - - - Updated - - -

    Quote Originally Posted by Wrechid View Post
    got a link to a clean copy...?
    Link now dead

    https://send.vis.ee/download/700b0d5...cLI8WWAPBZazZw

    someone else mirror it, I'm putting this into the wild, not maintaining the link
    Last edited by Psytrac; 5 Days Ago at 02:01 AM.

  10. #4720
    Omega 343 is offline
    The OmegaRank
    Oct 2009 Join Date
    Ancient DGN CTYLocation
    5,485Posts

    Re: ¤ The Complete PW Package ¤

    The more I have been thinking about it, the more I want to 'future proof' this release too (especially since/if this winds up being my last release/update)!

    So, the segmentation fault errors that Ubuntu 12.04.3 is causing in Win10 and/or VMware 16 environments does have me (overall) concerned about this..! So, moving forward I am going to look into a version that will not seg fault under a Win10/VMware16 - but is also already EOL...

    My thoughts behind this are, if I just update to "the latest and greatest" or to *anything* that's currently still "supported" (in ANY way [including ESM]) - they could change something, at any point, that would cause it and or this package to no longer work! So, my thoughts/hopes are that a fully EOL version of Ubuntu server, that doesn't already currently incur a segmentation fault on Win10/VMware16, may be the most solid choice to go with for said "future proofing"... Because if/since it's already EOL, they will NOT be changing anything about it moving forward... So, at least in theory, that would mean that version combined with this package could (again in theory) work "forever"... And that's what I want, I would like for this release package to still be able to function 100 or even 1000 years from now (even if they have to go back to Win7 or Win10 too)..!

    So, all that being said I have already begun my research on which version of Ubuntu I should "require" and use in/for/with this package release..! So far most of my homework has been reading and studying this page ~ https://wiki.ubuntu.com/Releases Which, if I'm reading it correctly, they actually EOL'd 12.04.3 in 2014..! As where even the "base" 12.04 (12.04.0) received support until EOL in 2017..! Also, it looks as though 12.04.5 is actually still "supported" (in "ESM") as well..!

    So, my current thoughts are switching the "requirement" to be for Ubuntu 12.04 x64 - instead of 12.04.3..! I am currently testing some of the things that I can test to assure I can switch this over from 12.04.3 to base 12.04 (12.04.0)... However, I CANNOT test to see if 12.04.0 gets a seg fault when installing on Win10/VMware16 since I do not have either...

    So, if someone could please let me know if Ubuntu 12.04 (12.04.0) gets the segmentation fault on Win10/VMware16 (like 12.04.3 does) ~ I would GREATLY appreciate it..!

    http://old-releases.ubuntu.com/relea...rver-amd64.iso

    https://www.vmware.com/go/getworkstation-win

    ¤ My Public Releases ¤




  11. #4721
    Hardcore Member lordmegamanx72 is offline
    MemberRank
    Mar 2014 Join Date
    121Posts

    Re: ¤ The Complete PW Package ¤

    Linux support is only persuaded by the support of it is industry and warranty of service. It has nothing to do with comparability across versions and editions. You can still install the packages offline if you are not using a distro officiated downloader like apt-get. Just use the linux OS with the supported comparability and kernel package. I like always the shortcut. Instead of changing the OS version over and over. Just provide the required packages to install on the provided OS by you. That way your support of your release can have a lifetime run. Windows 10 is unnecessary as well. If you notice the whole lot of Operating systems now are taking the path of closed platforms like consoles. Sooner or later, Jailbreak over operating systems will become a thing like on Android platform.

  12. #4722
    Registered SrlyBeeto is offline
    MemberRank
    Apr 2021 Join Date
    13Posts

    Re: ¤ The Complete PW Package ¤

    Quote Originally Posted by 343 View Post
    The more I have been thinking about it, the more I want to 'future proof' this release too (especially since/if this winds up being my last release/update)!

    So, the segmentation fault errors that Ubuntu 12.04.3 is causing in Win10 and/or VMware 16 environments does have me (overall) concerned about this..! So, moving forward I am going to look into a version that will not seg fault under a Win10/VMware16 - but is also already EOL...

    My thoughts behind this are, if I just update to "the latest and greatest" or to *anything* that's currently still "supported" (in ANY way [including ESM]) - they could change something, at any point, that would cause it and or this package to no longer work! So, my thoughts/hopes are that a fully EOL version of Ubuntu server, that doesn't already currently incur a segmentation fault on Win10/VMware16, may be the most solid choice to go with for said "future proofing"... Because if/since it's already EOL, they will NOT be changing anything about it moving forward... So, at least in theory, that would mean that version combined with this package could (again in theory) work "forever"... And that's what I want, I would like for this release package to still be able to function 100 or even 1000 years from now (even if they have to go back to Win7 or Win10 too)..!

    So, all that being said I have already begun my research on which version of Ubuntu I should "require" and use in/for/with this package release..! So far most of my homework has been reading and studying this page ~ https://wiki.ubuntu.com/Releases Which, if I'm reading it correctly, they actually EOL'd 12.04.3 in 2014..! As where even the "base" 12.04 (12.04.0) received support until EOL in 2017..! Also, it looks as though 12.04.5 is actually still "supported" (in "ESM") as well..!

    So, my current thoughts are switching the "requirement" to be for Ubuntu 12.04 x64 - instead of 12.04.3..! I am currently testing some of the things that I can test to assure I can switch this over from 12.04.3 to base 12.04 (12.04.0)... However, I CANNOT test to see if 12.04.0 gets a seg fault when installing on Win10/VMware16 since I do not have either...

    So, if someone could please let me know if Ubuntu 12.04 (12.04.0) gets the segmentation fault on Win10/VMware16 (like 12.04.3 does) ~ I would GREATLY appreciate it..!

    http://old-releases.ubuntu.com/relea...rver-amd64.iso

    https://www.vmware.com/go/getworkstation-win

    I have Win 10 and i'm downloading both links now.
    Will let you know as soon ubuntu finishes DL... is taking forever.

    Thank you

  13. #4723
    Omega 343 is offline
    The OmegaRank
    Oct 2009 Join Date
    Ancient DGN CTYLocation
    5,485Posts

    Re: ¤ The Complete PW Package ¤

    Quote Originally Posted by lordmegamanx72 View Post
    Linux support is only persuaded by the support of it is industry and warranty of service. It has nothing to do with comparability across versions and editions. You can still install the packages offline if you are not using a distro officiated downloader like apt-get. Just use the linux OS with the supported comparability and kernel package. I like always the shortcut. Instead of changing the OS version over and over. Just provide the required packages to install on the provided OS by you. That way your support of your release can have a lifetime run. Windows 10 is unnecessary as well. If you notice the whole lot of Operating systems now are taking the path of closed platforms like consoles. Sooner or later, Jailbreak over operating systems will become a thing like on Android platform.
    Let me preface by saying: I think I "get" what you're saying, I think...

    But I've been between a rock and a hard spot with the "requirements" of this package all along because it's not even meant for Windows anything in the first place; well the client is of course, but the server is NOT... The server is MEANT to be installed on ACTUAL linux, not a VM... BUT I also know, or maybe just assume? That most people downloading this will not have a spare machine (let alone an actual server machine) to run it on, and are most likely downloading it to "play around" (AKA "mess around")... Maybe even made a server that their family/friends will play on; but will likely never run a server that will see numbers in the thousands..!

    All that being said, the ONLY reason this package "requires" a specific OS: Ubuntu 12.04.3 x64 - is because of the offline install it does of IA32-LIBS..! I do want the "base package" to have absolutely ZERO external dependencies - ergo, can be installed with absolutely no interwebs connection whatsoever

    That being said I often say "requires" specifically in quotes because obviously anyone with enough experience will know how to make it work with ANY OS of their choice... While the default installer I've made does "require" what it requires, there are plenty of ways around this - some I've even built in (for those who care to look)! So, could you take this and manually install it on Ubuntu 20.x, sure... Could you take it and install it on CentOS, or RH, or FC, - I'm almost sure of it... If you want to, and (actually) know what you're doing...

    I'm thinking that will not be most people that download this...

    At one point I thought about going down the path of making it a "real" .DEB; but then I urged myself against that because I figured why limit it to DEBIAN based distros!? For the same reason I wouldn't have considered making it an .RPM either...!

    But for the most basic of use (and users) I have to "require" what I have to "require" in order to facilitate an installation which is 100% "self sufficient"! That, as long as you have the "required" OS (ISO) and this package (ISOs) and a PC, you can and will succeed at getting it installed. Even if the interwebs blew up tomorrow and ceased to exist, or if you were on an island with a laptop and a solar generator ROFL... Or whatever scenario you could dream up (that's never even going to happen in the first place)... But, point being = it has NO/ZERO external dependencies

    So, back to point - I think LOL; sure, Ubuntu x64 12.04.3 would continue to "do the job" if actually installing it on a physical machine (like a server)! Which is what this SHOULD be, but I also DO have to "cater" (to some degree) to those which I know will not "do things 'right'" whether by choice, or limitation...

    So I do suppose for the actual longevity moving forward; I can supply Ubuntu 12.04 LTS x64, this package, and at some point I may find myself having to add an ISO for Win7 / Win10 for the client, and for those who actually WANT (again, for whatever reason, choice or hardware/financial limitation) to also run the Server in a VM with a Win host...

    So, IDK if that all even made any sense, but I know what I'm thinking LOL I guess to TL;DR would be; yes, there's NO reason for "compatibility" between Win and Linux (and VMs)... BUT; I also know/figure that is how MOST people that DL this are actually gonna use it! So while I cannot assure 100% compatibility - I will still do my best to make sure my package/release is as versatile as humanly possible..!

    ¤ My Public Releases ¤




  14. #4724
    Registered SrlyBeeto is offline
    MemberRank
    Apr 2021 Join Date
    13Posts

    Re: ¤ The Complete PW Package ¤

    Quote Originally Posted by 343 View Post
    The more I have been thinking about it, the more I want to 'future proof' this release too (especially since/if this winds up being my last release/update)!

    So, the segmentation fault errors that Ubuntu 12.04.3 is causing in Win10 and/or VMware 16 environments does have me (overall) concerned about this..! So, moving forward I am going to look into a version that will not seg fault under a Win10/VMware16 - but is also already EOL...

    My thoughts behind this are, if I just update to "the latest and greatest" or to *anything* that's currently still "supported" (in ANY way [including ESM]) - they could change something, at any point, that would cause it and or this package to no longer work! So, my thoughts/hopes are that a fully EOL version of Ubuntu server, that doesn't already currently incur a segmentation fault on Win10/VMware16, may be the most solid choice to go with for said "future proofing"... Because if/since it's already EOL, they will NOT be changing anything about it moving forward... So, at least in theory, that would mean that version combined with this package could (again in theory) work "forever"... And that's what I want, I would like for this release package to still be able to function 100 or even 1000 years from now (even if they have to go back to Win7 or Win10 too)..!

    So, all that being said I have already begun my research on which version of Ubuntu I should "require" and use in/for/with this package release..! So far most of my homework has been reading and studying this page ~ https://wiki.ubuntu.com/Releases Which, if I'm reading it correctly, they actually EOL'd 12.04.3 in 2014..! As where even the "base" 12.04 (12.04.0) received support until EOL in 2017..! Also, it looks as though 12.04.5 is actually still "supported" (in "ESM") as well..!

    So, my current thoughts are switching the "requirement" to be for Ubuntu 12.04 x64 - instead of 12.04.3..! I am currently testing some of the things that I can test to assure I can switch this over from 12.04.3 to base 12.04 (12.04.0)... However, I CANNOT test to see if 12.04.0 gets a seg fault when installing on Win10/VMware16 since I do not have either...

    So, if someone could please let me know if Ubuntu 12.04 (12.04.0) gets the segmentation fault on Win10/VMware16 (like 12.04.3 does) ~ I would GREATLY appreciate it..!

    http://old-releases.ubuntu.com/relea...rver-amd64.iso

    https://www.vmware.com/go/getworkstation-win


    Took 1h to DL ubuntu, idk why, but, here it installed without any issue.
    Lemme know If you need further help.

    :)



    - - - Updated - - -

    IDk if helps but my system is:

    Ryzen 5 3500,
    16gb, gtx 1070
    Win 10 pro

  15. #4725
    Psy Sins Psytrac is online now
    Alpha MaleRank
    Jul 2011 Join Date
    Hammond, INLocation
    1,872Posts

    Re: ¤ The Complete PW Package ¤

    donno why 343 posted that openly when he privately contacted me to do the same thing, it's been confirmed to work on VMware player 16 on win 10 as well



Advertisement