[VS22] v19.2

Page 4 of 8 FirstFirst 12345678 LastLast
Results 46 to 60 of 107
  1. #46
    ‎‎‎‎ Ketchup is offline
    ModeratorRank
    Jan 2009 Join Date
    New YorkLocation
    2,926Posts
    Quote Originally Posted by cognitivedesign View Post
    What security risk does deleting a character create? Been trying to think of what would have an issue and I cant lol.
    Character deletion dupe.

  2. #47
    Enthusiast Bradix0805 is offline
    MemberRank
    Apr 2022 Join Date
    37Posts
    duplication of items. I believe.

  3. #48
    Valued Member MakVee is offline
    MemberRank
    Mar 2021 Join Date
    MarsLocation
    143Posts
    Can anyone help me about this CClientSocket.Fetch error
    Code:
    2022/11/18   23:40:26   CClientSocket.Fetch: ip = 188.61.253.14, size = 790647882
    This error always show up after few hours after the server starts in VPS.
    and suddenly a crash will happen in the program it's either coreserver,accountserver,databaseserver,cert etc etc..

    I implemented __SECURITY_FIXES and some __GAMEGUARD fixes.
    And add some features with the database implementation like:
    Code:
    __BATTLEPASS
    __OFFLINE_VENDOR
    __SWITCH_EQUIP
    And i change and setup all ports to this and add it into firewall just like the screenshot below:


    I read some thread regarding this CClientSocket.Fetch Error Issues in the other forum or even here in ragezone but the only posible problem they say is:
    [code]
    Possible problems:

    - Packet encryption
    - You try to send corrupted packets.
    - Someone took his hands on the CAr buffer
    - And last is about netcode thing i really don't have idea about it.
    Last edited by Ketchup; 18-11-22 at 06:30 PM.

  4. #49
    ‎‎‎‎ Ketchup is offline
    ModeratorRank
    Jan 2009 Join Date
    New YorkLocation
    2,926Posts
    Quote Originally Posted by MakVee View Post
    Can anyone help me about this CClientSocket.Fetch error
    Code:
    2022/11/18   23:40:26   CClientSocket.Fetch: ip = 188.61.253.14, size = 790647882
    This error always show up after few hours after the server starts in VPS.
    and suddenly a crash will happen in the program it's either coreserver,accountserver,databaseserver,cert etc etc..

    I implemented __SECURITY_FIXES and some __GAMEGUARD fixes.
    And add some features with the database implementation like:
    Code:
    __BATTLEPASS
    __OFFLINE_VENDOR
    __SWITCH_EQUIP
    And i change and setup all ports to this and add it into firewall just like the screenshot below:


    I read some thread regarding this CClientSocket.Fetch Error Issues in the other forum or even here in ragezone but the only posible problem they say is:
    [code]
    Possible problems:

    - Packet encryption
    - You try to send corrupted packets.
    - Someone took his hands on the CAr buffer
    - And last is about netcode thing i really don't have idea about it.
    This has nothing to do with systems implemented by you and everything to do with port scanning. This has been said now on multiple sites and told to you multiple times. Change your ports, setup and secure your vps correctly OR change to the V21.2 network code.

    You should also learn to debug and see where problems come from so they can be fixed.

    The files your trying to bribe people to fix this for you are already public and on this forum btw:
    https://forum.ragezone.com/f457/mark...theme-1191641/

    And the post of your all.h is from guru and not from my files.

    So you should be posting your query there not here.
    Last edited by Ketchup; 18-11-22 at 06:35 PM.

  5. #50
    I ❤️ Shawarma Percuflex is offline
    MemberRank
    Jan 2020 Join Date
    IsraelLocation
    253Posts
    Quote Originally Posted by MakVee View Post
    Can anyone help me about this CClientSocket.Fetch error
    Code:
    2022/11/18   23:40:26   CClientSocket.Fetch: ip = 188.61.253.14, size = 790647882
    This error always show up after few hours after the server starts in VPS.
    and suddenly a crash will happen in the program it's either coreserver,accountserver,databaseserver,cert etc etc..

    I implemented __SECURITY_FIXES and some __GAMEGUARD fixes.
    And add some features with the database implementation like:
    Code:
    __BATTLEPASS
    __OFFLINE_VENDOR
    __SWITCH_EQUIP
    And i change and setup all ports to this and add it into firewall just like the screenshot below:


    I read some thread regarding this CClientSocket.Fetch Error Issues in the other forum or even here in ragezone but the only posible problem they say is:
    [code]
    Possible problems:

    - Packet encryption
    - You try to send corrupted packets.
    - Someone took his hands on the CAr buffer
    - And last is about netcode thing i really don't have idea about it.
    Something is off with your query and does not seems to be the one from ketchup release. First of all , where is your NEUZ_CPORT ? Why do did you made an inbound rule with your NEUZ_IPSET address? From all this I can conclude that you are not doing things correctly, check the groxy tutorial again maybe. Been using ketchup releases for 3+ years at least and never had that kind of problem, In the other hand when I started to get into the flyff scene this error appear when I went into shitty sources. Try to change ports numbers of NEUZ_CPORT & PN_LOGINSRVR & PN_CERTIFIER to 1010, 1020 , 1030 or something maybe.

  6. #51
    Valued Member MakVee is offline
    MemberRank
    Mar 2021 Join Date
    MarsLocation
    143Posts
    Quote Originally Posted by Ketchup View Post
    This has nothing to do with systems implemented by you and everything to do with port scanning. This has been said now on multiple sites and told to you multiple times. Change your ports, setup and secure your vps correctly OR change to the V21.2 network code.

    You should also learn to debug and see where problems come from so they can be fixed.

    The files your trying to bribe people to fix this for you are already public and on this forum btw:
    https://forum.ragezone.com/f457/mark...theme-1191641/

    And the post of your all.h is from guru and not from my files.

    So you should be posting your query there not here.
    The file you release is just the source of it, and about the files that you said that files that im editing is guru? no it's not it's your K19 release files i just edit kCommon.h and add configurations in it.

    And about the debug i've posted it already in the help section and no one cares about it.

    - - - Updated - - -

    Quote Originally Posted by Percuflex View Post
    Something is off with your query and does not seems to be the one from ketchup release. First of all , where is your NEUZ_CPORT ? Why do did you made an inbound rule with your NEUZ_IPSET address? From all this I can conclude that you are not doing things correctly, check the groxy tutorial again maybe. Been using ketchup releases for 3+ years at least and never had that kind of problem, In the other hand when I started to get into the flyff scene this error appear when I went into shitty sources. Try to change ports numbers of NEUZ_CPORT & PN_LOGINSRVR & PN_CERTIFIER to 1010, 1020 , 1030 or something maybe.
    Ok thanks for your advise, Btw i allow NEUZ_IPSET in inbound rules coz i can't connect in my domain and even login in game

  7. #52
    ‎‎‎‎ Ketchup is offline
    ModeratorRank
    Jan 2009 Join Date
    New YorkLocation
    2,926Posts
    Tons of servers use my bases and don't have these issues. Infact I have been running a vps now with my 18 and haven't had this issue at all. So Im pretty sure it comes down to poor setup and security on your end.


    I really don't know what else to tell you honestly. I also wouldn't add all of those florist/as flyff fixes either as most of it is junk and it could be contributing to your problems.

  8. #53
    Valued Member MakVee is offline
    MemberRank
    Mar 2021 Join Date
    MarsLocation
    143Posts
    Quote Originally Posted by Ketchup View Post
    Tons of servers use my bases and don't have these issues. Infact I have been running a vps now with my 18 and haven't had this issue at all. So Im pretty sure it comes down to poor setup and security on your end.


    I really don't know what else to tell you honestly. I also wouldn't add all of those florist/as flyff fixes either as most of it is junk and it could be contributing to your problems.

    Yeah you're right it's all about the poor setup in firewall and i think i have manage to fix it it's been 24hrs and i didn't get the error issue.. Thank you very much for the advise's and hints. My only problem now is how to include my domain in firewall to make it access in public
    Last edited by MakVee; 20-11-22 at 09:24 AM.

  9. #54
    Enthusiast asheashia is offline
    MemberRank
    Jul 2022 Join Date
    20Posts
    This is an amazing release AS ALWAYS from you @Ketchup --- I don't think the Flyff P-Server would flourish that it is now without your releases. Hope you'll stick around for some of us nooblets to bugger you with stupid questions xD xD

  10. #55
    ‎‎‎‎ Ketchup is offline
    ModeratorRank
    Jan 2009 Join Date
    New YorkLocation
    2,926Posts
    Quote Originally Posted by MakVee View Post
    Yeah you're right it's all about the poor setup in firewall and i think i have manage to fix it it's been 24hrs and i didn't get the error issue.. Thank you very much for the advise's and hints. My only problem now is how to include my domain in firewall to make it access in public
    You don't include a domain into the firewall.

    Use something like cloudflare and hook your server ip to the dns. Then update where you bought the domain from and change the name servers that cloudflare provides you. Then allow ports 80, 443 via your firewall.

  11. #56
    Valued Member MakVee is offline
    MemberRank
    Mar 2021 Join Date
    MarsLocation
    143Posts
    Quote Originally Posted by Ketchup View Post
    You don't include a domain into the firewall.

    Use something like cloudflare and hook your server ip to the dns. Then update where you bought the domain from and change the name servers that cloudflare provides you. Then allow ports 80, 443 via your firewall.

    Ohh i see got it!. It's all about the port thank you very much! it help's a lot! :handsdown:

  12. #57
    ‎‎‎‎ Ketchup is offline
    ModeratorRank
    Jan 2009 Join Date
    New YorkLocation
    2,926Posts
    Quote Originally Posted by MakVee View Post
    Ohh i see got it!. It's all about the port thank you very much! it help's a lot! :handsdown:
    Glad you resolved your issues. You should post how you fixed the socket issue for others if they need it as you would be doing them a service.

  13. #58
    Valued Member MakVee is offline
    MemberRank
    Mar 2021 Join Date
    MarsLocation
    143Posts
    Quote Originally Posted by Ketchup View Post
    Glad you resolved your issues. You should post how you fixed the socket issue for others if they need it as you would be doing them a service.
    I fixed the socket issue by setting up the right ports in the firewall and allow it (cert,cache,login & NEUZ_CPORT)both inbound and outbound and secure it in outbound. And about the domain to make it access in public i just open the ports of (80,443) and now all is accessible and works fine big thanks to @Ketchup, @Percuflex :handsdown:

  14. #59
    Enthusiast Ryzelle01 is offline
    MemberRank
    Sep 2021 Join Date
    36Posts
    i got this weird issue. .bat file exits withour even booting my neuz.exe to open, anyone here got the same issue?

  15. #60
    ‎‎‎‎ Ketchup is offline
    ModeratorRank
    Jan 2009 Join Date
    New YorkLocation
    2,926Posts
    Quote Originally Posted by Ryzelle01 View Post
    i got this weird issue. .bat file exits withour even booting my neuz.exe to open, anyone here got the same issue?
    Make sure the boot string is the same in kcommon as it is in the bat file. Otherwise make sure u didn't delete it from within the source.



Page 4 of 8 FirstFirst 12345678 LastLast

Advertisement