[WZ Question] Adding new stuff cannot be found in-game

Results 1 to 2 of 2
  1. #1
    Registered xDYX is offline
    MemberRank
    Apr 2012 Join Date
    CanadaLocation
    13Posts

    ! [WZ Question] Adding new stuff cannot be found in-game

    Hello, after I have exported and imported one random Cap into my server as well as the source I'm using (HeavenMs), I tried typing in !item <itemid> but it says that "Item id <item id> does not exist.". I have been looking for answers for the past four hours. I used to import and export and it worked finely but this time around I don't know what went wrong.

    My steps are:
    1. Used WzRepacker to dump the cap's XML into storage (XML_Dumps).
    2. Imported the XML into my Maplestory WZ (Character.wz under Cap.)
    3. Saved and rewritten the Character.wz file in my Maplestory directory.
    4. Copy and pasted the cap's XML from the XML_Dumps folder into my source wz folder.

    Exactly what went wrong? I also checked in ItemConstants that the code I'm taking from is within the limits set by the coder.

    This doesn't work for hairstyles as well. I tried several methods such as renaming the XML into a number that's not used inside the source wz folder (for e.g. gap btw 0000300 and 000302 so i used 000301 <just an example, not in rl>) and I still couldn't get it to work.

    Please help if you have any knowledge on this. Thank you so much. Just wanted to set up a custom server for my close pals to play together.


  2. #2
    Registered xDYX is offline
    MemberRank
    Apr 2012 Join Date
    CanadaLocation
    13Posts

    Re: [WZ Question] Adding new stuff cannot be found in-game

    [SOLVED]

    Solution: Import Strings for all the item IDs into your WZ server folder as well. Reminder to self to always dump into server wz too other than just dumping into the client side folder.



Advertisement