[Release] Perfect World Server 1.4.4 - Basic Setup

1. Patch with files from PWS144-ClientSide.rar
2. Go to
\Perfect World Entertainment\Perfect World International\patcher\server
and
\Perfect World Entertainment\Perfect World International\element\userdata\server

Delete all then change the content of the serverlist.txt to smth like this

PWI HELL 29000:192.168.x.x 1
Where 192.168.x.x is your server IP
:D::D:

Thanks so much! :)
 
Got all working :)
But when we try to edit the gshop with the latest sGshopedit, things turn out bad :(. Map crashed with authd problem.
Hope everything will be fine soon.
 
Everything seems to work and can log in except in pwAdmin when I do the import roles I get the error Import roles to MySql failed.

I haven't fixed AuthD so that is still offline, is it related to getting that fixed first or can I just ignore it with au_cert = false? I'll put a trace on the update SQL statement otherwise and see if I can see anything wrong in it.

Thanks very much.

Ignore above - Worked though iweb to do the things from pwAdmin
 
Got all working :)
But when we try to edit the gshop with the latest sGshopedit, things turn out bad :(. Map crashed with authd problem.
Hope everything will be fine soon.

if you are using Ronny's editor and following the instruction right.. it should be ok i suppose..
also dont forget this:
Code:
Gshop.data (same files in client/server)
Gshop1.data/Gshopsev.data (same files in client/server)
 
Configuration:
1. Unpack the Server files direct to the root
2. Open the file /root/glinkd/gamesys.conf and change the 4 initial IP as bellow:

[GLinkServer1]
address=192.168.1.3 <- change to your IP

[GLinkServer2]
address=192.168.1.3 <- change to your IP

[GLinkServer3]
address=192.168.1.3 <- change to your IP

[GLinkServer4]
address=192.168.1.3 <- change to your IP

Okay i am a complete nub with IPs and stuff like that for this part which ip do i need to put there my WAN IP (from ip chicken) LAN (from ipconfig in CMD prompt) or VMwares IP (from ifconfig) sorry for nub question :/
 
Gshop.data (same files in client/server)
Gshop1.data/Gshopsev.data (same files in client/server)

== wrong ...

gshop.data | gshop1.data [ event boutique ] only client
gshopsev.data | gshopsev1.data [ event boutique ] only server

Thx for the info...

Ive not rly checked the files, since i dont relly need Event boutique... the main shop working is what i wanted and this package got it just fine... ill check that later and update the info.

Okay i am a complete nub with IPs and stuff like that for this part which ip do i need to put there my WAN IP (from ip chicken) LAN (from ipconfig in CMD prompt) or VMwares IP (from ifconfig) sorry for nub question :/

normally you would use eth0's IP that you can see with ifconfig command...

but in ultimate case if you dont know much what to do, you can always try all the IPs that you got (lol)... you will waste a couple minutes but at some point you will find it =]
 
i used to set my client by patching files. everything ok but i try to set one friend client and fail. he downloaded version 580, patched witf files drom this section. All ok but i cant see characters, they are completly invisible. Anyone have same issue?
 
normally you would use eth0's IP that you can see with ifconfig command...

but in ultimate case if you dont know much what to do, you can always try all the IPs that you got (lol)... you will waste a couple minutes but at some point you will find it =]

see thats what i thought and the one i put ty for confirming ^^

also another question the when i go to i get "Not Found

The requested URL /phpmyadmin was not found on this server.
Apache/2.2.14 (Ubuntu) Server at 192.168.0.10 Port 80"

anyone know what i did wrong o.o
 
@AcidRayne i had to edit the apache config to connect to phpmyadmin, its basically 2 lines to type in terminal ...i think its on my guide in mixing136/144 files post, if not google it.
Edit
sudo gedit /etc/apache2/apache2.conf
Add this to the bottom of script...
include /etc/phpmyadmin/apache.conf
 
Last edited:
@argonaut Thanks a ton dude i'll deffinitly try that once i get the chance. i am currently reading up on networking and ips and stuff like that, so once i finish that i will let you know how what you suggested turned out.



Edit:
okay so i was still having some trouble so, I went out on a guess and used "reboot" and now it works thanks so much for your help.


Edit:
Ugh I hate asking for so much help, i normally just google search and forum search or look around in files for the error; i haven't been able to find anything on what im having trouble with. So when i go to login, password, repeat password and email comes up. So to keep it simple and remember-able i make it the same as my phpmyadmin info and ubuntu info when i click registration button an error comes up "Can't connect to MySQL." I don't think i did anything wrong but if anyone knows this error or can recreate it can you toss me some suggestions? thanks. ^^
 
Last edited:
var/www/register/config.php
make sure these values are set correctly to your own settings in config.php
var/www/register/status.php
make sure these values are set correctly to your own settings in status.php

Illustration only
$DBHost = "localhost"; // localhost or your IP
$DBUser = "root"; // Database user
$DBPassword = "123456"; // Database password <---change this to your sql password
$DBName = "pw"; // Database name
Illustration only
Looks like the problem youre having is incorrect information supplied by the scripts and database connection fails thereof.
 
Thank you again argonaut everything is working now

Edit:----

except for when i run /root/start.sh it gets to a part then says "TRACE: gdelivery: :gfactionclient: Connect to server failed. reconnecting..."
over and over again >.<

Edit:--
actually it seems a lot of the programs trying to start are having something they can't find like ./gacd etc etc
 
Last edited:
You have installed the ia32-libs?
apt-get install ia32-libs
Also check the tables.xml in /mauthd/ and /etc/ for correct sql password
 
Last edited:
that fixed it... i must of forgotten about ia32 libs when i did a fresh install sorry for all my nub questions..and thanks for your help
 
I didnt know were to post it so il post it here currently looking for help with a server i alrdy have the server running need help with the workload send me a message or add me on msn if this post is in the wrong place please delete or move it thanks
 
No direct Download available at all ?? I don't want to wait 13 hours for these files to be transferred onto my Dedicated Server -.-"
 
No direct Download available at all ?? I don't want to wait 13 hours for these files to be transferred onto my Dedicated Server -.-"

If you're asking for a better download speed, here is a cool site to leech it:
 
Back