[EP33] Docker repack

Hello everyone, i'm having a problem when i try to log in, i put print of my LoginSvr_01.log , status of the server is all OK, and i can connect to the database with MSS. Somenone can help me with that ? Tks.

OBS: I'm using Debian 11 and VirtualBox, network is set to Bridge, and i'm using the VM IP in odbc.ini
 

Attachments

  • Captura de tela 2025-05-17 160828 - [EP33] Docker repack - RaGEZONE Forums
    Captura de tela 2025-05-17 160828.webp
    25.4 KB · Views: 94
  • Captura de tela 2025-05-17 161345 - [EP33] Docker repack - RaGEZONE Forums
    Captura de tela 2025-05-17 161345.webp
    54.4 KB · Views: 91
Create linked server to not have to edit a bunch of procedures…

1: change serverIP to your public/wanip

SQL:
EXEC sp_addlinkedserver
@server = 'adb01',
@srvproduct = '',
@provider = 'SQLNCLI',
@datasrc = 'serverIP';


2.
SQL:
EXEC sp_serveroption
@server = 'adb01',
@optname = 'rpc',
@optvalue = 'true';

EXEC sp_serveroption
@server = 'adb01',
@optname = 'rpc out',
@optvalue = 'true';
what ip should i put? is it the vm Ip or my pc ip?
 
I need help, when I try to buy something in the agent shop it says that it failed to purchase the item, follow the logs, please help me

[2025-05-26 20:17:54.244711 140424286005632]: open log file '/var/log/cabal/AgentShop_01.log'
[2025-05-26 20:17:54.244870 140424286005632]: LOG LEVEL: 3
[2025-05-26 20:17:54.245721 140424286005632]: Version(56), Nation(TWN), SrcMD5(8e160816b16818aa7c65611fd4fc85f7)
[2025-05-26 20:17:54.246048 140424286005632]: Seed: 2068084039
[2025-05-26 20:17:54.292568 140424286005632]: Start AgentShop_01 Server
[2025-05-26 20:17:54.292723 140424286005632]: ReloadConfig(): ReloadConfig
[2025-05-26 20:17:54.292774 140424286005632]: LOG LEVEL: 3
[2025-05-26 20:17:54.292824 140424286005632]: MaxSearchResult(100)
[2025-05-26 20:17:54.292871 140424286005632]: NoActiveLimit(120000)
[2025-05-26 20:17:54.292903 140424286005632]: NoResponseTimeout(1800000)
[2025-05-26 20:17:54.292935 140424286005632]: SearchCacheCount(1023)
[2025-05-26 20:17:54.292966 140424286005632]: SearchCacheExpirationMilliSec(60000)
[2025-05-26 20:17:54.292996 140424286005632]: PetInfoCacheCount(127)
[2025-05-26 20:17:54.293027 140424286005632]: PetInfoCacheExpirationMilliSec(1800000)
[2025-05-26 20:17:54.293058 140424286005632]: NoCancelCommissionTimeoutSec(300)
[2025-05-26 20:17:54.293091 140424286005632]: ServerNoResponseTimeoutSec(20)
[2025-05-26 20:17:54.293121 140424286005632]: NotifyBbeadSlotCount(false)
[2025-05-26 20:17:54.293152 140424286005632]: AlertAveragePrice(25%)
[2025-05-26 20:17:54.293182 140424286005632]: GuildCashbackCheckHour(0)
[2025-05-26 20:17:54.293213 140424286005632]: GuildWHCheckoutTimeout(3600000)
[2025-05-26 20:17:54.293243 140424286005632]: InitEnv BEGIN
[2025-05-26 20:17:54.293274 140424286005632]: InitEnv END
[2025-05-26 20:17:54.688537 140424286005632]: UseAgentShopForcegem(Off)
[2025-05-26 20:17:54.688766 140424286005632]: Default CommissionRate(Alz) - (400/100)%
[2025-05-26 20:17:54.688817 140424286005632]: Default CommissionRate(Forcegem) - (0/100)%
[2025-05-26 20:17:54.688875 140424286005632]: PersonalTradeUsingAlz(Off)
[2025-05-26 20:17:54.688917 140424286005632]: PersonalTradeUsingForcegem(On)
[2025-05-26 20:17:54.688957 140424286005632]: Default Personal Trade CommissionRate(Alz) - (0/100)%
[2025-05-26 20:17:54.689013 140424286005632]: Default Personal Trade CommissionRate(Forcegem) - (500/100)%
[2025-05-26 20:17:54.791569 140424260159168]: CProcessLayer(0)::svc Start [140424260159168]
[2025-05-26 20:17:54.791730 140424286005632]: try connect 127.0.0.1:38170, Sync
[2025-05-26 20:17:54.792442 140424286005632]: sock 5 ->LinkHandler Open
[2025-05-26 20:17:54.792486 140424286005632]: waiting for SendIPSConnect2Svr
[2025-05-26 20:17:56.793614 140424286005632]: SendIPSConnect2Svr (233:01:01:00:246)
[2025-05-26 20:17:56.794595 140424286005632]: try connect 127.0.0.1:48211, Sync
[2025-05-26 20:17:56.794946 140424286005632]: sock 7 ->LinkHandler Open
[2025-05-26 20:17:56.795005 140424286005632]: waiting for SendIPSConnect2Svr
[2025-05-26 20:17:58.795596 140424286005632]: SendIPSConnect2Svr (233:01:01:00:212)
[2025-05-26 20:17:58.797322 140424286005632]: try connect 127.0.0.1:48111, Sync
[2025-05-26 20:17:58.798854 140424286005632]: sock 8 ->LinkHandler Open
[2025-05-26 20:17:58.798918 140424286005632]: waiting for SendIPSConnect2Svr
[2025-05-26 20:18:00.800543 140424286005632]: SendIPSConnect2Svr (233:01:01:00:250)
[2025-05-26 20:18:00.802394 140424286005632]: try listening 35001 port
[2025-05-26 20:18:00.803751 140424286005632]: try listening 38151 port
[2025-05-26 20:18:00.804451 140424286005632]: BookmarkCacheCount(50)
[2025-05-26 20:18:00.808500 140424260159168]: [HeartBeat] Register : Addr(127.0.0.1:48111)
[2025-05-26 20:18:00.809170 140424260159168]: [HeartBeat] Register : Addr(127.0.0.1:38170)
[2025-05-26 20:18:00.892029 140424260159168]: [Average Price] End Rotation(0)
[2025-05-26 20:18:00.892500 140424260159168]: [HeartBeat] Register : Addr(127.0.0.1:48211)
[2025-05-26 20:18:11.421130 140424286005632]: success accept 11(127.0.0.1:50386)
[2025-05-26 20:18:11.423137 140424286005632]: 1.open user 11 [1CD4C20] (127.0.0.1)
[2025-05-26 20:18:15.434110 140424286005632]: [Security] Connect From Internal Server(127.0.0.1:50386)
[2025-05-26 20:18:15.434889 140424260159168]: OnIPCConnect2Svr(): [WorldSvr] new linked(161, 1, 1)
[2025-05-26 20:18:15.434974 140424260159168]: [HeartBeat] Register : Addr(127.0.0.1:50386)
[2025-05-26 20:18:15.435151 140424260159168]: OnIPCConnect2Svr(): ServerIdx(1), GroupIdx(1), Type(161), Addr(127.0.0.1:50386)
[2025-05-26 20:18:19.627387 140424260159168]: SetRestricted : 1
[2025-05-26 20:18:48.655801 140424286005632]: success accept 12(45.165.4.161:50675)
[2025-05-26 20:18:48.656881 140424286005632]: 2.open user 12 [1CD5240] (45.165.4.161)
[2025-05-26 20:18:48.682163 140424286005632]: [Security] Connect From User(45.165.4.161:50675)
[2025-05-26 20:18:48.762091 140424260159168]: [Auth] Request. UserNum(6), CharIndex(96), IP(45.165.4.161)
[2025-05-26 20:18:48.782738 140424260159168]: [UserIN_] User(6)
[2025-05-26 20:18:48.783170 140424260159168]: [Auth] Response. Result(0), UserNum(6), CharIndex(96), IP(45.165.4.161)
[2025-05-26 20:18:48.909617 140424260159168]: [Bookmark] Add First : UserNum(6), Count(1)
[2025-05-26 20:19:02.933149 140424260159168]: [##ERROR##] OnIPCBuyItemResult(): [AgentShop] Buy Fail. CharacterIdx(96), Reason(193)
[2025-05-26 20:19:20.110743 140424260159168]: [##ERROR##] OnIPCBuyItemResult(): [AgentShop] Buy Fail. CharacterIdx(96), Reason(193)
[2025-05-26 20:19:50.009072 140424286005632]: 2.close user 12 [1CD5240] (45.165.4.161)
[2025-05-26 20:19:50.011838 140424260159168]: [UserOUT] User(6)
[2025-05-26 20:19:50.012146 140424260159168]: [Bookmark] Logout : UserNum(6)
[2025-05-26 20:23:09.345369 140424286005632]: success accept 12(45.165.4.161:50653)
[2025-05-26 20:23:09.346736 140424286005632]: 2.open user 12 [1CD5240] (45.165.4.161)
[2025-05-26 20:23:09.356155 140424286005632]: [Security] Connect From User(45.165.4.161:50653)
[2025-05-26 20:23:09.430392 140424260159168]: [Auth] Request. UserNum(6), CharIndex(96), IP(45.165.4.161)
[2025-05-26 20:23:09.441932 140424260159168]: [UserIN_] User(6)
[2025-05-26 20:23:09.442169 140424260159168]: [Auth] Response. Result(0), UserNum(6), CharIndex(96), IP(45.165.4.161)
[2025-05-26 20:23:09.516257 140424260159168]: [Bookmark] Get : UserNum(6), Count(1)
[2025-05-26 20:23:14.755842 140424260159168]: [HeartBeat] Response : Addr(127.0.0.1:38170)
[2025-05-26 20:23:23.843962 140424286005632]: 2.close user 12 [1CD5240] (45.165.4.161)
[2025-05-26 20:23:23.845963 140424260159168]: [UserOUT] User(6)
[2025-05-26 20:23:23.846131 140424260159168]: [Bookmark] Logout : UserNum(6)
[2025-05-26 20:23:47.371968 140424260159168]: [HeartBeat] Response : Addr(127.0.0.1:48111)
[2025-05-26 20:28:59.276407 140424260159168]: [HeartBeat] Response : Addr(127.0.0.1:50386)
[2025-05-26 20:29:00.804836 140424260159168]: [HeartBeat] Request : Addr(127.0.0.1:48111)
[2025-05-26 20:29:00.804950 140424260159168]: [HeartBeat] Request : Addr(127.0.0.1:38170)
[2025-05-26 20:29:05.687814 140424260159168]: [HeartBeat] Response : Addr(127.0.0.1:48211)
[2025-05-26 20:34:00.805273 140424260159168]: [HeartBeat] Request : Addr(127.0.0.1:50386)
[2025-05-26 20:34:14.755889 140424260159168]: [HeartBeat] Response : Addr(127.0.0.1:38170)
[2025-05-26 20:34:47.379030 140424260159168]: [HeartBeat] Response : Addr(127.0.0.1:48111)
[2025-05-26 20:35:05.689977 140424260159168]: [HeartBeat] Response : Addr(127.0.0.1:48211)
[2025-05-26 20:36:06.446179 140424286005632]: success accept 12(45.165.4.161:50699)
[2025-05-26 20:36:06.446761 140424286005632]: 2.open user 12 [1CD5240] (45.165.4.161)
[2025-05-26 20:36:06.454948 140424286005632]: [Security] Connect From User(45.165.4.161:50699)
[2025-05-26 20:36:06.526622 140424260159168]: [Auth] Request. UserNum(6), CharIndex(96), IP(45.165.4.161)
[2025-05-26 20:36:06.529174 140424260159168]: [UserIN_] User(6)
[2025-05-26 20:36:06.529323 140424260159168]: [Auth] Response. Result(0), UserNum(6), CharIndex(96), IP(45.165.4.161)
[2025-05-26 20:36:06.601247 140424260159168]: [Bookmark] Get : UserNum(6), Count(1)
[2025-05-26 20:36:20.033018 140424260159168]: [##ERROR##] OnIPCBuyItemResult(): [AgentShop] Buy Fail. CharacterIdx(96), Reason(193)
 
Hi, new member here, i'm stuck on trying to run build_cabal_repo. i keep getting an error: "/usr/sbin/build_cabal_repo: line 18: /proc/sys/vm/drop_caches: operation not permitted"
i should mention: im trying to run this on win 10
 
Guys I need help

- I'm having this problem in my ChatNode_01.log "[##ERROR##] [Security] Invalid Connection(127.0.0.1:43284) : Xor(0), Internal(0)"
- I'm also having this randomly "[##ERROR##] VerifyRemoteResult(): [Auth] Not Waiting Response From Remote : UserIdx(5), UserNum(0), UserID(ragezone), IP(49.x.x.x), Flag(1,1,0)" sometimes it wont appear and sometime it appears. this happens every time I login to my client using husky.
 
Guys I need help

- I'm having this problem in my ChatNode_01.log "[##ERROR##] [Security] Invalid Connection(127.0.0.1:43284) : Xor(0), Internal(0)"
- I'm also having this randomly "[##ERROR##] VerifyRemoteResult(): [Auth] Not Waiting Response From Remote : UserIdx(5), UserNum(0), UserID(ragezone), IP(49.x.x.x), Flag(1,1,0)" sometimes it wont appear and sometime it appears. this happens every time I login to my client using husky.
you cant go ingaMe ?
 
you cant go ingaMe ?
Actually I can login when disconnect and login again this error appears "[##ERROR##] VerifyRemoteResult(): [Auth] Not Waiting Response From Remote : UserIdx(5), UserNum(0), UserID(ragezone), IP(49.x.x.x), Flag(1,1,0)" in client says "You have disconnected to the game" try logging in again and again until it succeeded. it randomly happens this log in from LoginSvr_01.log
 
it shows:
build_cabal_repo
/usr/bin/build_cabal_repo: line 10: cd: /home/dockerBuild/source/cabal-data: No such file or directory
/usr/bin/build_cabal_repo: line 12: cd: /home/dockerBuild/source/cabal-scripts: No such file or directory
tar (child): /home/dockerBuild/installator/cabal_default_backup.tar.gz: Cannot open: No such file or directory
tar (child): Error is not recoverable: exiting now
tar: Child returned status 2
tar: Error is not recoverable: exiting now
/usr/bin/build_cabal_repo: line 18: /proc/sys/vm/drop_caches: Permission denied
how cam i fix it? thx!
 
it shows:
build_cabal_repo
/usr/bin/build_cabal_repo: line 10: cd: /home/dockerBuild/source/cabal-data: No such file or directory
/usr/bin/build_cabal_repo: line 12: cd: /home/dockerBuild/source/cabal-scripts: No such file or directory
tar (child): /home/dockerBuild/installator/cabal_default_backup.tar.gz: Cannot open: No such file or directory
tar (child): Error is not recoverable: exiting now
tar: Child returned status 2
tar: Error is not recoverable: exiting now
/usr/bin/build_cabal_repo: line 18: /proc/sys/vm/drop_caches: Permission denied
how cam i fix it? thx!
you have a wrong repack. just check to the commend section for docker share
 
you have a wrong repack. just check to the commend section for docker share
I used this one-->ep33_repack_docker,and put "dockerbuild" it into /home(by using WSL,Ubuntu).
Could the issue be caused by the setup environment?
 
I used this one-->ep33_repack_docker,and put "dockerbuild" it into /home(by using WSL,Ubuntu).
Could the issue be caused by the setup environment?
cabal_default_backup.tar.gz: you have this file on this repack if you dont have. just download na latest Repack from a Comment Section scroll and Next to check. from mr Mental
 
This repack is based on HariSeldon docker and 2nd version released which includes some correction and fixes.

This release contains the following below:

Repack has been tested and worked properly in Debian 11 only after following the installation guide included on the repack.



All credits belong to respective owners who released the files:
HariSeldon, w3rnis (1st repack), immafishball (husky fixed), MrSensei (EP33 files)
Sir iwant to ask how to create 2 server in one docker. Itry changing sql port but no connect
 
Guys, to use this client on a VPS, do I just need to edit internal.txt?
 
Last edited:
got this problem with step 6.

1753431752430 - [EP33] Docker repack - RaGEZONE Forums


root@srv777874775:/home/dockerBuild/source/cabal-container/cabal-container-C7# docker build --rm --no-cache -t x10plays/cabal-ep33
-bash: docker: command not found

got any advise?
 
This repack is based on HariSeldon docker and 2nd version released which includes some correction and fixes.

This release contains the following below:

Repack has been tested and worked properly in Debian 11 only after following the installation guide included on the repack.



All credits belong to respective owners who released the files:
HariSeldon, w3rnis (1st repack), immafishball (husky fixed), MrSensei (EP33 files)
where me watch guide install sir?
 
==> Install MEGAcmd...
--2025-08-29 14:31:24--
Resolving mega.nz (mega.nz)... 31.216.145.5, 31.216.144.5, 2a0b:e46:1:144::5, ...
Connecting to mega.nz (mega.nz)|31.216.145.5|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 19186948 (18M) [application/x-deb]
Saving to: ‘megacmd-Debian_11_amd64.deb’

megacmd-Debian_11_amd64.deb 100%[======================================================>] 18.30M 4.69MB/s in 5.1s

2025-08-29 14:31:31 (3.57 MB/s) - ‘megacmd-Debian_11_amd64.deb’ saved [19186948/19186948]

Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Note, selecting 'megacmd' instead of './megacmd-Debian_11_amd64.deb'
The following NEW packages will be installed:
megacmd
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/19.2 MB of archives.
After this operation, 59.4 MB of additional disk space will be used.
Get:1 /root/megacmd-Debian_11_amd64.deb megacmd amd64 2.1.1-1.1 [19.2 MB]
Selecting previously unselected package megacmd.
(Reading database ... 143989 files and directories currently installed.)
Preparing to unpack .../megacmd-Debian_11_amd64.deb ...
Unpacking megacmd (2.1.1-1.1) ...
Setting up megacmd (2.1.1-1.1) ...
fs.inotify.max_user_watches = 524288
N: Download is performed unsandboxed as root as file '/root/megacmd-Debian_11_amd64.deb' couldn't be accessed by user '_apt'. - pkgAcquire::Run (13: Permission denied)


Hi guys how to fix this ?

1756479790352 - [EP33] Docker repack - RaGEZONE Forums

is there anyone could help me how to fix this ?
thank you in advance
 
Last edited:
Back