Welcome!

Join our community of MMO enthusiasts and game developers! By registering, you'll gain access to discussions on the latest developments in MMO server files and collaborate with like-minded individuals. Join us today and unlock the potential of MMO server development!

Join Today!

After Login empty server list !

Joined
Aug 31, 2003
Messages
765
Reaction score
5
Hey :D
I have managed to get my server working to a degree ...
After creating an accout and logging in I am greeted by an empty server list.

All of my server bits seem to be running on the linux side.

Here's a screenshot:
omen - After Login empty server list ! - RaGEZONE Forums
 
Junior Spellweaver
Joined
Sep 26, 2007
Messages
152
Reaction score
2
yeah this is because you made some changes in your character details.. trun the hacks of in worldsvr.

Code:
# ALZ_DBHACK_CHECK
UseAlzDbHackCheck=0
UseCutIfAlzDbHacked=0

UseLevDiffValueForExpCalc=0
UePartyMinExpForInvalidPartyMember=0

# HackCheckOption
UseCheckShopHack=0
UseCheckWarpHack=0
UseCheckWareHouseHack=0
UseCheckSkillCoolTimeHack=0
UseCheckDistanceSkillHack=0
UseBlessingBeadCheck=0
UseCheckDeadStatActive=0
UseHackcheckByTimeScope=0
UseCheckDMZArea=0
UseCheckInventoryHack=0
 
Upvote 0
Joined
Aug 31, 2003
Messages
765
Reaction score
5
Okay, i have edited the files that have hack related stuff

WorldSvr.ini
WorldSvr_24_01.ini

all my server compnents are running !
and my WorldSvr_24_01 is taking up about 200mb of ram while running.

I am able to make accounts and log in, but i cannot see the server or the channels.

logs seem to be "OK"
apart from:

DBAgent_24.log
Code:
[Mon Sep  8 2008 23:45:13.778453 3064826768]: [##ERROR##] UsrMap Fail : MainCmd(600) Ret(8C:0:140) Addr(192.168.1.25)
[Mon Sep  8 2008 23:46:13.769629 3064826768]: [##ERROR##] DB ERROR(MSG)      : [unixODBC][Driver Manager]Connection name in use
[Mon Sep  8 2008 23:46:13.769657 3064826768]: [##ERROR##] DB ERROR(CODE)     : 0
[Mon Sep  8 2008 23:46:13.769670 3064826768]: [##ERROR##] DB ERROR(VAR_INFO) : 
[Mon Sep  8 2008 23:46:13.769682 3064826768]: [##ERROR##] DB ERROR(SQLSTATE) : 08002
[Mon Sep  8 2008 23:46:13.769693 3064826768]: [##ERROR##] DB ERROR(STM_TEXT) : 
[Mon Sep  8 2008 23:46:13.769705 3064826768]: [##ERROR##] Database Connect Fail (uid=ncabal;pwd=polkaudio;dsn=CabalGame24;APP=DBAgent_24)
[Mon Sep  8 2008 23:46:13.769718 3064826768]: [##ERROR##] check 'pDB' fail
[Mon Sep  8 2008 23:46:13.769729 3064826768]: [##ERROR##] 'OnIPCIWarGetLastNationRewardWarResults' fail (Database/InstantWar.cpp:140)
[Mon Sep  8 2008 23:46:13.769742 3064826768]: [##ERROR##] UsrMap Fail : MainCmd(600) Ret(8C:0:140) Addr(192.168.1.25)

WorldSvr_24_01.log
Code:
[Mon Sep  8 2008 23:40:15.577929 2799356816]: CProcessLayer(27)::svc Start [2799356816]
[Mon Sep  8 2008 23:40:15.607734 2786716560]: CProcessLayer(28)::svc Start [2786716560]
[Mon Sep  8 2008 23:40:15.628017 2773986192]: CProcessLayer(29)::svc Start [2773986192]
[Mon Sep  8 2008 23:40:15.647864 2761087888]: CProcessLayer(30)::svc Start [2761087888]
[Mon Sep  8 2008 23:40:15.653156 3081770688]: try listening 38111 port
 
Upvote 0
Newbie Spellweaver
Joined
Jun 13, 2008
Messages
33
Reaction score
0
hiya .

omen the prob is pointing to your sql.

i had the same thing for an hour or 2 untill i made sure that my sql is accepting calls to the port. check that your dbs are not in hidden status and that the tcp/ is accepting port 1433.
check that your id pass is owner of gamedb and that it is the same id and pass for the virtual server check that your dbagent and world server have the correct ip address.
make sure you edit both the odbc ini and cfg files to same ip address as the cfg rewrites the ini file.
shut down server files shutdown virt server , then reload virt server rerun dbs and all should be fine
 
Upvote 0
Joined
Aug 31, 2003
Messages
765
Reaction score
5
Could somebody please upload their .ini settings please ?
I have modified clean original files and none of the servers would start. Using my "working" inis, now my configed starts but I get these errors:
DBAgent_24.log
Code:
[Tue Sep  9 2008 01:17:09.421756 3081599888]: [##ERROR##] check 'pDB' fail
[Tue Sep  9 2008 01:17:09.421769 3081599888]: [##ERROR##] 'OnIPCItemSerial0' fail (Database/ItemSerial.cpp:24)
[Tue Sep  9 2008 01:17:09.421783 3081599888]: [##ERROR##] UsrMap Fail : MainCmd(50) Ret(18:0:24) Addr(192.168.1.25)
[Tue Sep  9 2008 01:17:09.421848 3081599888]: [##ERROR##] DB ERROR(MSG)      : [unixODBC][Driver Manager]Connection name in use
[Tue Sep  9 2008 01:17:09.421863 3081599888]: [##ERROR##] DB ERROR(CODE)     : 0
[Tue Sep  9 2008 01:17:09.421876 3081599888]: [##ERROR##] DB ERROR(VAR_INFO) : 
[Tue Sep  9 2008 01:17:09.421888 3081599888]: [##ERROR##] DB ERROR(SQLSTATE) : 08002
[Tue Sep  9 2008 01:17:09.421901 3081599888]: [##ERROR##] DB ERROR(STM_TEXT) : 
[Tue Sep  9 2008 01:17:09.421913 3081599888]: [##ERROR##] Database Connect Fail

Afaik know my SQL is ok, all the permissions are given to the user and the user name and pw is correct (double, treble checked).

Could somebody also post "working" servers "/etc/odbc.ini" and "/etc/odbcinst.ini"

I am collecting info on how to launch and install this server on ubuntu with all the required files to run php server and register site.

I will release a proper english only guide. Help me help you :)
 
Upvote 0
Junior Spellweaver
Joined
Apr 5, 2006
Messages
191
Reaction score
2
This is the part your configuration is wrong

[Mon Sep 8 2008 23:46:13.769705 3064826768]: [##ERROR##] Database Connect Fail (uid=ncabal;pwd=polkaudio;dsn=CabalGame24;APP=DBAgent_24)
[Mon Sep 8 2008 23:46:13.769718 3064826768]: [##ERROR##] check 'pDB' fail
 
Upvote 0
Joined
Aug 31, 2003
Messages
765
Reaction score
5
Damn that DBAgent


indicates eror 08002 is a "Connection in use error"

I will mess with odbc.ini to add more connections so there's "enough"... of connections to go around.
 
Upvote 0
Back
Top