Welcome!

Join our community of MMO enthusiasts and game developers! By registering, you'll gain access to discussions on the latest developments in MMO server files and collaborate with like-minded individuals. Join us today and unlock the potential of MMO server development!

Join Today!

Anybody running MaNGOS behind a gateway router?

Newbie Spellweaver
Joined
Jan 27, 2007
Messages
13
Reaction score
0
Is anyone else running a MaNGOS server on a LAN PC connected to the Internet via a gateway router? Can you get a WoW client to login to the server from both a local PC on the LAN and a remote PC via the Internet at the same time?

If you can, what IP address have you used in the realmd database, the local IP of the server or the WAN IP for the Internet? Are there any other weird settings which make this work?

You've guessed that I am having problems with this. If I set the realmd IP to the local LAN IP of the server then all the PCs on the LAN can connect. If I set it to the WAN IP then remote PCs can connect. BUT NOT BOTH AT ONCE!

If you've got any suggestions I'll be glad to hear them. Thanks.
 
Last edited:
Initiate Mage
Joined
Jan 16, 2007
Messages
4
Reaction score
0
Is anyone else running a MaNGOS server on a LAN PC connected to the Internet via a gateway router? Can you get a WoW client to login to the server from both a local PC on the LAN and a remote PC via the Internet at the same time?
Yes.
If you can, what IP address have you used in the realmd database, the local IP of the server or the WAN IP for the Internet? Are there any other weird settings which make this work?
visit: no-ip.org and set yourself up

You've guessed that I am having problems with this. If I set the realmd IP to the local LAN IP of the server then all the PCs on the LAN can connect. If I set it to the WAN IP then remote PCs can connect. BUT NOT BOTH AT ONCE!
Setting it to you internet Gateway in the realmd means you'll try and connect to the router, have the router foward the WoW ports to you server machine. done.
 
Newbie Spellweaver
Joined
Jan 27, 2007
Messages
13
Reaction score
0
Thanks for reply.

Sorry, maybe I wasn't clear. I meant that I was using the Internet IP (the one the ISP provides) not the local IP of the gateway device.

I've already set up a no-ip reroute but it doesn't help.

The ports 3724,8085,8080 are open for the server IP on the router.

Obviously you have this working. Are you using your no-ip domain name in the realmd DB? And have you set the relamlist.wtf file on the local LAN PCs to the no-ip domain as well? When I do this the local PCs will login but then disconnect after about 1 minute.
 
Initiate Mage
Joined
Jan 16, 2007
Messages
4
Reaction score
0
yes i use my no-ip domain in the realmd table and wow's realmlist.wtf file (in the root wow folder) points straight to that location so when i try and login it goes to the emu not the real wow servers. The dns resolves my no-ip domain to my current ip and wow then connects to my router which fowards the ports to the server box and logs me in the Auth(realmd.exe) which then in turn hands the connection onto the world server (mangos.exe). Just check the router isn't blocking anything with any firewall crap, also ping your no-ip domain to see if the ip is correct to that which is currently assigned to the router... if that fails just try setting it to the routers ip and connection directly :) gl

btw i forward: 3724,8085,3443 the router to the server.
 
Newbie Spellweaver
Joined
Jun 10, 2006
Messages
35
Reaction score
0
Hello, I had the same problem myself long time ago (when WoWEmu was still leading). It's in fact simple: You need to go in C:/WINDOWS/System32/drivers/etc and edit the file "hosts" with notepad. Add the line "127.0.0.1 yourip.no-ip.info" at the end of the file and save. Enjoy playing :)
 
Newbie Spellweaver
Joined
Jan 27, 2007
Messages
13
Reaction score
0
YES !!! :thumb_yel You are a star.

That is the answer.

Add the following to the C:\Windows\System32\Drivers\etc\Hosts file:

On the PC which is running the server add "127.0.0.1 your.no-ip.org"
but on the OTHER PCs on the LAN add "192.168.yourserverlocalIP your.no-ip.org".

And on Windows 98 (probably Me and 2000 as well) the Hosts file lives in the C:\Windows folder.

SORTED!
 
Newbie Spellweaver
Joined
Jan 1, 2007
Messages
47
Reaction score
0
Sure am

I am running smoothwall and have it configured just fine. I had the same problems with connection as everyone else though, at one point, I can connect from within the network, but not outside of it and vise versa. What I did was added two entries in my realmlist, one for outside the network and one for inside, and people connected respectively. Mine is setup as Id/name/(private ip address)/~/~/~/dbinfo
Make a copy of that with the second one reflecting your public ip address (make sure ID is changed to 2) and you are all set to go!
 
Back
Top