Welcome!

Join our community of MMO enthusiasts and game developers! By registering, you'll gain access to discussions on the latest developments in MMO server files and collaborate with like-minded individuals. Join us today and unlock the potential of MMO server development!

Join Today!

[ASM]CD Bootloader - Media test failed, check your cables

Legendary Battlemage
Loyal Member
Joined
Apr 7, 2009
Messages
647
Reaction score
25
I'm using NASM to compile my bootloader (I got this from a tutorial)
And yes, before you ask me, I do understand a bit of ASM.
Code:
[BITS 16]	;Tells the assembler that its a 16 bit code
[ORG 0x7C00]	;Origin, tell the assembler that where the code will
				;be in memory after it is been loaded

MOV SI, HelloString ;Store string pointer to SI
CALL PrintString	;Call print string procedure
JMP $ 		;Infinite loop, hang it here.


PrintCharacter:	;Procedure to print character on screen
	;Assume that ASCII value is in register AL
MOV AH, 0x0E	;Tell BIOS that we need to print one charater on screen.
MOV BH, 0x00	;Page no.
MOV BL, 0x07	;Text attribute 0x07 is lightgrey font on black background

INT 0x10	;Call video interrupt
RET		;Return to calling procedure



PrintString:	;Procedure to print string on screen
	;Assume that string starting pointer is in register SI

next_character:	;Lable to fetch next character from string
MOV AL, [SI]	;Get a byte from string and store in AL register
INC SI		;Increment SI pointer
OR AL, AL	;Check if value in AL is zero (end of string)
JZ exit_function ;If end then return
CALL PrintCharacter ;Else print the character which is in AL register
JMP next_character	;Fetch next character from string
exit_function:	;End label
RET		;Return from procedure


;Data
HelloString db 'Hello World', 0	;HelloWorld string ending with 0

TIMES 510 - ($ - $$) db 0	;Fill the rest of sector with 0
DW 0xAA55			;Add boot signature at the end of bootloader

It said to use a floppy, but i don't have one lol.

So...I tried using CD-RW.
I burned it on, put it into one of my x86 computers, rebooted, and tried to boot from CD.

Code:
PXE-e61 Media test failed, check cable
PXE-M0F: Exiting Intel Boot Agent
Operating System not found

What the...
 
Last edited:
Junior Spellweaver
Joined
Apr 12, 2009
Messages
104
Reaction score
10
Now its been a while since I've done any boot loaders, but if you look at , it gives a basic explanation.

What I think is happening, but can verify because this computer doesn't have NASM on it, is that the 0xAA55 is probably ending up in the wrong position, that would be the first thing I would check.
 
Legendary Battlemage
Loyal Member
Joined
Apr 7, 2009
Messages
647
Reaction score
25
Then how can i get NASM on it?
Lol

---------- Post added at 11:16 PM ---------- Previous post was at 10:59 PM ----------

I think the bootloader just isn't found.

The boot order is CD-ROM->LAN->HDD->FDD (or something like that)

It just skips to the LAN; it's using the intel card.
Is there anything wrong with it?
 
Back
Top