Welcome!

Join our community of MMO enthusiasts and game developers! By registering, you'll gain access to discussions on the latest developments in MMO server files and collaborate with like-minded individuals. Join us today and unlock the potential of MMO server development!

Join Today!

Ep2 (ep8) WebSite . Waring: Can"t connect to msssql !?

Initiate Mage
Joined
Aug 23, 2012
Messages
24
Reaction score
2
Hello guys,

i wanted to do a webshop for my cabal server.


When I change ip to my mssql ip (192.168.1.5) the website work.

But when i change ip to my internet ip this error come;

Warning: mssql_connect() [function.mssql-connect]: Unable to connect to server: MY IP in C:\AppServ\www\index.php on line 26
Could not connect to MSSQL database.



I need help :=)

Thaks Guys
 
Last edited by a moderator:
Initiate Mage
Joined
Oct 9, 2011
Messages
2
Reaction score
1
Open the file php.ini, and view if the following settings are the same:

extension=php_mssql.dll
mssql.secure_connection = On

On the "extension=php_mssql.dll", you need to remove the ";" thats have on this.

Look if the extension directory way it's correct, and if the file "php_mssql.dll" are in the folder.

Reboot Apache.

If the error persist, go to the folder of PHP, copy the file "ntwdlib.dll" and paste in 2 places:


C:\WINDOWS\System32

and in the Apache folder

Apache\bin
 
Upvote 0
Junior Spellweaver
Joined
Jun 2, 2011
Messages
145
Reaction score
14
create new database called "CashShop" and run query, u have sql databases in database folder in htdocs
 
Upvote 0
Joined
Aug 3, 2011
Messages
963
Reaction score
506
Open the file php.ini, and view if the following settings are the same:

extension=php_mssql.dll
mssql.secure_connection = On

On the "extension=php_mssql.dll", you need to remove the ";" thats have on this.

Look if the extension directory way it's correct, and if the file "php_mssql.dll" are in the folder.

Reboot Apache.

If the error persist, go to the folder of PHP, copy the file "ntwdlib.dll" and paste in 2 places:


C:\WINDOWS\System32

and in the Apache folder

Apache\bin

His apache and php setting is configured well, he said, when he use his LAN IP the database can connect, but when he use his WAN IP, database cannot connect.

The answers, you need to forward your port of 192.168.1.5 to port 80.
 
Upvote 0
Banned
Banned
Joined
Sep 6, 2007
Messages
834
Reaction score
167
You need use loop to make it working duo your INET ip has not connecting to localhost.
 
Upvote 0
Initiate Mage
Joined
Aug 23, 2012
Messages
24
Reaction score
2
The ep2 server internet site with ep8 update works not so good but it works. open port 80 and it works
 
Upvote 0
Joined
Jan 6, 2013
Messages
35
Reaction score
0
Add my msn I can help you: djmamotinho@hotmail.com.br

Hello guys,

i wanted to do a webshop for my cabal server.


When I change ip to my mssql ip (192.168.1.5) the website work.

But when i change ip to my internet ip this error come;

Warning: mssql_connect() [function.mssql-connect]: Unable to connect to server: MY IP in C:\AppServ\www\index.php on line 26
Could not connect to MSSQL database.



I need help :=)

Thaks Guys
 
Upvote 0
Back
Top