Join our community of MMO enthusiasts and game developers! By registering, you'll gain access to discussions on the latest developments in MMO server files and collaborate with like-minded individuals. Join us today and unlock the potential of MMO server development!

Join Today!

Error converting data type numeric to int

Newbie Spellweaver
Dec 10, 2009
Reaction score
So my roomie and I finally got our lil server up using SerusUriel repack. Started up fine and our friends could log on but then suddenly i couldn't use /sys message command or /say anyone in game. So i logged off and tried to re log and couldn't log in.

So i checked the CQuery-LogFile and noticed i came up with this error:?:

query:LOG_STR 'L1',@im_idPlayer='0000005',@iserverindex='01',@im_nExp1=2449828000,@im_nLevel=121,@im_nJob=25,@im_nJobLv=0,@im_nFlightLv=1,@im_nStr=15,@im_nDex=15,@im_nInt=15,@im_nSta=15,@im_nRemainGP=301,@im_nRemainLP=0,@iState='O',@idwWorldID=0,@ikilled_m_szName='(null)',@im_vPos_x=0.000000,@im_vPos_y=0.000000,@im_vPos_z=0.000000,@iattackPower=880447954,@imax_HP=0,@im_GetszName='(null)',@im_dwGold=0,@im_nRemainGold=0,@iItem_UniqueNo=0,@iItem_Name='',@iItem_durability=0,@iItem_count=0,@iItem_AddLv=0,@iStart_Time='(null)',@iTotalPlayTime=0,@iremoteIP='(null)',@iQuest_Index=0,@ikilled_m_idPlayer='0000000'
SQLSTATE:42000 error:[Microsoft][SQL Native Client][SQL Server]Error converting data type numeric to int.

Restarted the servers up and was able to log in and function fine. Left it on for like 10mins or so and ended up having the same problem again with the chatting and then i couldn't log back in when i re loged and came up with the same error.:scared:

Hope someone has a idea whats happening because google isn't helping me much :*:

======= figured it out lol, nvm ========
Last edited: