Welcome!

Join our community of MMO enthusiasts and game developers! By registering, you'll gain access to discussions on the latest developments in MMO server files and collaborate with like-minded individuals. Join us today and unlock the potential of MMO server development!

Join Today!

Guards wont talk anymore

Newbie Spellweaver
Joined
Jan 26, 2007
Messages
16
Reaction score
0
I'm obviously doing something wrong somewhere. I updated my server recently and it fixed a lot of bugs but the guards no longer work. You get basically a blank text window.

I tried rebuilding on a different machine and get the same result. So I setup a server from scratch using a recent build(3367) and now I can't even activate them. The mouse doesn't indicate that you can talk to them and right clocking gives the usual audible greeting but nothing else.

WTH am I missing?
 
Newbie Spellweaver
Joined
Feb 9, 2007
Messages
58
Reaction score
0
Did the ScriptName fields get changed/cleared in your DB?
Did you update (rebuild) the scripting system you use?
 
Newbie Spellweaver
Joined
Jan 26, 2007
Messages
16
Reaction score
0
Looking at the original repack and the current updated server the scripts seem to be the same and are in the same relative path. I can't find them mentioned in the database but I don't know where to look.
 
Newbie Spellweaver
Joined
Jan 26, 2007
Messages
16
Reaction score
0
:paperbag1

Never mind. I'm an idiot. I was testing the problem with the wrong group of %^&^& guards.

Move along folks. Nothing to see here.
 
Kaotic Owner
Loyal Member
Joined
Oct 12, 2005
Messages
1,282
Reaction score
70
fix is simple use a dif mangosscript or MaNGOSScript.dll the 312 kbs one is the best one out there also be sure to update the scirpts.sql to ur server.

i would use MaNGOSScript.dll over the mangos script lua cuz the lua has a fcked up agro system when u raid. and MaNGOSScript.dll u can add as much ai to ur creatures as u like in ur creature template.
 
Back
Top