Welcome!

Join our community of MMO enthusiasts and game developers! By registering, you'll gain access to discussions on the latest developments in MMO server files and collaborate with like-minded individuals. Join us today and unlock the potential of MMO server development!

Join Today!

Ascent [Help]Friends cannot get passed realmlist screen

Initiate Mage
Joined
Aug 5, 2008
Messages
4
Reaction score
0
I have followed a bunch of different guides of what the hell to do, but I ended up following one on Mmowned.com since i can't find any here that tell you how to put it online and set it up, but it told me to switch the Ascent files with Arcemu files, but with the same config files so it would run on 2.4.3..

But with or without the Ascent or Arcemu, they cannot get passed the god damn realmlist, it will just send them back to the realmlist screen when they click it, but I can get in perfectly fine. I have no clue what is wrong, and I turn to you guys as a last hope.

Here is my Realms.conf file, tell me if you need anything else. And the .servegame.org thing isn't just made up, I registered that at DynDNS following the guide as well to work as a wildcard with my external IP.

Realms.conf:
Code:
#######################################################################
# OpenAscent Realms Configuration File
# Last updated at revision 446 by Burlex
#######################################################################

/********************************************************************************
 * How to use this config file:                                                 *
 * Config files are in a block->variable->setting format.                       *
 * A < signifies the opening of a block, the block name is expected after that. * 
 * After the block name, a space and then the settings sperated by = / ' '.     *
 *                                                                              *
 * e.g.                                                                         *
 * <block setting="0" someval = "1">                                            *
 *                                                                              *
 * Comments can be in C format, e.g. /* some stuff */, with a // at the start   *
 * of the line, or in shell format (#).                                         *
 ********************************************************************************/

#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#
# LogonServer Section
#
#    Address:
#        The address (no port) of the server.
#
#    Port:
#        The port on which the logon server listens. (*** NOT 3724 ***)
#
#    Name:
#        Not really relavant, but name the logon.
#
#    RealmCount:
#        The number of realms in the next section.
#
#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#

<LogonServer Address = "worldofwaffles.servegame.org"
             Port = "8093"
             Name = "Default Logon"
             RealmCount = "2">

#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#
# Realm Section
#
#    Name:
#        The name of the realm.
#    
#    Address:
#        The address (and port) of that realm.
#
#    Icon:
#        The type of realm (PVP, Normal, RPPVP, RP)
#
#    TimeZone:
#        Time zone the realm is in.
#
#    Population:
#        (0 = low, 1 = medium, 2 = high)
#
#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#

<Realm1 Name = "World of Waffles!"
        Address = "24.24.146.197:8129"
        Icon = "PVP"
        Population = "1.0"
        TimeZone = "1">

<Realm2 Name = "Admin Only"
        Address = "24.24.146.197:8129"
        Icon = "PVP"
        Population = "1.0"
        TimeZone = "1">
 
Skilled Illusionist
Joined
Apr 6, 2008
Messages
389
Reaction score
1
Do me a favor and try changing this:

Code:
<LogonServer Address = "worldofwaffles.servegame.org"
             Port = "8093"
             Name = "Default Logon"
             RealmCount = "2">

to this:

Code:
<LogonServer Address = "127.0.0.1"
             Port = "8093"
             Name = "Default Logon"
             RealmCount = "2">

The logon server address should be internal, not external like it was, as it can cause problems.

Lemme know if it helped or not, please~
 
Junior Spellweaver
Joined
Mar 22, 2008
Messages
169
Reaction score
0
If you do it external and it doesn't have a really active connection it will drop the connection. 10 Seconds later it tries to reconnect. This can fail, 'cus the logonserver does it allready have it in his cache or something so he doesn't accept it. Like, the logonserver doesn't know he disconnected and the Worldserver saids Drop connection due Ping timeout.

Weard local IP adress though.

Code:
#######################################################################
# OpenAscent Realms Configuration File
# Last updated at revision 446 by Burlex
#######################################################################

/********************************************************************************
 * How to use this config file:                                                 *
 * Config files are in a block->variable->setting format.                       *
 * A < signifies the opening of a block, the block name is expected after that. * 
 * After the block name, a space and then the settings sperated by = / ' '.     *
 *                                                                              *
 * e.g.                                                                         *
 * <block setting="0" someval = "1">                                            *
 *                                                                              *
 * Comments can be in C format, e.g. /* some stuff */, with a // at the start   *
 * of the line, or in shell format (#).                                         *
 ********************************************************************************/

#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#
# LogonServer Section
#
#    Address:
#        The address (no port) of the server.
#
#    Port:
#        The port on which the logon server listens. (*** NOT 3724 ***)
#
#    Name:
#        Not really relavant, but name the logon.
#
#    RealmCount:
#        The number of realms in the next section.
#
#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#

<LogonServer Address = "[COLOR="Red"][B]127.0.0.1[/B][/COLOR]" // or Localhost
             Port = "8093"
             Name = "Default Logon"
             RealmCount = "2">

#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#
# Realm Section
#
#    Name:
#        The name of the realm.
#    
#    Address:
#        The address (and port) of that realm.
#
#    Icon:
#        The type of realm (PVP, Normal, RPPVP, RP)
#
#    TimeZone:
#        Time zone the realm is in.
#
#    Population:
#        (0 = low, 1 = medium, 2 = high)
#
#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#

<Realm1 Name = "World of Waffles!"
        Address = "[B][COLOR="Red"]worldofwaffles.servegame.org[/COLOR][/B]:8129"
        Icon = "PVP"
        Population = "1.0"
        TimeZone = "1">

<Realm2 Name = "Admin Only"
        Address = "24.24.146.197:8129" // i don't know if this is your external IP or your network IP. And i don't think its your localip.
        Icon = "PVP"
        Population = "1.0"
        TimeZone = "1">
 
Skilled Illusionist
Joined
Apr 6, 2008
Messages
389
Reaction score
1
Wow, KH, that's EXACTLY what I said..... Way to try and steal credit for my solution >.>
 
Back
Top