Welcome!

Join our community of MMO enthusiasts and game developers! By registering, you'll gain access to discussions on the latest developments in MMO server files and collaborate with like-minded individuals. Join us today and unlock the potential of MMO server development!

Join Today!

[Help]Mangos DB's

Newbie Spellweaver
Joined
Jan 7, 2007
Messages
8
Reaction score
0
2007-03-27 19:26:13 Using configuration file mangosd.conf.
2007-03-27 19:26:13 MaNGOS daemon /0.7-SVN (Win32)
2007-03-27 19:26:13 <Ctrl-C> to stop.


MM MM MM MM MMMMM MMMM MMMMM
MM MM MM MM MMM MMM MM MM MMM MMM
MMM MMM MMM MM MMM MMM MM MM MMM
MM M MM MMMM MM MMM MM MM MMM
MM M MM MMMMM MM MMMM MMM MM MM MMM
MM M MM M MMM MM MMM MMMMMMM MM MM MMM
MM MM MMM MM MM MM MMM MM MM MMM
MM MM MMMMMMM MM MM MMM MMM MM MM MMM MMM
MM MM MM MMM MM MM MMMMMM MMMM MMMMM
MM MMM
MMMMMM


2007-03-27 19:26:13 World Database: 76.166.245.220;3306;root;;mangos
2007-03-27 19:26:13 ERROR:Could not connect to MySQL database at 76.166.245.220: Host '76.166.245.220' is not allowed to connect to this MySQL server

2007-03-27 19:26:13 ERROR:Cannot connect to world database 76.166.245.220;3306;root;;mangos

this is the realmd.exe error...

2007-03-27 19:23:24 Using configuration file realmd.conf.
2007-03-27 19:23:24 MaNGOS realm daemon /0.7-SVN (Win32)
2007-03-27 19:23:24 <Ctrl-C> to stop.

2007-03-27 19:23:24 Database: 76.166.245.220;3306;root;;realmd
2007-03-27 19:23:24 ERROR:Could not connect to MySQL database at 76.166.245.220: Host '76.166.245.220' is not allowed to connect to this MySQL server

2007-03-27 19:23:24 ERROR:Cannot connect to database
 
Newbie Spellweaver
Joined
Mar 27, 2007
Messages
14
Reaction score
0
I have that same problem and anyone help us plz :p I would greatly appreceate it :p
 
Newbie Spellweaver
Joined
Dec 10, 2006
Messages
15
Reaction score
3
Use 127.0.0.1 for all ip like this: 127.0.0.1;3306;root;yourpass;realmd --for relamd and 127.0.0.1;3306;root;yourpass;mangos --for mangos
The password must be the same with your database password.
 
Experienced Elementalist
Joined
Feb 25, 2007
Messages
228
Reaction score
0
LoginDatabaseInfo = "127.0.0.1;3306;root;PASS;realmd"
WorldDatabaseInfo = "127.0.0.1;3306;root;PASS;mangos"
 
Newbie Spellweaver
Joined
Mar 27, 2007
Messages
14
Reaction score
0
Now that I did that it now the error is

2007-03-27 19:41:51 Database: 127.0.0.1;3306;root;42862588;realmd
2007-03-27 19:41:51 ERROR:SQL: SELECT `id`, `name`,`address`,`port`,`icon`,`color`,`timezone` FROM `realmlist` ORDER BY `name`
2007-03-27 19:41:51 ERROR:query ERROR: Table 'realmd.realmlist' doesn't exist
2007-03-27 19:41:51 ERROR:No valid realms specified.

What does it mean what do I got too do?
 
Newbie Spellweaver
Joined
Jan 7, 2007
Messages
8
Reaction score
0
first i would appriciate it if you didnt ask for help in my help thread becuase im asking for help second im running 1.12.1 becuz all TBC servers are being shutdown becuz of blizzard thrid the 127.0.0.1 only works if you are going to play single player nub if you want it to be publich it has to be your lan ip thats why im asking for help becuz the .exe's arent connecting to the db's
 
Newbie Spellweaver
Joined
Feb 9, 2007
Messages
58
Reaction score
0
I'd recommend starting from scratch instead of trying to undo any number of changes you may have made so far. Get the server working with the default localhost settings, and then modify from there.

Remove/disable any firewall applications until you have a working server. You can install and configure them to allow access after your server is working.

Edit your realmd DB in SQL, select the realmlist table, and set the address field to your external IP/name.

Configure you router (if applicable) to foward internet trafic (on ports 3306, 3724, and 8085) to your internal server IP.

Other players will need to change their realmlist.wtf to your external IP before they can connect.
 
Newbie Spellweaver
Joined
Jan 7, 2007
Messages
8
Reaction score
0
ok i did what you said but it still doesnt work for lan im getting same error although i can connect when the .conf files are 127.0.0.1
 
Initiate Mage
Joined
Apr 1, 2007
Messages
2
Reaction score
0
you need to go into your sql manager and set permissions for the account your using to access the database. i had the same problem for a week and that fixed it
 
Newbie Spellweaver
Joined
Feb 9, 2007
Messages
58
Reaction score
0
Now you can connect locally, you're halfway there... with the proper database permissions.

Leave the conf files set to the default 127.0.0.1 values.

For a Solo server: Edit your realmd DB in SQL, select the realmlist table, and set the address to 127.0.0.1 or localhost.
For a LAN server: Edit your realmd DB in SQL, select the realmlist table, and set the address to the servers LAN IP/name.
For a Internet server: Edit your realmd DB in SQL, select the realmlist table, and set the address to the servers external IP/name.

Make sure the dbinfo field matches the WorldDatabaseInfo listed in your mangosd.conf ("127.0.0.1;3306;root;mangos;mangos" was the default for most distros), and you should be set.

As an example for a LAN, here is the LAN config I often use for testing my diskw creations:
Code:
realmd.conf
LoginDatabaseInfo = "127.0.0.1;3306;root;mangos;realmd"
 
mangosd.conf
LoginDatabaseInfo = "127.0.0.1;3306;root;mangos;realmd"
WorldDatabaseInfo = "127.0.0.1;3306;root;mangos;mangos"
 
realmlist table in realmd DB
1 Server-1 192.168.0.2 8085 1 0 0 127.0.0.1;3306;root;mangos;mangos
Configure the realmlist.wtf on each client to 192.168.1.2 (match the address field from the realmlist table in realmd DB), and you're all set.

Replace the 192.168.0.2 from this example, with the LAN IP of your server, and enjoy... so long as you aren't blocking access with some form of firewall/security application.

NOTES: If you change the password for your database, be sure to update it in your conf files and realmd DB.

Some home/office routers do not fully support loopback, so hosting Internet and LAN play may require a static route to be configured on the router to allow both access at the same time.
 
Back
Top