Welcome!

Join our community of MMO enthusiasts and game developers! By registering, you'll gain access to discussions on the latest developments in MMO server files and collaborate with like-minded individuals. Join us today and unlock the potential of MMO server development!

Join Today!

[Help] WampServer Orange

Skilled Illusionist
Joined
Dec 7, 2012
Messages
304
Reaction score
4
Hello, If anyone can help me out I'm trying to fix my Wampserver to go Green but I've tried multiple things but It hasn't changed anything.

Things I tried was downloading Visual C++ and than trying to install Apache Service inside of it but that won't even work saying "The application was unable to start correctly (0xc000007b). "

Does anyone know the Solution to this ?
 
至死不渝
Joined
Dec 31, 2008
Messages
454
Reaction score
33
If I'm not wrong, Wampserver doesn't go green because for it to go green, it needs to have its built in mysql server running and you probably installed a stand-alone version of mysql already so the one with wamp doesn't run. As far as the colour is concerned, I have always been able to host a server even if it's orange.
 
Upvote 0
Experienced Elementalist
Joined
Aug 24, 2012
Messages
280
Reaction score
101
Well, you should at least have MySQL and other things with the Wampserver regardless.

Also, even after you do that, if it's still orange. Go into Apache > http.conf and scroll down till you see Listen: 80. Change it to 81.
 
Upvote 0
Skilled Illusionist
Joined
May 28, 2011
Messages
379
Reaction score
38
Also, don't forget to sign off Skype, or change the preferences to not use port 80. If your wamp server is orange, then something is using port 80.
 
Upvote 0
Junior Spellweaver
Joined
Apr 30, 2010
Messages
141
Reaction score
18
If I'm not wrong, ... As far as the colour is concerned, I have always been able to host a server even if it's orange.

Mine is orange too by the way and it is working fine xD. But you can try these solutions out if you want.

1. If you have skype, it is probably your Skype giving you a hard time.
Try configuring your Skype this way:

Tools -> Options -> Advanced -> Connection -> Unchecking the 'Use port 80...'

2. If you don't have skype,

left click on the WAMP icon Apache -> Service, I saw that the start/stop service was grayed out.

So, I clicked on "Install service" Apache -> Service -> Install Service.
 
Upvote 0
Skilled Illusionist
Joined
May 28, 2011
Messages
379
Reaction score
38
It's also possible to have issues like this if you install the newer MySQL Community Server 5.5. Which is why I suggest sticking to 5.1. This is only because Wamp, and MySQL Community Server 5.5 do not play nice together, and the default MySQL settings in Wamp override the installed service you have if you installed MySQL Community Server 5.5.
 
Upvote 0
Custom Title Activated
Member
Joined
Mar 6, 2012
Messages
1,503
Reaction score
213
Did you install visual c++ sp1 2008
If its not sp1, it will not fix it. It's 2008 or 2005 or 2010. I forgot.
 
Upvote 0
Experienced Elementalist
Joined
Aug 24, 2012
Messages
280
Reaction score
101
I've never had any type of interference with Skype and WAMP.

I haven't for awhile. Normally Skype is automatically using ports that no other program would, so it shouldn't have any conflict at all.

However, you can try and test to see if it is.

Regarding the it still being orange and still being online, I guess there is no problem at all then.

I would try and get it to be green though just to make sure.
 
Upvote 0
Skilled Illusionist
Joined
May 28, 2011
Messages
379
Reaction score
38
I've never had any type of interference with Skype and WAMP.

I haven't for awhile. Normally Skype is automatically using ports that no other program would, so it shouldn't have any conflict at all.

However, you can try and test to see if it is.

Regarding the it still being orange and still being online, I guess there is no problem at all then.

I would try and get it to be green though just to make sure.
You're an odd case. Wamp uses port 80. Also, Skype uses port 80, unless you tell it not to. There is obviously going to be a conflict. You must have changed your wamp config file or your Skype settings a long time ago, and just don't remember. You can start Wamp, and then start Skype, with no issues. However, starting Skype first will always result in issues.
 
Upvote 0
Experienced Elementalist
Joined
Aug 24, 2012
Messages
280
Reaction score
101
You're an odd case. Wamp uses port 80. Also, Skype uses port 80, unless you tell it not to. There is obviously going to be a conflict. You must have changed your wamp config file or your Skype settings a long time ago, and just don't remember.

Well, like I had posted earlier, I changed the Listen:80 to 81. So that might be the case.
 
Upvote 0
Experienced Elementalist
Joined
Jan 16, 2013
Messages
284
Reaction score
53
Changing the port that WAMP uses never fixed the problem for me. My previous ISP force blocked the opening of port 80 and 8080, and I know this because I was able to open every other port.

You can try it for yourself, hopefully it works. You must make sure that WAMP is the first thing that is executed upon startup on your computer. Skype and some other programs use port 80, so don't let Skype or these other programs be in the default startup list (Start > Run > 'msconfig')
 
Upvote 0
Skilled Illusionist
Joined
Dec 7, 2012
Messages
304
Reaction score
4
Mine is orange too by the way and it is working fine xD. But you can try these solutions out if you want.

1. If you have skype, it is probably your Skype giving you a hard time.
Try configuring your Skype this way:

Tools -> Options -> Advanced -> Connection -> Unchecking the 'Use port 80...'

2. If you don't have skype,

left click on the WAMP icon Apache -> Service, I saw that the start/stop service was grayed out.

So, I clicked on "Install service" Apache -> Service -> Install Service.

Yeah I tried doing that and I installed MySql Workbench CE 5.2 and it`s still orange besides that, When I try to download the Service for Apache it brings up a Error
 
Upvote 0
Back
Top