Welcome!

Join our community of MMO enthusiasts and game developers! By registering, you'll gain access to discussions on the latest developments in MMO server files and collaborate with like-minded individuals. Join us today and unlock the potential of MMO server development!

Join Today!

Help with Hotuk.ini

Initiate Mage
Joined
Feb 18, 2007
Messages
69
Reaction score
0
I can't connect to my Private Server using the McMadness repack. Registry IP set to 127.0.0.1 for testing.

Tell me what I am missing please :)
Code:
*GAME_SERVER TestPT 127.0.0.1 127.0.0.1 127.0.0.1
*CLAN_SERVER 127.0.0.1 80 127.0.0.1 80 127.0.0.1 80 
*MODE SERVER
*SERVER_CODE 0
*SERVER_NAME TestPT
//*VERSION 1850
*SERVER_AUTOPLAY
*Enable_Clan
*MAX_USERS 1000
*ENABLE_PARTYITEM
*SERVER_RECORD_MEM
//*EVENT_EXPUP 1
*CHECK_POTION_COUNT 100000
*CLIENT_CHECK_PROCESS_TIME 10
//*CLIENT_PROCESS_TIME_OUT
//*ENABLE_SERVER_EXP 100000000
// [ Event Stuff ] to disable an event just put // at the begin of the line
*EVENT_EXPUP 1
*EVENT_POTION 5
*EVENT_BITMASK 32
*EVENT_BLESSCASTLE 
*EVENT_SUMMER_CHICKEN 
//*EVENT_SANTAGOBLIN
*EVENT_GHOST
//*EVENT_MOLLYWOLF
*EVENT_MORIFSHELTOM
//*EVENT_WHITEDAY
//*EVENT_VALENTINEDAY
//*EVENT_NINEFOX
*EVENT_BABELHORN 
//*EVENT_PUZZLE
//*EVENT_BIRTHDAY
//*EVENT_STARPOINT
//*EVENT_CRISTAL
//*EVENT_CHILD
//*EVENT_DAMAGEOFF //?
*EVENT_HARDCORE
*EVENT_MANDOO
*ENABLE_PK 1
*PK_FIELD 9
 

*CLIENT_CHECK_FUNC 0
*BLOCK_LEVEL 1
*DISCONNECT_ITEM_ERROR 1
*CONNECT_CLIENT_CODE
*REMOVE_PROTECT_TIME
//Tax  rate (lv * tax = price to enter)
*BELATRA_TAX 1000 1
*BELATRA_TEXT_ERROR "Bellatra Text Error"
//Round  1,2,3
*BELATRA_MONSTER "SOD_Crypt" 40 "SOD_Buma" 40 "SOD_Armored Beetle" 40 "SOD_Skeleton Ranger" 40 "SOD_Vega Demir" 40
*BELATRA_MONSTER "SOD_Cyclops Knight" 40 "SOD_Greven" 40 "SOD_Titan" 40 "SOD_Avelisk-S" 40 "SOD_HellSing" 40
*BELATRA_MONSTER "SOD_Skeleton Knight" 40 "SOD_Mummy" 40 "SOD_Slaughter" 40 "SOD_Skeleton Ranger" 40 "SOD_Cursed Web" 40
//Round  4,5,6
*BELATRA_MONSTER "SOD_Muffin" 40 "SOD_Solid Snail" 40 "SOD_Dark Knight" 40 "SOD_BeEvil" 40 "SOD_Slayon" 30
*BELATRA_MONSTER "SOD_Figon" 40 "SOD_Illusion Knight" 40 "SOD_Slaughter" 40 "SOD_Mummy" 40 "SOD_Unseen" 30
*BELATRA_MONSTER "SOD_Heavy Goblin" 40 "SOD_Stone Golem" 40 "SOD_Doom Guard" 40 "SOD_Witch" 40 "SOD_Doom Lord" 30
//Round  7,8
*BELATRA_MONSTER "SOD_Sliver" 40 "SOD_Dusk" 40 "SOD_Hulk" 40 "SOD_Dawlin" 40 "SOD_Morgonyte" 20
*BELATRA_MONSTER "SOD_DeadZone" 40 "SOD_Avelin Queen" 40 "SOD_Chain Golem" 40 "SOD_Sadness" 40 "SOD_Shadow Phalanx" 20
 
*CONNECT_CLIENT_CODE    940236431
*CLSAFE_CODE        940236431

*BACKUP_FOLDER_NAME "c:\databasebackup"
*BACKUP_PATH "c:\databasebackup"
*CLIENT_CHECK_FUNC 1
*BLOCK_LEVEL 1
//*DISCONNECT_ITEM_ERROR 1
//*DEBUG_IP 127.0.0.1 127.0.0.1 127.0.0.1
//*ADMINISTRATOR_IP 127.0.0.1
//*ADMIN_IP 127.0.0.1
 
*DEBUG_ID Test
*RECORD_JOBCHANGER
*REC_ADMIN_CMD
*ADMIN_NAME "TestUser"
*ADMIN_COMMAND "lvl1"
*ADMIN_COMMAND "lvl2"
*ADMIN_COMMAND "lvl3"
//*GAME_SERVER Test 127.0.0.1 127.0.0.1 127.0.0.1
 
Initiate Mage
Joined
Feb 18, 2007
Messages
69
Reaction score
0
*Bump*

15 Views and no one see's anything wrong with my Hotuk.ini?
 

SiK

Custom Title Activated
Member
Joined
Sep 10, 2006
Messages
2,099
Reaction score
7
ditch these:
*CLIENT_CHECK_FUNC 0
*BLOCK_LEVEL 1
*DISCONNECT_ITEM_ERROR 1
*CONNECT_CLIENT_CODE
*CONNECT_CLIENT_CODE 940236431
*CLSAFE_CODE 940236431
*CLIENT_CHECK_FUNC 1
*BLOCK_LEVEL 1

If you still cant connect check your firewall / router settings, forward ports 10003, 10007, 10009. May also want to try your LAN/WAN IP in all required IP fields.
 
Initiate Mage
Joined
Feb 18, 2007
Messages
69
Reaction score
0
I have setup a private server using the jPT files/guide, but using McMadness repack...dunno what I have to do different. I will try removing those lines when I get home. Also it is said that Clients 1847-1855 work with this repack, does that mean both ePT and kPT clients? Also the ports shouldn't matter since I am connecting to HOME(127.0.0.1) doesn't even touch the router.
 
Master Summoner
Joined
Mar 24, 2007
Messages
514
Reaction score
0
true because isnt the 127.0.0.1 your local ip that doesnt go to your router?

try port triggering... if that doesnt work try your router ip other than local.
 
Last edited:
Initiate Mage
Joined
Feb 18, 2007
Messages
69
Reaction score
0
127.0.0.1 should NOT go to your router and does not. It is a loopback address.
 
Master Summoner
Joined
Mar 24, 2007
Messages
514
Reaction score
0
whats your computer mac address?
and what kind of router do you have and what modem model?
 
Initiate Mage
Joined
Feb 18, 2007
Messages
69
Reaction score
0
Just informing you, thought you didn't know. Knowledge is power my friend =)
 
Back
Top