Welcome!

Join our community of MMO enthusiasts and game developers! By registering, you'll gain access to discussions on the latest developments in MMO server files and collaborate with like-minded individuals. Join us today and unlock the potential of MMO server development!

Join Today!

Map data missing

Ben

Developer - JS
Developer
Joined
Jul 6, 2013
Messages
1,222
Reaction score
503
Hey guys i'm having a little problem... based on @343 's post of how to clone a map http://forum.ragezone.com/f695/cloning-clone-map-871130/

i tried to clone map is06 i've done the changes that are told in the thread and tried to get inside tho this is what i did and the error message i got..

If anyone could help out where the error is made as i assume that it is a clientsided error and not server based tho i could already be wrong on that part.

********gs.conf*******

Code:
[Instance_custommap]
index             =     91
tag            =    130
base_path        =    custommap/
limit               =        nofly;clear-ap;allow-root;nomount;no-bind;lowjump;
grid            =    {80,80,25,-1000.0,-1000.0}
base_region        =    {-512.0,-512.0} , {512,512.0}
local_region        =    {-512.0,-512.0} , {512,512.0}
save_point              =       106,-385.643,334.408,327.777
;ÏÂÃæÊǸ±±¾µÄ²ÎÊýÉ趨 Íæ¼ÒÊýÄ¿µÈ¶¼Êǹ«ÓõÄ
player_per_instance     =       6
player_capacity         =       3000
npc_count               =       65536
matter_count            =       131072
instance_capacity       =       100
pool_threshold_low      =       10
pool_threshold_high     =       20
;¸±±¾ÀïÌØÊâplayerÂß¼­£¬Í¨¹ýÖƶ¨playerÂß¼­µÄÈý¸ö²¿·ÖµÄcidÀ´Íê³É
;Õ⼸¸öÖµµÃÉ趨·Ç³£Ãô¸Ð£¬²»ÄÜËæÒâÉ趨£¬Óë³ÌÐò´úÂëñîºÏÐԷdz£Ç¿
cid            =    0,2,13


[Terrain_custommap]
szMapPath        = map
nAreaWidth         = 512
nAreaHeight         = 512
nNumAreas         = 1
nNumCols         = 1
nNumRows         = 1
vGridSize         = 2.0f
vHeightMin         = 0.0f
vHeightMax         = 800.0f


[MsgReceiverTCP_custommap]
type            =    tcp
listen_addr        =    CUSTOMMAP:10940
so_sndbuf        =    16384
so_rcvbuf        =    16384
tcp_nodelay        =    1
listen_backlog        =    10


[MsgReceiverUNIX_custommap]
type            =    unix
listen_addr        =    /tmp/gssock_custommap
so_sndbuf        =    16384
so_rcvbuf        =    16384
listen_backlog        =    10

Code:
instance_servers    = is05;is06;is07;is08;is09;is10;is11;is14;is15;is16;is17;is23;is24;is25;is26;is27;is28;is29;bg01;bg02;bg03;bg04;bg05;bg06;is31;is35;is38;is39;is41;is44;is45;is46;is47;is48;is49;is62;is66;is67;custommap;

*******gsalias*******

Code:
instance_servers    =    is05;is06;is07;is08;is09;is10;is11;is14;is15;is16;is17;is23;is24;is25;is26;is27;is28;is29;bg01;bg02;bg03;bg04;bg05;bg06;is31;is35;is38;is39;is41;is44;is45;is46;is48;is49;is62;is66;is67;is47;custommap;

Code:
CUSTOMMAP=game2

********configs/instance.txt******

Code:
//////////////////////////////////////////////////////////////"custommap"
{
236        //  ID
"custommap"        //  path
1, 1        //  row, column
1
""
}


//////////////////////////////////////////////////////////////

In surfaces/maps i've added custommap.dds and in litmodels also a map called custommap.

and on tasks the teleport req.
Ben - Map data missing - RaGEZONE Forums


Now when i try to teleport into the instance i get the following message:

Ben - Map data missing - RaGEZONE Forums
 
RaGEaholic
Joined
Jul 12, 2011
Messages
622
Reaction score
149
Hey guys i'm having a little problem... based on @343 's post of how to clone a map http://forum.ragezone.com/f695/cloning-clone-map-871130/

i tried to clone map is06 i've done the changes that are told in the thread and tried to get inside tho this is what i did and the error message i got..

If anyone could help out where the error is made as i assume that it is a clientsided error and not server based tho i could already be wrong on that part.

********gs.conf*******

Code:
[Instance_custommap]
index             =     [COLOR="#00FF00"]91[/COLOR]
tag            =    [COLOR="#FF0000"]130[/COLOR]
base_path        =    custommap/
limit               =        nofly;clear-ap;allow-root;nomount;no-bind;lowjump;
grid            =    {80,80,25,-1000.0,-1000.0}
base_region        =    {-512.0,-512.0} , {512,512.0}
local_region        =    {-512.0,-512.0} , {512,512.0}
save_point              =       106,-385.643,334.408,327.777
;ÏÂÃæÊǸ±±¾µÄ²ÎÊýÉ趨 Íæ¼ÒÊýÄ¿µÈ¶¼Êǹ«ÓõÄ
player_per_instance     =       6
player_capacity         =       3000
npc_count               =       65536
matter_count            =       131072
instance_capacity       =       100
pool_threshold_low      =       10
pool_threshold_high     =       20
;¸±±¾ÀïÌØÊâplayerÂß¼­£¬Í¨¹ýÖƶ¨playerÂß¼­µÄÈý¸ö²¿·ÖµÄcidÀ´Íê³É
;Õ⼸¸öÖµµÃÉ趨·Ç³£Ãô¸Ð£¬²»ÄÜËæÒâÉ趨£¬Óë³ÌÐò´úÂëñîºÏÐԷdz£Ç¿
cid            =    0,2,13


[Terrain_custommap]
szMapPath        = map
nAreaWidth         = 512
nAreaHeight         = 512
nNumAreas         = 1
nNumCols         = 1
nNumRows         = 1
vGridSize         = 2.0f
vHeightMin         = 0.0f
vHeightMax         = 800.0f


[MsgReceiverTCP_custommap]
type            =    tcp
listen_addr        =    CUSTOMMAP:[COLOR="#00FF00"]10940[/COLOR]
so_sndbuf        =    16384
so_rcvbuf        =    16384
tcp_nodelay        =    1
listen_backlog        =    10


[MsgReceiverUNIX_custommap]
type            =    unix
listen_addr        =    /tmp/gssock_custommap
so_sndbuf        =    16384
so_rcvbuf        =    16384
listen_backlog        =    10

Code:
instance_servers    = is05;is06;is07;is08;is09;is10;is11;is14;is15;is16;is17;is23;is24;is25;is26;is27;is28;is29;bg01;bg02;bg03;bg04;bg05;bg06;is31;is35;is38;is39;is41;is44;is45;is46;is47;is48;is49;is62;is66;is67;custommap;

*******gsalias*******

Code:
instance_servers    =    is05;is06;is07;is08;is09;is10;is11;is14;is15;is16;is17;is23;is24;is25;is26;is27;is28;is29;bg01;bg02;bg03;bg04;bg05;bg06;is31;is35;is38;is39;is41;is44;is45;is46;is48;is49;is62;is66;is67;is47;custommap;

Code:
CUSTOMMAP=game2

********configs/instance.txt******

Code:
//////////////////////////////////////////////////////////////"custommap"
{
[COLOR="#FF0000"]236        [/COLOR]//  ID
"custommap"        //  path
1, 1        //  row, column
1
""
}


//////////////////////////////////////////////////////////////

In surfaces/maps i've added custommap.dds and in litmodels also a map called custommap.

and on tasks the teleport req.
Ben - Map data missing - RaGEZONE Forums


Now when i try to teleport into the instance i get the following message:

Ben - Map data missing - RaGEZONE Forums

Have to be the same number.


Can't be the same as any other maps
 
  • Like
Reactions: Ben
Upvote 0

Ben

Developer - JS
Developer
Joined
Jul 6, 2013
Messages
1,222
Reaction score
503
Quite obvious, but did you actually start the map before attempting this? Not starting it beforehand happened to me more times than i'd like to admit.

Yea the map was open because if it was closed the teleport quest would fail but it didn't. It is acting like entering but then it goes that way

Crxfreak ill try to do those changes when im back
 
Upvote 0

Ben

Developer - JS
Developer
Joined
Jul 6, 2013
Messages
1,222
Reaction score
503
Okay so i tried what crxfreak said and it turned out so its porting me into the cave :) thanks for that

Now i assume i've forgot some files on client side as:

Ben - Map data missing - RaGEZONE Forums
******* Client sided logs *******

Code:
[17:54:36.026] <!> CECWorld::LoadWorld: File operation error. (line: 561)


[17:54:39.105] <!> CECOrnament::LoadInThread, Failed to load LitModels\custommap\1\litmodel_33.bmd


[17:54:39.105] <!> CECOrnament::LoadInThread, Failed to load LitModels\custommap\1\litmodel_5.bmd


[17:54:39.105] <!> CECOrnament::LoadInThread, Failed to load LitModels\custommap\1\litmodel_167.bmd


[17:54:39.105] <!> CECOrnament::LoadInThread, Failed to load LitModels\custommap\1\litmodel_161.bmd


[17:54:39.105] <!> CECOrnament::LoadInThread, Failed to load LitModels\custommap\1\litmodel_162.bmd


[17:54:39.105] <!> CECOrnament::LoadInThread, Failed to load LitModels\custommap\1\litmodel_166.bmd


[17:54:39.105] <!> CECOrnament::LoadInThread, Failed to load LitModels\custommap\1\litmodel_2.bmd


[17:54:39.105] <!> CECOrnament::LoadInThread, Failed to load LitModels\custommap\1\litmodel_3.bmd


[17:54:39.105] <!> CECOrnament::LoadInThread, Failed to load LitModels\custommap\1\litmodel_4.bmd


[17:54:39.105] <!> CECOrnament::LoadInThread, Failed to load LitModels\custommap\1\litmodel_9.bmd


[17:54:39.106] <!> CECOrnament::LoadInThread, Failed to load LitModels\custommap\1\litmodel_168.bmd


[17:54:39.106] <!> CECOrnament::LoadInThread, Failed to load LitModels\custommap\1\litmodel_169.bmd


[17:54:39.106] <!> CECOrnament::LoadInThread, Failed to load LitModels\custommap\1\litmodel_170.bmd


[17:55:34.747] <!> exit process because failed to load building

It fails to load either tho i have added the litmodels from the original folder to the new one and named it custommap

Checking the other .pck files right now as i assume most likely will need those too.

Any suggestion is welcome.
 
Upvote 0

Ben

Developer - JS
Developer
Joined
Jul 6, 2013
Messages
1,222
Reaction score
503
Is it a map from PW or from another game?

PW it originally is map is06 i copied the GS part over and pasted it again on the bottom, that part is all working fine now! it is just the graphic and the client crash that is left to fix.

In the guide was said just copy the litmodels and instead of calling the map is06 its called the new name that what i did and then repacked the litmodels.
 
Upvote 0
Back
Top