Welcome!

Join our community of MMO enthusiasts and game developers! By registering, you'll gain access to discussions on the latest developments in MMO server files and collaborate with like-minded individuals. Join us today and unlock the potential of MMO server development!

Join Today!

Strange dependencies with cabal.rpm

Newbie Spellweaver
Joined
Jul 23, 2008
Messages
10
Reaction score
0
On a cliean centos os reinstall with all dependencies unixODBC openssl097a db4 etc. i am getting these dependencies.And yes every other rpm was extracted before cabal.rpm Never saw it before any ideas?

[root@cabal ~]# rpm -Uvh cabal.rpm
error: Failed dependencies:
libcrypto.so.4 is needed by cabal-chnserverCB-1.0-2.i386
libssl.so.4 is needed by cabal-chnserverCB-1.0-2.i386
[root@cabal ~]# cd /
[root@cabal /]# yum install openssl097a db4
Setting up Install Process
Parsing package install arguments
Package openssl097a - 0.9.7a-9.x86_64 is already installed.
Package db4 - 4.3.29-9.fc6.x86_64 is already installed.
Package db4 - 4.3.29-9.fc6.i386 is already installed.
Nothing to do
 
Newbie Spellweaver
Joined
Feb 16, 2008
Messages
70
Reaction score
2
[darkstar]# rpm -Uvh --force --nodeps cabal.rpm
[darkstar]# wget
[darkstar]# rpm -Uvh --nodeps --force openssl097a-0.9.7a-9.i386.rpm


saludos!
 
Upvote 0
Newbie Spellweaver
Joined
Jul 23, 2008
Messages
10
Reaction score
0
guybrush sorry but you phail :) forgot that on dedi proc is x64 while using yum u get i386 package
Solution to this prob:
google for x64_x86 openssl package
 
Upvote 0
Experienced Elementalist
Joined
Sep 10, 2006
Messages
213
Reaction score
1
like you are not install freetds-odbc.....rpm, install that first
 
Upvote 0
Newbie Spellweaver
Joined
Jul 23, 2008
Messages
10
Reaction score
0
holishit plox read the first post all casual dependencies were already installed on the system

Crap still didint fix the prob after installing openssl097a_x64_x86.rpm
still getting damn dependency on libcrypto.so.4 and libssl.so.4
any ideas?
 
Upvote 0
Newbie Spellweaver
Joined
Feb 16, 2008
Messages
70
Reaction score
2
guybrush sorry but you phail :) forgot that on dedi proc is x64 while using yum u get i386 package
Solution to this prob:
google for x64_x86 openssl package

its the same my friend, its like win x64 and x32.

soft x64 just on x64, soft i386 any machine in the world.

chears.
 
Upvote 0
Newbie Spellweaver
Joined
Jul 23, 2008
Messages
10
Reaction score
0
damnt its killing me, openssl097a db4 unixodb everything is installed but god damnt it it somehow doesnt see libssl.so.4 and libcrypto.so.4
so like theyre not installed

proc intel quad core. x64
centos running in x64 comp mode

maybe something to do with other packages along with cabal.rpm they come with i386.arch
centosdvd_x86_x64

Just and idea cabal.rpm checks /usr/lib or /lib64 ?
 
Upvote 0
Newbie Spellweaver
Joined
Jul 23, 2008
Messages
10
Reaction score
0
both .so libs were in /usr/lib64 copied em to /usr/lib but still no luck,getting failed dependencies
 
Upvote 0
Back
Top