create character

Newbie Spellweaver
Joined
Oct 29, 2004
Messages
51
Reaction score
4
ok here is the log,

I can connect to the server but when I go to create a character I put the name in and click create and the name disappears and nothing happens the character is not made..

[Wed Nov 26 2008 17:52:48.754594 3044064160]: Database Connect success!
[Wed Nov 26 2008 17:52:48.820185 3075533728]: Database Connect success!
[Wed Nov 26 2008 17:52:48.865593 3065043872]: Database Connect success!
[Wed Nov 26 2008 17:52:49.163898 3054554016]: Database Connect success!
[Wed Nov 26 2008 17:53:09.658061 3086023584]: Database Connect success!
[Wed Nov 26 2008 17:53:41.973787 3044064160]: [##ERROR##] OnIPCNewMyChartr fail (CharacterIdx: 16)
[Wed Nov 26 2008 17:53:41.975984 3044064160]: [##ERROR##] DB ERROR(MSG) : [FreeTDS][SQL Server][DBNETLIB][ConnectionOpen (Connect()).]SQL Server does not exist or access denied.
[Wed Nov 26 2008 17:53:41.976824 3044064160]: [##ERROR##] DB ERROR(CODE) : 17
[Wed Nov 26 2008 17:53:41.977448 3044064160]: [##ERROR##] DB ERROR(VAR_INFO) :
[Wed Nov 26 2008 17:53:41.977873 3044064160]: [##ERROR##] DB ERROR(SQLSTATE) : 42000
[Wed Nov 26 2008 17:53:41.978472 3044064160]: [##ERROR##] DB ERROR(STM_TEXT) : {call cabal_sp_newchar( ? , ? , ? , ? )}
[Wed Nov 26 2008 17:53:42.234672 3044064160]: Database Connect success!
[Wed Nov 26 2008 17:53:46.126230 3086027328]: SIGTERM
3086027328: work_pending_i: Interrupted system call
[Wed Nov 26 2008 17:53:46.265760 3044064160]: CProcessLayer(0)::svc Terminated [3044064160]
[Wed Nov 26 2008 17:53:46.274042 3075533728]: [##ERROR##] getq fail (108)
[Wed Nov 26 2008 17:53:46.274412 3075533728]: CProcessLayer(0)::svc Terminated [3075533728]
[Wed Nov 26 2008 17:53:46.279206 3054554016]: [##ERROR##] getq fail (108)
[Wed Nov 26 2008 17:53:46.279541 3054554016]: CProcessLayer(0)::svc Terminated [3054554016]
[Wed Nov 26 2008 17:53:46.280222 3086023584]: [##ERROR##] getq fail (108)
[Wed Nov 26 2008 17:53:46.280446 3086023584]: CProcessLayer(0)::svc Terminated [3086023584]
[Wed Nov 26 2008 17:53:46.289600 3065043872]: [##ERROR##] getq fail (108)
[Wed Nov 26 2008 17:53:46.289909 3065043872]: CProcessLayer(0)::svc Terminated [3065043872]

can anyone tell me what may be wrong?

thanks
 
SQL Server does not exist or access denied.

Seems pretty clear to me. If you can get past the login screen then there is at least a partial connection as it is authing your password so i would guess this is the linked server settings as it goes through the linked server to create chars. Try checking the security settings on the linked server properties and make sure the tickboxes are ticked.
 
Upvote 0
ok now I am getting this error while trying to create a character:

[Thu Nov 27 2008 20:53:55.670358 3065109408]: [##ERROR##] OnIPCNewMyChartr fail (CharacterIdx: 8)
[Thu Nov 27 2008 20:53:55.670788 3065109408]: [##ERROR##] DB ERROR(MSG) : [FreeTDS][SQL Server]Named Pipes Provider: Could not open a connection to SQL Server [53].
[Thu Nov 27 2008 20:53:55.670989 3065109408]: [##ERROR##] DB ERROR(CODE) : 53
[Thu Nov 27 2008 20:53:55.671195 3065109408]: [##ERROR##] DB ERROR(VAR_INFO) :
[Thu Nov 27 2008 20:53:55.671357 3065109408]: [##ERROR##] DB ERROR(SQLSTATE) : 42000
[Thu Nov 27 2008 20:53:55.671514 3065109408]: [##ERROR##] DB ERROR(STM_TEXT) : {call cabal_sp_newchar( ? , ? , ? , ? )}
[Thu Nov 27 2008 20:53:55.736899 3065109408]: Database Connect success!

I have reinstalled once with sql 2000 and once with 2005 I am now using SQL 2005 and all permissions are set

I can connect with the website and create my account..
I can telnet into the sql from the CentOS VM
I log on with the client just fine but I cannot create a new character..
remote connections are enabled I have no idea what is causing this I do not have a fire wall installed and the windows firewall is disabled (the exceptions have been added even though it is not functioning)

btw thanks chumpy for ur help with the other issue maybe ur smart enough to figure this one out LOL!!
 
Upvote 0
Basically this is the same thing that's happening to me as well, and I tried with 2000 and 2005 but i'm going to 2005 again because 2000 is damaged for the install =\
 
Upvote 0
ok I fixed this problem..

the gameserver linked server was setup wrong.. there is a link on here that will tell u how to set it up.. just do a search for GAMESERVER and it will show..

hey chumpy thanks for all the help man!!
 
Upvote 0
Back