[EP33] Docker repack

Code:
[2025-04-20 20:16:25.607242 140545204672192]: [##ERROR##] 'OnCSCNewMyChartr' fail (Proc/Character.cpp:569)
[2025-04-20 20:16:25.607301 140545204672192]: [##ERROR##] UsrMap Fail : MainCmd(134) Ret(60239:6:569) Addr(192.168.0.3) CharIdx(0)
[2025-04-20 20:16:25.607360 140545204672192]: close(): closing(192.168.0.3)
[2025-04-20 20:16:25.607416 140545204672192]: 1.close user -1 [2972B8C0] (192.168.0.3)
[2025-04-20 20:18:41.615717 140545187886784]: [HeartBeat] Response : Addr(127.0.0.1:38190)
[2025-04-20 20:19:03.895764 140545179494080]: [HeartBeat] Response : Addr(127.0.0.1:38140)
[2025-04-20 20:19:04.725849 140545356265856]: success accept 177(192.168.0.3:63889)
[2025-04-20 20:19:04.726017 140545356265856]: 1.open user 177 [2972B8C0] (192.168.0.3)
[2025-04-20 20:19:04.726846 140545356265856]: [Security] Connect From User(192.168.0.3:63889)
[2025-04-20 20:19:04.728535 140545179494080]: [Auth] C2S_VERIFYLINKS : UserIdx(16777220), UserNum(1), UserID(camsay), IP(192.168.0.3), connctTick=1963387(3ms)
[2025-04-20 20:19:04.745740 140545187886784]: [Auth] C2S_GETMYCHARTR : UserIdx(16777220), UserNum(1), UserID(camsay), IP(192.168.0.3), processTick=1963391(16ms), connctTick=1963387(20ms)
[2025-04-20 20:19:18.575810 140545204672192]: [HeartBeat] Response : Addr(127.0.0.1:38200)
[2025-04-20 20:19:20.189535 140545326511808]: [##ERROR##] 'OnCSCNewMyChartr' fail (Proc/Character.cpp:569)
[2025-04-20 20:19:20.189588 140545326511808]: [##ERROR##] UsrMap Fail : MainCmd(134) Ret(60239:6:569) Addr(192.168.0.3) CharIdx(0)
[2025-04-20 20:19:20.189640 140545326511808]: close(): closing(192.168.0.3)
[2025-04-20 20:19:20.189675 140545326511808]: 1.close user -1 [2972B8C0] (192.168.0.3)
[2025-04-20 20:19:21.336175 140545301333696]: [HeartBeat] Request : Addr(127.0.0.1:48111)
[2025-04-20 20:19:21.336231 140545301333696]: [HeartBeat] Request : Addr(127.0.0.1:48171)
[2025-04-20 20:19:25.399410 140545301333696]: [HeartBeat] Response : Addr(127.0.0.1:38151)
[2025-04-20 20:19:26.422591 140545356265856]: success accept 177(192.168.0.3:63910)
[2025-04-20 20:19:26.422696 140545356265856]: 1.open user 177 [2972B8C0] (192.168.0.3)
[2025-04-20 20:19:26.423323 140545356265856]: [Security] Connect From User(192.168.0.3:63910)
[2025-04-20 20:19:26.424792 140545326511808]: [Auth] C2S_VERIFYLINKS : UserIdx(16777221), UserNum(1), UserID(camsay), IP(192.168.0.3), connctTick=1985084(2ms)
[2025-04-20 20:19:26.429094 140545221457600]: [Auth] C2S_GETMYCHARTR : UserIdx(16777221), UserNum(1), UserID(camsay), IP(192.168.0.3), processTick=1985087(4ms), connctTick=1985084(7ms)
[2025-04-20 20:19:42.374502 140545326511808]: [##ERROR##] 'OnCSCNewMyChartr' fail (Proc/Character.cpp:569)
[2025-04-20 20:19:42.374553 140545326511808]: [##ERROR##] UsrMap Fail : MainCmd(134) Ret(60239:6:569) Addr(192.168.0.3) CharIdx(0)
[2025-04-20 20:19:42.374613 140545326511808]: close(): closing(192.168.0.3)
[2025-04-20 20:19:42.374767 140545326511808]: 1.close user -1 [2972B8C0] (192.168.0.3)
[2025-04-20 20:20:28.064889 140545309726400]: [HeartBeat] Response : Addr(127.0.0.1:38181)
1745151992178 - [EP33] Docker repack - RaGEZONE Forums


Error when creating character , using this repack ... anyone who can help ? how to fix
 
Code:
[2025-04-20 20:16:25.607242 140545204672192]: [##ERROR##] 'OnCSCNewMyChartr' fail (Proc/Character.cpp:569)
[2025-04-20 20:16:25.607301 140545204672192]: [##ERROR##] UsrMap Fail : MainCmd(134) Ret(60239:6:569) Addr(192.168.0.3) CharIdx(0)
[2025-04-20 20:16:25.607360 140545204672192]: close(): closing(192.168.0.3)
[2025-04-20 20:16:25.607416 140545204672192]: 1.close user -1 [2972B8C0] (192.168.0.3)
[2025-04-20 20:18:41.615717 140545187886784]: [HeartBeat] Response : Addr(127.0.0.1:38190)
[2025-04-20 20:19:03.895764 140545179494080]: [HeartBeat] Response : Addr(127.0.0.1:38140)
[2025-04-20 20:19:04.725849 140545356265856]: success accept 177(192.168.0.3:63889)
[2025-04-20 20:19:04.726017 140545356265856]: 1.open user 177 [2972B8C0] (192.168.0.3)
[2025-04-20 20:19:04.726846 140545356265856]: [Security] Connect From User(192.168.0.3:63889)
[2025-04-20 20:19:04.728535 140545179494080]: [Auth] C2S_VERIFYLINKS : UserIdx(16777220), UserNum(1), UserID(camsay), IP(192.168.0.3), connctTick=1963387(3ms)
[2025-04-20 20:19:04.745740 140545187886784]: [Auth] C2S_GETMYCHARTR : UserIdx(16777220), UserNum(1), UserID(camsay), IP(192.168.0.3), processTick=1963391(16ms), connctTick=1963387(20ms)
[2025-04-20 20:19:18.575810 140545204672192]: [HeartBeat] Response : Addr(127.0.0.1:38200)
[2025-04-20 20:19:20.189535 140545326511808]: [##ERROR##] 'OnCSCNewMyChartr' fail (Proc/Character.cpp:569)
[2025-04-20 20:19:20.189588 140545326511808]: [##ERROR##] UsrMap Fail : MainCmd(134) Ret(60239:6:569) Addr(192.168.0.3) CharIdx(0)
[2025-04-20 20:19:20.189640 140545326511808]: close(): closing(192.168.0.3)
[2025-04-20 20:19:20.189675 140545326511808]: 1.close user -1 [2972B8C0] (192.168.0.3)
[2025-04-20 20:19:21.336175 140545301333696]: [HeartBeat] Request : Addr(127.0.0.1:48111)
[2025-04-20 20:19:21.336231 140545301333696]: [HeartBeat] Request : Addr(127.0.0.1:48171)
[2025-04-20 20:19:25.399410 140545301333696]: [HeartBeat] Response : Addr(127.0.0.1:38151)
[2025-04-20 20:19:26.422591 140545356265856]: success accept 177(192.168.0.3:63910)
[2025-04-20 20:19:26.422696 140545356265856]: 1.open user 177 [2972B8C0] (192.168.0.3)
[2025-04-20 20:19:26.423323 140545356265856]: [Security] Connect From User(192.168.0.3:63910)
[2025-04-20 20:19:26.424792 140545326511808]: [Auth] C2S_VERIFYLINKS : UserIdx(16777221), UserNum(1), UserID(camsay), IP(192.168.0.3), connctTick=1985084(2ms)
[2025-04-20 20:19:26.429094 140545221457600]: [Auth] C2S_GETMYCHARTR : UserIdx(16777221), UserNum(1), UserID(camsay), IP(192.168.0.3), processTick=1985087(4ms), connctTick=1985084(7ms)
[2025-04-20 20:19:42.374502 140545326511808]: [##ERROR##] 'OnCSCNewMyChartr' fail (Proc/Character.cpp:569)
[2025-04-20 20:19:42.374553 140545326511808]: [##ERROR##] UsrMap Fail : MainCmd(134) Ret(60239:6:569) Addr(192.168.0.3) CharIdx(0)
[2025-04-20 20:19:42.374613 140545326511808]: close(): closing(192.168.0.3)
[2025-04-20 20:19:42.374767 140545326511808]: 1.close user -1 [2972B8C0] (192.168.0.3)
[2025-04-20 20:20:28.064889 140545309726400]: [HeartBeat] Response : Addr(127.0.0.1:38181)
View attachment 280262

Error when creating character , using this repack ... anyone who can help ? how to fix
Go to stored procedure [SERVER01].dbo.cabal_sp_newchar and look for "adb01" and delete it.

This repack also need to clean up all "adb01" linked server to prevent most of the issue, you can run the query to search them.

SQL:
SELECT
    OBJECT_NAME(object_id) AS ProcedureName,
    definition
FROM
    sys.sql_modules
WHERE
    definition LIKE '%adb01%'
 
Code:
[2025-04-20 20:16:25.607242 140545204672192]: [##ERROR##] 'OnCSCNewMyChartr' fail (Proc/Character.cpp:569)
[2025-04-20 20:16:25.607301 140545204672192]: [##ERROR##] UsrMap Fail : MainCmd(134) Ret(60239:6:569) Addr(192.168.0.3) CharIdx(0)
[2025-04-20 20:16:25.607360 140545204672192]: close(): closing(192.168.0.3)
[2025-04-20 20:16:25.607416 140545204672192]: 1.close user -1 [2972B8C0] (192.168.0.3)
[2025-04-20 20:18:41.615717 140545187886784]: [HeartBeat] Response : Addr(127.0.0.1:38190)
[2025-04-20 20:19:03.895764 140545179494080]: [HeartBeat] Response : Addr(127.0.0.1:38140)
[2025-04-20 20:19:04.725849 140545356265856]: success accept 177(192.168.0.3:63889)
[2025-04-20 20:19:04.726017 140545356265856]: 1.open user 177 [2972B8C0] (192.168.0.3)
[2025-04-20 20:19:04.726846 140545356265856]: [Security] Connect From User(192.168.0.3:63889)
[2025-04-20 20:19:04.728535 140545179494080]: [Auth] C2S_VERIFYLINKS : UserIdx(16777220), UserNum(1), UserID(camsay), IP(192.168.0.3), connctTick=1963387(3ms)
[2025-04-20 20:19:04.745740 140545187886784]: [Auth] C2S_GETMYCHARTR : UserIdx(16777220), UserNum(1), UserID(camsay), IP(192.168.0.3), processTick=1963391(16ms), connctTick=1963387(20ms)
[2025-04-20 20:19:18.575810 140545204672192]: [HeartBeat] Response : Addr(127.0.0.1:38200)
[2025-04-20 20:19:20.189535 140545326511808]: [##ERROR##] 'OnCSCNewMyChartr' fail (Proc/Character.cpp:569)
[2025-04-20 20:19:20.189588 140545326511808]: [##ERROR##] UsrMap Fail : MainCmd(134) Ret(60239:6:569) Addr(192.168.0.3) CharIdx(0)
[2025-04-20 20:19:20.189640 140545326511808]: close(): closing(192.168.0.3)
[2025-04-20 20:19:20.189675 140545326511808]: 1.close user -1 [2972B8C0] (192.168.0.3)
[2025-04-20 20:19:21.336175 140545301333696]: [HeartBeat] Request : Addr(127.0.0.1:48111)
[2025-04-20 20:19:21.336231 140545301333696]: [HeartBeat] Request : Addr(127.0.0.1:48171)
[2025-04-20 20:19:25.399410 140545301333696]: [HeartBeat] Response : Addr(127.0.0.1:38151)
[2025-04-20 20:19:26.422591 140545356265856]: success accept 177(192.168.0.3:63910)
[2025-04-20 20:19:26.422696 140545356265856]: 1.open user 177 [2972B8C0] (192.168.0.3)
[2025-04-20 20:19:26.423323 140545356265856]: [Security] Connect From User(192.168.0.3:63910)
[2025-04-20 20:19:26.424792 140545326511808]: [Auth] C2S_VERIFYLINKS : UserIdx(16777221), UserNum(1), UserID(camsay), IP(192.168.0.3), connctTick=1985084(2ms)
[2025-04-20 20:19:26.429094 140545221457600]: [Auth] C2S_GETMYCHARTR : UserIdx(16777221), UserNum(1), UserID(camsay), IP(192.168.0.3), processTick=1985087(4ms), connctTick=1985084(7ms)
[2025-04-20 20:19:42.374502 140545326511808]: [##ERROR##] 'OnCSCNewMyChartr' fail (Proc/Character.cpp:569)
[2025-04-20 20:19:42.374553 140545326511808]: [##ERROR##] UsrMap Fail : MainCmd(134) Ret(60239:6:569) Addr(192.168.0.3) CharIdx(0)
[2025-04-20 20:19:42.374613 140545326511808]: close(): closing(192.168.0.3)
[2025-04-20 20:19:42.374767 140545326511808]: 1.close user -1 [2972B8C0] (192.168.0.3)
[2025-04-20 20:20:28.064889 140545309726400]: [HeartBeat] Response : Addr(127.0.0.1:38181)
View attachment 280262

Error when creating character , using this repack ... anyone who can help ? how to fix
Create linked server to not have to edit a bunch of procedures…

1: change serverIP to your public/wanip

SQL:
EXEC sp_addlinkedserver
@server = 'adb01',
@srvproduct = '',
@provider = 'SQLNCLI',
@datasrc = 'serverIP';


2.
SQL:
EXEC sp_serveroption
@server = 'adb01',
@optname = 'rpc',
@optvalue = 'true';

EXEC sp_serveroption
@server = 'adb01',
@optname = 'rpc out',
@optvalue = 'true';
 
Go to stored procedure [SERVER01].dbo.cabal_sp_newchar and look for "adb01" and delete it.

This repack also need to clean up all "adb01" linked server to prevent most of the issue, you can run the query to search them.

SQL:
SELECT
    OBJECT_NAME(object_id) AS ProcedureName,
    definition
FROM
    sys.sql_modules
WHERE
    definition LIKE '%adb01%'
1745154068004 - [EP33] Docker repack - RaGEZONE Forums

is this ok for sv ? and how to connect to database ? the password is default
set by install or i have to restore and set it ?
 
Use SSMS in your windows, database was restored and have password already if you want to change need to edit new_server.conf file (actual password is there too)
thanks sr for ask to much i just know basic code

Use SSMS in your windows, database was restored and have password already if you want to change need to edit new_server.conf file (actual password is there too)
when i try to connect the client keep resetart and ask me to update u know how to fix ?
 
Last edited:
This repack is based on HariSeldon docker and 2nd version released which includes some correction and fixes.

This release contains the following below:

Repack has been tested and worked properly in Debian 11 only after following the installation guide included on the repack.



All credits belong to respective owners who released the files:
HariSeldon, w3rnis (1st repack), immafishball (husky fixed), MrSensei (EP33 files)
Dude, did you know what is ChannelData for Trade server?
 
Create linked server to not have to edit a bunch of procedures…

1: change serverIP to your public/wanip

SQL:
EXEC sp_addlinkedserver
@server = 'adb01',
@srvproduct = '',
@provider = 'SQLNCLI',
@datasrc = 'serverIP';


2.
SQL:
EXEC sp_serveroption
@server = 'adb01',
@optname = 'rpc',
@optvalue = 'true';

EXEC sp_serveroption
@server = 'adb01',
@optname = 'rpc out',
@optvalue = 'true';
even using only in VM? i tried it last night still the same.. hahaha i just deleted the vm and create new again hahaha
 
你在尝试什么系统?对于使用ubuntu的我,我需要修改install.sh
Can you create a complete video tutorial guide? It will be of great help to beginners.

不需要执行步骤1,因为“build_cabal_repo.sh”命令会帮你重新打包所有/cabal-data和/cabal-scripts

如果你使用的是Debian 11之外的其他操作系统,只需在构建repo之后修改/root/install.sh。
Can you create a complete video tutorial guide? It will be of great help to beginners.
 
Works for me on local VM and VPS
I already install it on vps can connect to data already change ip in internal.txt but when i connect account it show need restart to update and out client you know what wrong ? Thanks
And what line in ocbd need to change ip ?
 
Hi, I cannot start the server. I was using this docker and installed it successfully on AlmaLinux 9.5 but couldn't start server. Changed IP already. I setup the server on NAT setting. Can anyone help me please?
 

Attachments

  • Screenshot 2025-04-21 153802 - [EP33] Docker repack - RaGEZONE Forums
    Screenshot 2025-04-21 153802.webp
    152.1 KB · Views: 111
Back