Welcome!

Join our community of MMO enthusiasts and game developers! By registering, you'll gain access to discussions on the latest developments in MMO server files and collaborate with like-minded individuals. Join us today and unlock the potential of MMO server development!

Join Today!

L2J help with geting more than one person onto server...

Status
Not open for further replies.
Experienced Elementalist
Joined
Jul 4, 2004
Messages
211
Reaction score
0
Ok, i disconected my router, set the IPs to my IP, reran all the .bat files. and it gives me this errer when i run startserver.bat.:
Exception in thread "main" java.net.BindException: Cannot assign requested addre
ss: JVM_Bind
at java.net.PlainSocketImpl.socketBind(Native Method)
at java.net.PlainSocketImpl.bind(Unknown Source)
at java.net.ServerSocket.bind(Unknown Source)
at java.net.ServerSocket.<init>(Unknown Source)
at net.sf.l2j.gameserver.GameServer.<init>(GameServer.java:214)
at net.sf.l2j.Server.main(Server.java:53)
Press any key to continue . . .


Can anyone maby help me? btw if it helps the port is set to defalt for what was in the file, wich is 7777...
 
Infinity/Divinity Dev
Banned
Joined
Jun 7, 2004
Messages
759
Reaction score
0
Try this then after auto install click yes and then try again. make sure with router or no router it's world ip. If just local pc best way is 127.0.0.1 for testing on same pc you play.
 
Upvote 0
Experienced Elementalist
Joined
Jul 4, 2004
Messages
211
Reaction score
0
o_O, i already have a server runing for myself :p, im trying to get my freind to be able to play on it from another computer, so we can test stuff.

btw, i already installed that a while ago when i installed the server ( like 2 days ago...), but i did reinstall it jest now, and were am i suposed to hit yes o_O? it jest says Java software install complete or something like that...
 
Last edited:
Upvote 0
Infinity/Divinity Dev
Banned
Joined
Jun 7, 2004
Messages
759
Reaction score
0
if says nothing then done make sure open ports on router then basicly have world ip in config in the one spot... NOTE if your using 0.1 it's not able to use the router the new 0.2 is.
 
Upvote 0
Experienced Elementalist
Joined
Jul 4, 2004
Messages
211
Reaction score
0
Ok, no mater how much i read that i cant make sens of it... :/ Wut IP do i set if im useing the router? my WAN Ip in all of them? my ip that has the 192. stuff, or the router IP?

edit: and what port am i opening? and do i need to forward any ports?
 
Upvote 0
Status
Not open for further replies.
Back
Top