.htacces

Internal Server errors can also be caused by incorrect file permissions, depending on what mods, or version of apache is installed, you may receive internal server error if the file ownership is incorrectly set or the file is writable by everyone.

Just a suggestion, its also just as possible his host has removed support for .htaccess files, seems rather unlikely but possible, can't see a reason why though(And it wouldn't give an internal server error, also it could be the .htaccess file is using depricated commands inside it, you may need to google the error in error_log and find out what the new command is), error_log is the way to go.
 
Back