My Zoneserver error NetworkInit n g_mainInit n Failed to created empty document

Status
Not open for further replies.
Newbie Spellweaver
Joined
Mar 26, 2013
Messages
17
Reaction score
0
Help me please,,,,!!!

what's wrong???

I need a solution??
please help me ...


1 - My Zoneserver error NetworkInit n g_mainInit n Failed to created empty document - RaGEZONE Forums 2 - My Zoneserver error NetworkInit n g_mainInit n Failed to created empty document - RaGEZONE Forums 3 - My Zoneserver error NetworkInit n g_mainInit n Failed to created empty document - RaGEZONE Forums

I want to play this game...
 
Help me please,,,,!!!

what's wrong???

I need a solution??
please help me ...


View attachment 126505View attachment 126506View attachment 126507

I want to play this game...

My setting ini..
What wrong,,

###FOLDER "Account and Login"###

##AccountSystem.ini##
[Database]
AccountDB_Machine = 192.168.28.1
AccountDB_Name = RF_User


[System]
NationCode = TH
;NationCode = RU (äëÿ ðóñ ëîêàëè)

[DB_INFO]
IP = 192.168.28.1
Port = 1433
DBName = BILLING
Acc = rfonline
PW = rf270192

[Service]
MaxAccountNum = 1337

[World]
WorldSet_Num =1
ServiceSet_Num = 0

Name0 = RF_LEET
Address0 = 192.168.28.1
DBName0 = RF_WORLD
Type0 = 0

##BillingSystem.ini##
[System]
ZoneAddress = 192.168.28.1
NationCode = RU
;NationCode = RU (äëÿ ðóñ ëîêàëè)

[BILLING]
SERVER_NAME = BILLING
IP = 192.168.28.1
PORT = 1433
CP_ID = 1
GROUP_NUM = 1
SERVER_NUM = 1
GAME_ID = 1

##Login_Filter_Dev.ini##
[IPAddress]
FilterNum = 0

Filter0 = 192.168.28.1
FilterRange0 = 255
[ID]
;ôèëüòð GM ëîãèíîâ
FilterNum = 2
Filter0 = !teste
Filter1 = !teste01

##LoginSystem.ini##
[Account]
AccountAddress = 192.168.28.1

[System]
NationCode = RU
;NationCode = RU (äëÿ ðóñ ëîêàëè)
[CHECK ADDRESS]
CHECK = TRUE

[LOG]
AUTH_LOG = TRUE

[World]
Lim World Num = 1
DB Push Job = 0

[BILLING]
Check = FALSE
BillingCode = 78

[MOTP]
Service = FALSE
HostName = Let.Tom.Ru
HostIP = ÂÀØ IP
URLPath = /MOTPValidation/ValidationServlet
Port = 1433

[IP Address Filter]
FilterNum = 0

Filter0 = 192.168.28.1
FilterRange0 = 255
[UserCountDisplyLimit]
Limit0 = 500
Limit1 = 1200
Limit2 = 2700
[BILL_RU]
DBName = BILLING
DBIP = 192.168.28.1
DBAccount = rfonline
DBPassword = rf270192
DBPort = 1433

##rfacc.ini## (C:\RF_server_2.2.3.2\1.Account,Login\RF_Bin)
[Options]
DBSTR = Provider=MSDASQL;DSN=BILLING;UID=rfonline;PWD=rf270192;
ErrDBSTR =
LogLevel = 2

###FOLDER "ZONESERVER"###

##WorldInfo.ini##
[System]
WorldName = RF_LEET

ServerType = 0

BillingCode = 32
BillOper = 0
FreeServer = 1

HBKPath = C:\Work\HBK
HistoryPath = C:\Work\History

NationCode = TH
;NationCode = RU (äëÿ ðóñ ëîêàëè)
[ServerMode]
BuyCashItemByGold = false
;Ñóùåñòâóåò 2øò(Internal è Release)
ReleaseType = Internal
ExcuteService = false

[Rule]
CrystalHPMultiple = 1.0
CrystalHPMultiple_1 = 5.0
CrystalHPMultiple_2 = 8.0
CrystalHPMultiple_3 = 11.0

[GUILD CREATE EVENT]
Enable = FALSE
START_DATE = 20090119
END_DATE = 20090120

##rfacc.ini## (C:\RF_server_2.2.3.2\2.ZoneServer\RF_Bin)
[Options]
DBSTR = Provider=SQLOLEDB;Source=192.168.28.1,1433;UID=rfonline;PWD=rf270192;Initial Catalog=BILLING;
ErrDBSTR =
LogLevel = 2

##WorldSystem.ini##
[System]
AccountAddress = 192.168.28.1
LimUserNum = 1337

[MainThread]
SleepTerm = 15
SleepValue = 10
SleepIgnore = 1
[Messenger]
Use = TRUE

[RankJob]
JobHour = 23
JobMin = 40

[Rule]
AttackSpareDelay = 200

[Economy]
Default_MgrVal =1000
Default_TaxVal =33
;Default_OreVal =10000
Default_OreVal =3500
2010/10/20_MgrVal = 2000
2010/10/20_TaxVal = 66

[HolySystem]
KeeperCreateMap = resources
KeeperCreateDummy = dk0001
KeeperActiveDummy = hskactdum
KeeperCenterDummy = dk0001
KeeperMonsterCode = 04903


StoneNum = 3

StoneCreateMap0 = resources
StoneCreateDummy0 = dh001
StoneMonsterCode0 = 04B01
StoneMasterRace0 = 0

StoneCreateMap1 = resources
StoneCreateDummy1 = dh002
StoneMonsterCode1 = 04B02
StoneMasterRace1 = 1

StoneCreateMap2 = resources
StoneCreateDummy2 = dh003
StoneMonsterCode2 = 04B03
StoneMasterRace2 = 2
QuestInit=0

[Schedule]
ScheduleInit=0

[Formula]
StdDefPoint=3
RcvDefPoint=10

[Buddha Event]
Enable = FALSE
GiveItem = irpre01
ExchangeItem = irpre01

[CLASS REFINE EVENT]
ENABLE = FALSE
START_DATE = 20101010
END_DATE = 20110101
LIMIT_COUNT = 3

[PcBang Favor]
USE = FALSE

[Time Limit]
Use = FALSE

CNT = 3
Time_0 = 0
Time_1 = 300
Time_2 = 500

Percent_0 = 1.0
Percent_1 = 0.5
Percent_2 = 0.0

LogoutTerm = 10
NotifyTerm = 2

[VersionCheck]
;Ver_CheckKey = Êëþ÷ ïðèâÿçêè êëèåíòà.

##fg.ini##
[Game Server]
Server Name = RF_LEET

[FireGuard Server]
Server IP = ÂÀØ IP
Server PORT = 15444

[Detect Info]
Time Interval = 180000

##fgrs.ini##
[Game Server]
Game Name = rfonline_levelup
Server Name = RF_LEET
Port = 15445

[FireGuard Server]
Server URL =
Server Port = 80

[Detect Info]
Time Interval = 5000

[FireGuard Use]
Use = TRUE
True not YES



Why could happen like this
Help me please,,,,!!!

Why could happen like this

View attachment 126505View attachment 126506View attachment 126507

...
 
Last edited:
Upvote 0
from the way i looked, the configs are all fine. try reading the logs, and found out whats your problem really are

I do not know about the log??
whether it might be ..
##NetLog(Zoneserver)##
#GameServer_ClientLine_System1303310104.log#
0 03/31/13 01:04:48 : m_NetSocket.SetSocket. fail : bind() Failure => 10048


I was very confused

Pengen Maen tapi error terus,,
Cape Deh,,
 
Upvote 0
Try to press Ctrl + Alt + Del (Task Manager)
Make Sure your ZoneServer Prosses not run.

sometimes if u close zoneserver.exe, the prosses cannot stop and stuck in Task Manager. u must check and stop first.
 
Upvote 0
Try to press Ctrl + Alt + Del (Task Manager)
Make Sure your ZoneServer Prosses not run.

sometimes if u close zoneserver.exe, the prosses cannot stop and stuck in Task Manager. u must check and stop first.
if I run zoneserver want to open but when I run loginserver but instead networkInit error,,

I was getting confused, why??
e1 - My Zoneserver error NetworkInit n g_mainInit n Failed to created empty document - RaGEZONE Forums e2 - My Zoneserver error NetworkInit n g_mainInit n Failed to created empty document - RaGEZONE Forums
 
Upvote 0
My setting ini..
What wrong,,

###FOLDER "Account and Login"###

##AccountSystem.ini##
[Database]
AccountDB_Machine = 192.168.28.1
AccountDB_Name = RF_User


[System]
NationCode = TH
;NationCode = RU (äëÿ ðóñ ëîêàëè)

[DB_INFO]
IP = 192.168.28.1
Port = 1433
DBName = BILLING
Acc = rfonline
PW = rf270192

[Service]
MaxAccountNum = 1337

[World]
WorldSet_Num =1
ServiceSet_Num = 0

Name0 = RF_LEET
Address0 = 192.168.28.1
DBName0 = RF_WORLD
Type0 = 0

##BillingSystem.ini##
[System]
ZoneAddress = 192.168.28.1
NationCode = RU
;NationCode = RU (äëÿ ðóñ ëîêàëè)

[BILLING]
SERVER_NAME = BILLING
IP = 192.168.28.1
PORT = 1433
CP_ID = 1
GROUP_NUM = 1
SERVER_NUM = 1
GAME_ID = 1

##Login_Filter_Dev.ini##
[IPAddress]
FilterNum = 0

Filter0 = 192.168.28.1
FilterRange0 = 255
[ID]
;ôèëüòð GM ëîãèíîâ
FilterNum = 2
Filter0 = !teste
Filter1 = !teste01

##LoginSystem.ini##
[Account]
AccountAddress = 192.168.28.1

[System]
NationCode = RU
;NationCode = RU (äëÿ ðóñ ëîêàëè)
[CHECK ADDRESS]
CHECK = TRUE

[LOG]
AUTH_LOG = TRUE

[World]
Lim World Num = 1
DB Push Job = 0

[BILLING]
Check = FALSE
BillingCode = 78

[MOTP]
Service = FALSE
HostName = Let.Tom.Ru
HostIP = ÂÀØ IP
URLPath = /MOTPValidation/ValidationServlet
Port = 1433

[IP Address Filter]
FilterNum = 0

Filter0 = 192.168.28.1
FilterRange0 = 255
[UserCountDisplyLimit]
Limit0 = 500
Limit1 = 1200
Limit2 = 2700
[BILL_RU]
DBName = BILLING
DBIP = 192.168.28.1
DBAccount = rfonline
DBPassword = rf270192
DBPort = 1433

##rfacc.ini## (C:\RF_server_2.2.3.2\1.Account,Login\RF_Bin)
[Options]
DBSTR = Provider=MSDASQL;DSN=BILLING;UID=rfonline;PWD=rf270192;
ErrDBSTR =
LogLevel = 2

###FOLDER "ZONESERVER"###

##WorldInfo.ini##
[System]
WorldName = RF_LEET

ServerType = 0

BillingCode = 32
BillOper = 0
FreeServer = 1

HBKPath = C:\Work\HBK
HistoryPath = C:\Work\History

NationCode = TH
;NationCode = RU (äëÿ ðóñ ëîêàëè)
[ServerMode]
BuyCashItemByGold = false
;Ñóùåñòâóåò 2øò(Internal è Release)
ReleaseType = Internal
ExcuteService = false

[Rule]
CrystalHPMultiple = 1.0
CrystalHPMultiple_1 = 5.0
CrystalHPMultiple_2 = 8.0
CrystalHPMultiple_3 = 11.0

[GUILD CREATE EVENT]
Enable = FALSE
START_DATE = 20090119
END_DATE = 20090120

##rfacc.ini## (C:\RF_server_2.2.3.2\2.ZoneServer\RF_Bin)
[Options]
DBSTR = Provider=SQLOLEDB;Source=192.168.28.1,1433;UID=rfonline;PWD=rf270192;Initial Catalog=BILLING;
ErrDBSTR =
LogLevel = 2

##WorldSystem.ini##
[System]
AccountAddress = 192.168.28.1
LimUserNum = 1337

[MainThread]
SleepTerm = 15
SleepValue = 10
SleepIgnore = 1
[Messenger]
Use = TRUE

[RankJob]
JobHour = 23
JobMin = 40

[Rule]
AttackSpareDelay = 200

[Economy]
Default_MgrVal =1000
Default_TaxVal =33
;Default_OreVal =10000
Default_OreVal =3500
2010/10/20_MgrVal = 2000
2010/10/20_TaxVal = 66

[HolySystem]
KeeperCreateMap = resources
KeeperCreateDummy = dk0001
KeeperActiveDummy = hskactdum
KeeperCenterDummy = dk0001
KeeperMonsterCode = 04903


StoneNum = 3

StoneCreateMap0 = resources
StoneCreateDummy0 = dh001
StoneMonsterCode0 = 04B01
StoneMasterRace0 = 0

StoneCreateMap1 = resources
StoneCreateDummy1 = dh002
StoneMonsterCode1 = 04B02
StoneMasterRace1 = 1

StoneCreateMap2 = resources
StoneCreateDummy2 = dh003
StoneMonsterCode2 = 04B03
StoneMasterRace2 = 2
QuestInit=0

[Schedule]
ScheduleInit=0

[Formula]
StdDefPoint=3
RcvDefPoint=10

[Buddha Event]
Enable = FALSE
GiveItem = irpre01
ExchangeItem = irpre01

[CLASS REFINE EVENT]
ENABLE = FALSE
START_DATE = 20101010
END_DATE = 20110101
LIMIT_COUNT = 3

[PcBang Favor]
USE = FALSE

[Time Limit]
Use = FALSE

CNT = 3
Time_0 = 0
Time_1 = 300
Time_2 = 500

Percent_0 = 1.0
Percent_1 = 0.5
Percent_2 = 0.0

LogoutTerm = 10
NotifyTerm = 2

[VersionCheck]
;Ver_CheckKey = Êëþ÷ ïðèâÿçêè êëèåíòà.

##fg.ini##
[Game Server]
Server Name = RF_LEET

[FireGuard Server]
Server IP = ÂÀØ IP
Server PORT = 15444

[Detect Info]
Time Interval = 180000

##fgrs.ini##
[Game Server]
Game Name = rfonline_levelup
Server Name = RF_LEET
Port = 15445

[FireGuard Server]
Server URL =
Server Port = 80

[Detect Info]
Time Interval = 5000

[FireGuard Use]
Use = TRUE
True not YES



Why could happen like this

try to put back all ip to 127.0.0.1
 
Upvote 0
This happens when 2 processes is trying to cancel the other out or a port connection can not be made: example if you accidentally started 2 Zoneservers at the same time they would be competing over the same running port or if your server is trying to connect to its gateway or sql server.. so check your INI files and your gateway setting.
 
Upvote 0
Help me please,,,,!!!

what's wrong???

I need a solution??
please help me ...


View attachment 126505View attachment 126506View attachment 126507

I want to play this game...
try this configuration

AccountSystem.ini

[Database]
AccountDB_Machine = 127.0.0.1 <==== Change to your hamachi IP
AccountDB_Name = RF_User


[System]
NationCode = RU


[DB_INFO]
IP = 127.0.0.1 <===== change to your hamachi IP
Port = 1433 <==== Put 61433
DBName = BILLING
Acc = sa
PW = mnbe5824

[Service]
MaxAccountNum = 1337

[World]
WorldSet_Num =1
ServiceSet_Num = 0

Name0 = RF_LEET
Address0 = 127.0.0.1
DBName0 = RF_World
Type0 = 0

BillingSystem.ini

[System]
ZoneAddress = 127.0.0.1
NationCode = RU


[BILLING]
SERVER_NAME = BILLING
IP = 127.0.0.1
PORT = 1433
CP_ID = 1
GROUP_NUM = 1
SERVER_NUM = 1
GAME_ID = 1

Login_Filter_Dev.in

[IPAddress]
FilterNum = 0

Filter0 = 192.168.1.0
FilterRange0 = 255
[ID]

FilterNum = 8
Filter0 = !karasss
Filter1 = !teste
Filter2 = !teste1
Filter3 = !teste2
Filter4 = !teste3
Filter5 = !teste4
Filter6 = !teste5
Filter7 = !teste6

LoginSystem.ini

[Account]
AccountAddress = 127.0.0.1

[System]
NationCode = RU

[CHECK ADDRESS]
CHECK = TRUE

[LOG]
AUTH_LOG = TRUE

[World]
Lim World Num = 1
DB Push Job = 0

[BILLING]
Check = FALSE
BillingCode = 78

[MOTP]
Service = FALSE
HostName = Let.Tom.Ru
HostIP = ÂÀØ IP
URLPath = /MOTPValidation/ValidationServlet
Port = 12380

[IP Address Filter]
FilterNum = 0

Filter0 = 192.168.0.10
FilterRange0 = 255
[UserCountDisplyLimit]
Limit0 = 500
Limit1 = 1200
Limit2 = 2700

[BILL_RU]
DBName = BILLING
DBIP = 127.0.0.1
DBAccount = sa
DBPassword = mnbe5824
DBPort = 1433

WorldInfo.ini

[System]
WorldName = RF_LEET

ServerType = 1

BillingCode = 32
BillOper = 0
FreeServer = 1

HBKPath = C:\Work\HBK
HistoryPath = C:\Work\History

NationCode = RU

[ServerMode]
BuyCashItemByGold = true
ReleaseType = Internal
ExcuteService = true

[Rule]
CrystalHPMultiple = 1.0
CrystalHPMultiple_1 = 5.0
CrystalHPMultiple_2 = 8.0
CrystalHPMultiple_3 = 11.0

[GUILD CREATE EVENT]
Enable = FALSE
START_DATE = 20090119
END_DATE = 20090120


WorldSystem.ini

[System]
AccountAddress = 127.0.0.1
LimUserNum = 1337

[MainThread]
SleepTerm = 15
SleepValue = 10
SleepIgnore = 1
[Messenger]
Use = TRUE

[RankJob]
JobHour = 23
JobMin = 40

[Rule]
AttackSpareDelay = 200

[Economy]
Default_MgrVal =1000
Default_TaxVal =33
;Default_OreVal =10000
Default_OreVal =3500
2010/10/20_MgrVal = 2000
2010/10/20_TaxVal = 66

[HolySystem]
KeeperCreateMap = resources
KeeperCreateDummy = dk0001
KeeperActiveDummy = hskactdum
KeeperCenterDummy = dk0001
KeeperMonsterCode = 04903


StoneNum = 3

StoneCreateMap0 = resources
StoneCreateDummy0 = dh001
StoneMonsterCode0 = 04B01
StoneMasterRace0 = 0

StoneCreateMap1 = resources
StoneCreateDummy1 = dh002
StoneMonsterCode1 = 04B02
StoneMasterRace1 = 1

StoneCreateMap2 = resources
StoneCreateDummy2 = dh003
StoneMonsterCode2 = 04B03
StoneMasterRace2 = 2
QuestInit=0

[Schedule]
ScheduleInit=0

[Formula]
StdDefPoint=3
RcvDefPoint=10

[Buddha Event]
Enable = FALSE
GiveItem = irpre01
ExchangeItem = irpre01

[CLASS REFINE EVENT]
ENABLE = FALSE
START_DATE = 20101010
END_DATE = 20110101
LIMIT_COUNT = 3

[PcBang Favor]
USE = FALSE

[Time Limit]
Use = FALSE

CNT = 3
Time_0 = 0
Time_1 = 300
Time_2 = 500

Percent_0 = 1.0
Percent_1 = 0.5
Percent_2 = 0.0

LogoutTerm = 10
NotifyTerm = 2

[VersionCheck]
;Ver_CheckKey = Êëþ÷ ïðèâÿçêè êëèåíòà.


all Name0 = are all match to your config.ini
Name0 = RF_LEET



change all ip's to your hamachi IP
change all " 1433 " port to " 61433 "
change DBAccount & DBPass to your

You only have to do is " Open " your ".ini files" Select all and remove copy my post and paste! then edit to your!!
Note: make sure your hamachi ip configured in to your "sql server configureration manager"
Make sure your hamachi ip use as "hostname"including the 61433 port
and very important click tha mapping exept " deny "
 
Last edited:
Upvote 0
Check the Password in the File: .\ZoneServer\RF_Bin\rfacc.ini

[Options]
DBSTR = Provider=SQLOLEDB;Source=1337n;UID=YouLoginSQL;PWD=YouPWSQL;Initial Catalog=BILLING;
ErrDBSTR =
LogLevel = 2
 
Upvote 0
check folder Script, in zoneserver, check all xxxx.dat (GuardTowerItem.dat, skill.dat, etc etc ect) if one dat file is wrong, or is for other file server, delete, and paste the correct dat file for your file server
 
Upvote 0
Status
Not open for further replies.
Back