[Release] Compiled Server+Client fully working

Combat-Arms_04.webp
 
someone help me test my server? Moderator i will send my discord to test my progress please dont ban me wizzy7132
 
Here's everything I've been doing though not much else is there
 

Attachments

Last edited by a moderator:
Hello everyone, I have this problem when im starting the Broadcast Server and on my ServerMonitor the Lobby ID stay red…

what can i do to fix that ?
 

Attachments

  • IMG_0476.webp
    19.5 KB · Views: 83
  • IMG_0475.webp
    36.8 KB · Views: 78
Nice release ashlay!
Almost got it working, working on fixing billserver..
currently stuck on the - Product Load Fail !! - Duplicated Product Num = [ 46 ]

for the launch server, i had to change the hardcoded sql password guys!!


C++:
#if defined(__US)
WCHAR* g_pszDBConnStr = L"DSN=COMBATARMS_LOG;UID=combatlog_service;PWD=m98dNFd!6GDW";
#elif defined(__KR)
WCHAR* g_pszDBConnStr = L"DSN=COMBATARMS_LOG;UID=combatlog_service;PWD=zjabatrpdla!1234";
#elif defined(__EU) || defined(__BR) || defined(__RU)
WCHAR* g_pszDBConnStr = L"DSN=COMBATARMS_LOG;UID=combatadmin;PWD=3eTHU63Q7kYFFAkP";
#else
#error Unknow Local
#endif


Sorry, by this, did you alter and recompile or just recreate the users with these passwords?

Still stuck on why my launchserver not working unfortunately

1737582681089.webp


I'm so close, the only thing not working is my launch.
:(

Update:
Nvm figured it out, it was my admin credentials for SQL
 
Last edited:
1737588706991.webp


Has anyone had issues doing the character creation?
is there a script to use for it?

Edit: Figured this out too: you need to use ashley's script to insert a user into combatarms then also insert into visms user table



Does anyone know what port to port forward if I were to expose this to the web?
Maybe a q for @Weverton
 
Last edited:
View attachment 274944

Has anyone had issues doing the character creation?
is there a script to use for it?

Edit: Figured this out too: you need to use ashley's script to insert a user into combatarms then also insert into visms user table



Does anyone know what port to port forward if I were to expose this to the web?
Maybe a q for @Weverton
Ports 10002 and 12001, and the dserver.
create a rule for the dserver on the firewall select the dserver.exe
Screenshot_1.webp
Each time the dserver start it will use a new udp port(last port used+1).
 
Ports 10002 and 12001, and the dserver.
create a rule for the dserver on the firewall select the dserver.exe
View attachment 274953
Each time the dserver start it will use a new udp port(last port used+1).
for dserver, wouldn't that be problematic, if it increments up a port?
that would mean potentially on the network you would need to expose all the ports?

Or am I misunderstanding, I'm not seeing a range for d-server in \CA_Server\DServer
 
for dserver, wouldn't that be problematic, if it increments up a port?
that would mean potentially on the network you would need to expose all the ports?

Or am I misunderstanding, I'm not seeing a range for d-server in \CA_Server\DServer
can you give me your discord username and I'll help you
 
Anyone figure out cases that don't open or gives an error?
 
for dserver, wouldn't that be problematic, if it increments up a port?
that would mean potentially on the network you would need to expose all the ports?

Or am I misunderstanding, I'm not seeing a range for d-server in \CA_Server\DServer
It will be a issue if you are using a reverse proxy or a firewall, but if your server have a public ip it will not be a problem.
when you add the DServer.exe on the firewall you don't need to add a port or a range of ports for it.
 
It will be a issue if you are using a reverse proxy or a firewall, but if your server have a public ip it will not be a problem.
when you add the DServer.exe on the firewall you don't need to add a port or a range of ports for it.
ah I see, that did the trick for me.

Interesting enough after running a few hours of tests with a friend I'm getting a billserver error again
1737656148092.webp


I haven't changed my .env, but the was a laravel error a long time about password expired for this user which I suspected caused this. But since updating the user nothing really changed i'm still getting this error, and now laravel is not logging at all.

Everything still works, it's just when I log in now the NX doesn't load properly anymore.

Does anyone have an idea of how to fix this? or what other logging I can reference for this again?

I'm 90% sure it's an apache or sql issue here, just not sure what.
 
Back