Welcome!

Join our community of MMO enthusiasts and game developers! By registering, you'll gain access to discussions on the latest developments in MMO server files and collaborate with like-minded individuals. Join us today and unlock the potential of MMO server development!

Join Today!

[Release] v496 Dysil's Wrath Server VM + Client + Guide

Newbie Spellweaver
Joined
Jan 11, 2014
Messages
10
Reaction score
1
are you running the vm or trying to run it without a vm? if you are trying to run it without the vm, its possible you forgot to grab the iweb.conf from /etc/ which would cause the iweb to not work

I use vm (not vm image). Install VBox, upload server files, setup all needed for work (mysql, apache, install all libs etc). Config Iweb like this (remove section <filter-mapping>) and add privileged="true" in "context.xml", copy "iweb.conf" to /etc/.

After this manipulation i go to "server managment" but not have "Rate config" function. "Option of Reparation Rate" (section "New iweb Entrance") in iweb write me "false" when i apply argument.
 
Experienced Elementalist
Joined
Nov 1, 2015
Messages
279
Reaction score
176
well thats not how you set the exp rate.
Server Management -> normal experience multiple:
->task experience multiple:

this is where you set exp rate in iweb
 
Newbie Spellweaver
Joined
Jan 11, 2014
Messages
10
Reaction score
1
iweb - [Release] v496 Dysil's Wrath Server VM + Client + Guide - RaGEZONE Forums
 

Attachments

You must be registered for see attachments list
Newbie Spellweaver
Joined
Aug 25, 2018
Messages
46
Reaction score
4
123 - [Release] v496 Dysil's Wrath Server VM + Client + Guide - RaGEZONE Forums

in the element you can change
 

Attachments

You must be registered for see attachments list
Newbie Spellweaver
Joined
Jan 11, 2014
Messages
10
Reaction score
1
Denval, thanks you. I did it right after your message in pm. Yes, i up lvl. But rate need not only for exp, SP to :) But not fast (example lvl up). Thanks for all. If rate-bonus is impossible - not problem. I play fun. Thanks.
 
Experienced Elementalist
Joined
Nov 1, 2015
Messages
279
Reaction score
176
if you would screenshot the issues you are having with the iweb we might be able to better help you fix it, without more details we are just guessing

you mentioned sp, there is a soul power multiplier in the iweb also

SP:


EXP:
 
Last edited:
Newbie Spellweaver
Joined
Jan 11, 2014
Messages
10
Reaction score
1
if you would screenshot the issues you are having with the iweb we might be able to better help you fix it, without more details we are just guessing

you mentioned sp, there is a soul power multiplier in the iweb also

SP:


EXP:

I not have function "exp multiple" like in your drawing. "multi SP" write me "false".

error_s - [Release] v496 Dysil's Wrath Server VM + Client + Guide - RaGEZONE Forums

iweb.conf :
Code:
[GameDBClient]
type            =    tcp
port            =    29400
address            =    172.16.128.31
so_sndbuf        =    65536
so_rcvbuf        =    65536
ibuffermax        =    1048576
obuffermax        =    1048576
so_broadcast    =    1
udp_nodelay        =    1

[DeliveryClient]
type            =    tcp
port            =    29100
address            =    172.16.128.21
so_sndbuf        =    65536
so_rcvbuf        =    65536
ibuffermax        =    1048576
obuffermax        =    1048576
so_broadcast    =    1
udp_nodelay        =    1

[FactionClient]
type            =    tcp
port            =    29500
address            =    172.16.128.21
so_sndbuf        =    65536
so_rcvbuf        =    65536
ibuffermax        =    1048576
obuffermax        =    1048576
so_broadcast    =    1
udp_nodelay        =    1

[UniqueNameClient]
type            =    tcp
port            =    29401
address            =    uniquenameserverip
so_sndbuf        =    65536
so_rcvbuf        =    65536
ibuffermax        =    1048576
obuffermax        =    1048576
;so_broadcast    =    1
tcp_nodelay        =    0
accumulate        =    268435456
isec            =    2
iseckey                 =       unameiseckey
osec                    =       2
oseckey                 =       unameoseckey

[ThreadPool]
config            =    (1,2)

[iweb]
language                = en_US
;pidon                   = true
version=20130515

[version]
version = wpackage.20130807191053

May be Iweb is broken.



tried to put other addresse (127.0.0.1) in config - long load page and not work. Where is log file iweb - not found.
 

Attachments

You must be registered for see attachments list
Experienced Elementalist
Joined
Nov 1, 2015
Messages
279
Reaction score
176
either the iweb is not properly configured then or the GS itself is not running, what is the output of ps aux | grep gs ?
 
Newbie Spellweaver
Joined
Jan 11, 2014
Messages
10
Reaction score
1
ps aux :
Code:
root      3277  0.0  0.0  87832  1292 tty1     Sl   14:35   0:01 ./logservice logservice.conf
root      3444  3.7 36.7 1687728 1494620 tty1  Sl   14:36   4:41 ./gs gs.conf gmserver.conf gsalias2.conf
root      3613  0.0  0.0   7868   884 pts/0    S+   16:42   0:00 grep gs



may be upload web.xml and server.xml of iweb ?
 
Experienced Elementalist
Joined
Nov 1, 2015
Messages
279
Reaction score
176
go through the directories of the daemons one by one, and compare the ip and port to the iweb.conf, if one doesn't match edit the iweb.conf to make it match, once all match restart the tomcat service so that it will reload the iweb with the new config settings.
 
Experienced Elementalist
Joined
Jun 3, 2007
Messages
218
Reaction score
19
Hello guys, somebody can reupload fully post? the links dissapear by author, really grateful if somebody can upload, client and server files, thanks.
 
Back
Top