Setup 99B+ server (non-router support)

Joined
May 26, 2005
Messages
1,042
Reaction score
6
Installing MSSQL(Part Taken By Warrior19's Guide) :

You can download Microsoft SQL Server 2000 .

1. Extract SQLEVAL.exe using WinRar or just execute it.
2. Run Setup.bat and click Next 8 times.
3. It will show you a window named Services Accounts.
4. In Service Settings set it to Use the Local System Account.
5. Click Next and it will show the Authentication Mode window.
6. Set it to Windows Authentication.
7. Then click next to continue the Installation.

The Server Files :

Download the best optimized and bugless server files (password: silver).

1. Extract muserver.rar to D:/Muserver.
2. Goto and get your WAN IP.
3. Goto the links directory.
3B. Right click to the 04 shortcut and replace 127.0.0.1 with your WAN IP.
3c. Do the same with 08 shortcut (there are two 127.0.0.1 strings there).

Making The Database

We have almost finished, this is an easy part also.

1. Goto Start->Run->isqlw.exe(don't close it).
2. Open the D:/Muserver/RankingServer/SQL/ Directory. (thanks to executio for generating the scripts)
3. Open the Muonline.sql file and copy the script to the query analyzer query box and hit F5.
4. Do the same with Ranking.sql

Getting The Server Online & Finishing

The server is ready to run.

1. Open the D:/Muserver/Links/ directory.
2. Run the 00 - Configurator shortcut.
3. Now run all the other shortcuts (01, 02, 03, 04, 05, 06, 07 and 08)

ODBC errors
If you get any ODBC errors then try using the manual way of setuping ODBC using ODBC.reg.
MSWINSCK.OCX & MSINET.OCX Error
If you get any erros related to MSWINSCK.OCX or MSINET.OCX files register them as activex controls.If you don't know how to do this read the CS\fix.txt file.
 
Last edited:
Sorry, i don't have any 99B+ Client links at the moment.

Here are the advantages of this guide/server files :
  • No need to set the IPs expect those in the links that aren't so neccesary (process emulated by 00 - configurator.exe, Vb6 src attached )
  • No need to setup ODBC - in some computers that don't have C:/ drive it must be done manually
  • You don't have to restore the database, the database will be created with the SQL files found in D:/Muserver/RankingServer/SQL.
  • Minimal size, junk files removed and there aren't any log files included.
  • The best monstersetbase.txt made by Dios(check file for credits).Also, formating was done using Codeus' Team monstersetbase fomater.
  • Normal CS replaced by DT's - no need to set IP, it's detected in runtime and it's easier to make groups & subservers.
 

Attachments

Hello all... nice guide but there are some problems....
First there is a virus (Hidrag.a) in most of the .exe files...
2nd when I try to open link 3 there is the following error
3rd when i add the ranking script i get the following..

The CREATE DATABASE process is allocating 8.00 MB on disk 'Ranking_Data'.
The CREATE DATABASE process is allocating 32.00 MB on disk 'Ranking_Log'.
Server: Msg 15007, Level 16, State 1, Procedure sp_grantdbaccess, Line 97
The login '9226com' does not exist.
Server: Msg 15410, Level 11, State 1, Procedure sp_addrolemember, Line 66
User or role '9226com' does not exist in this database.
 
OK files almost work now but i have 2 probs and 1 question.....

1st)Again when i add the ranking script appears the same:
The CREATE DATABASE process is allocating 8.00 MB on disk 'Ranking_Data'.
The CREATE DATABASE process is allocating 32.00 MB on disk 'Ranking_Log'.
Server: Msg 15007, Level 16, State 1, Procedure sp_grantdbaccess, Line 97
The login '9226com' does not exist.
Server: Msg 15410, Level 11, State 1, Procedure sp_addrolemember, Line 66
User or role '9226com' does not exist in this database.

Im not sure but i think it has sth to do with the add of user 9226com...... maybe in these lines
"if not exists (select * from dbo.sysusers where name = N'9226com' and uid < 16382)
EXEC sp_grantdbaccess N'9226com'
GO

exec sp_addrolemember N'db_owner', N'9226com'"

2nd)I still have the prob with the link 5
[GR]SiLvER - Setup 99B+ server (non-router support) - RaGEZONE Forums

Smo said it is a prob of the sa password, but it is coreect!!! Checked it many times... Do you have any other ideas?

3rd)How do i chage the name of the server?? :D
 
Silver,
Iam not able to start the 00 configurator. I do doubleclick on it but it doesnt start, there also do not occour any errors, can you might help me please?
 
3. Open the Muonline.sql file and copy the script to the query analyzer query box and hit F5.
4. Do the same with Ranking.sql
Whath exactly was i supose to copy and how?
 
problems..`

Hello ppl! I have a problem whit my server.. it won't start.. at the 5 link is says something with odbc. Can someone help me pls?
 

Attachments

  • errorr - Setup 99B+ server (non-router support) - RaGEZONE Forums
    errorr.webp
    3.9 KB · Views: 119
epsylon said:
Silver,
Iam not able to start the 00 configurator. I do doubleclick on it but it doesnt start, there also do not occour any errors, can you might help me please?
There aren't any problems, the thing that 00 configruator does is set the IP in iplist.dat and make the ODBC when it's able to. It does everything in one second and it closes.

*Andreiz* said:
Hello ppl! I have a problem whit my server.. it won't start.. at the 5 link is says something with odbc. Can someone help me pls?

You can leave it and go ahead but if you don't want so get the ODBC.reg file in the first thread and merge it(dblClick).

#BH# said:
3. Open the Muonline.sql file and copy the script to the query analyzer query box and hit F5.
4. Do the same with Ranking.sql
Whath exactly was i supose to copy and how?
Open it in notepad, click Ctrl + A to select the whole text and Ctrl + C to copy it, now paste it in the query box(Ctrl+V to paste) and hit F5, do the same with ranking.sql

papari55 said:
OK files almost work now but i have 2 probs and 1 question.....

1st)Again when i add the ranking script appears the same:
The CREATE DATABASE process is allocating 8.00 MB on disk 'Ranking_Data'.
The CREATE DATABASE process is allocating 32.00 MB on disk 'Ranking_Log'.
Server: Msg 15007, Level 16, State 1, Procedure sp_grantdbaccess, Line 97
The login '9226com' does not exist.
Server: Msg 15410, Level 11, State 1, Procedure sp_addrolemember, Line 66
User or role '9226com' does not exist in this database.

Im not sure but i think it has sth to do with the add of user 9226com...... maybe in these lines
"if not exists (select * from dbo.sysusers where name = N'9226com' and uid < 16382)
EXEC sp_grantdbaccess N'9226com'
GO

exec sp_addrolemember N'db_owner', N'9226com'"

2nd)I still have the prob with the link 5
[GR]SiLvER - Setup 99B+ server (non-router support) - RaGEZONE Forums

Smo said it is a prob of the sa password, but it is coreect!!! Checked it many times... Do you have any other ideas?

3rd)How do i chage the name of the server?? :D
1.Don't mind about it.
2.Go ahead and ignore it or just download the ODBC.reg file above and dblclick it.
3.When you select server? Edit text.bmd in the client using skyteam's bmd editor.
 
Last edited:
thx bro, nice guide u have, i made it in my 1st time

but i dont have client, so cant play >_<
i'm searching the client link, i'll update later when found ^^

this server use alot of memory, my computer used 1.2Gigs of memory to run this server :surprise:

ahm, another question, i think this server going online, i want to make a lan server, how can i do that ? thx b4 bro :D
 
Back