[Tutorial] Mabinogi Heroes Setup

I believe it should be possible to add new content in the future, but the current problem we are facing is that we are currently not able to edit the client unpack/repack so we cannot add our own content besides limited mods to the client.



Lol how do you go from client server maintenance issue to client refusing to start? you just went a step backwards. I think it is most likely your Hosts file looks like it is trying to connect to nexon servers.





your web server is the EndPoint.txt edited with your IP? are you using the correct start.bat? are you using 127.0.0.1 IP or LAN IP? Did you modify the .ini in the client and did you edit the Hosts file?


The start.bat is extracted from the MabinogiHeroes.7z and placed in the MHTW file.

Here is my EndPoint.txt
DZZMXzS - [Tutorial] Mabinogi Heroes Setup - RaGEZONE Forums


How do I know if I am using 127.0.0.1 IP or LAN IP? While I was starting everything... I wasn't paying attention to this part.

The hosts was added with the lines as told in first page.

My .ini in client is

[Settings]
ServerIp=localhost
ServerPort=47611

---update
I just disabled the ethernet at Network Connections.... but still inaccessible.
 
Last edited:
The start.bat is extracted from the MabinogiHeroes.7z and placed in the MHTW file.

Here is my EndPoint.txt
DZZMXzS - [Tutorial] Mabinogi Heroes Setup - RaGEZONE Forums


How do I know if I am using 127.0.0.1 IP or LAN IP? While I was starting everything... I wasn't paying attention to this part.

The hosts was added with the lines as told in first page.

My .ini in client is

[Settings]
ServerIp=localhost
ServerPort=47611

---update
I just disabled the ethernet at Network Connections.... but still inaccessible.

127.0.0.1 is localhost IP's 192.168.x.x is your LAN IPs by default the server files came with localhost IPs. There is no need to disable any connections. I have been running the server with my LAN network on as well.



Thanks for the tutorial got it setup. Will it ever be possible to update the client to the newest version? I think this one is missing Vella's update, even Fiona's revamp, but especially Delia.

Vella mercenary character is there and this server files is season3 episode1 so delia isn't added yet. Causes yesterday the official Vindictus just got Delia. According to Vindictus's wiki they are on season3 episode4.
 
but where else should I change in order to get into the game? :/: I mean I have been working on setting it for days still not working...
---update
no wonder I failed so many times, I didn't even START the Heroes operating tool.

BIG THANKS TO EVERYONE HELPED ME OUT !!!
 
Last edited:
mHryHbG - [Tutorial] Mabinogi Heroes Setup - RaGEZONE Forums

I guess your web and server services are all working and running.
Run NMServer.exe before login in game.
nope, the problem is after opening the Optool, I didn't press the start button... so nothing was happening. But still, it is all fine now, thanks for helping me !
 
Ack, I'm still stumped. Not sure what I missed; I combed over tutorial and still can't get it working again. Hosts file has already been adjusted, as well as the RC services running, xml/config files are set appropriately. Can't figure the issue :(

8fbFUH7 - [Tutorial] Mabinogi Heroes Setup - RaGEZONE Forums


uUxPrpI - [Tutorial] Mabinogi Heroes Setup - RaGEZONE Forums

This is all the logs say. RC services are confirmed to be running.

07-16 00:15:49 > [1][(null) ((null))][HeroesContentsLoader] - HeroesContentsLoader in 64bit07-16 00:15:49 > [1][(null) ((null))][HeroesContentsLoader] - GetGameCode : FeatureMatrix
07-16 00:15:49 > [1][(null) ((null))][HeroesContentsLoader] - GetGameCodeEnd : FeatureMatrix
07-16 00:15:49 > [1][(null) ((null))][HeroesContentsLoader] - GetFeatureMatrix : ZH-TW-X-GM
07-16 00:15:49 > [1][(null) ((null))][HeroesContentsLoader] - GetFeatureMatrixEnd : ZH-TW-X-GM
07-16 00:15:49 > [1][(null) ((null))][ConnectionStringLoader] - Testing Contents DB Connection...
07-16 00:15:49 > [1][(null) ((null))][HeroesContentsLoader] - GetGameCode : FeatureMatrix
07-16 00:15:49 > [1][(null) ((null))][HeroesContentsLoader] - GetGameCodeEnd : FeatureMatrix
07-16 00:15:49 > [1][(null) ((null))][ConnectionStringLoader] - Do NOT define Configuration Setting outside of ServiceCore : ignoreDSServiceReady
07-16 00:15:49 > [1][(null) ((null))][HeroesContentsLoader] - GetTable : EventTemplate
07-16 00:15:49 > [1][(null) ((null))][HeroesContentsLoader] - GetTableEnd : EventTemplate
07-16 00:15:49 > Exception Occurred : Exception has been thrown by the target of an invocation.
07-16 00:15:49 > at System.RuntimeMethodHandle.InvokeMethod(Object target, Object[] arguments, Signature sig, Boolean constructor)
07-16 00:15:49 > at System.Reflection.RuntimeMethodInfo.UnsafeInvokeInternal(Object obj, Object[] parameters, Object[] arguments)
07-16 00:15:49 > at System.Reflection.RuntimeMethodInfo.Invoke(Object obj, BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo culture)
07-16 00:15:49 > at Executer.Program.RunService(String[] args)
07-16 00:15:49 > at Executer.Program.Main(String[] args)
07-16 00:15:49 >
07-16 00:15:49 > InnerException : Could not load file or assembly 'Core.ExceptionHandler, Version=1.0.5546.20392, Culture=neutral, PublicKeyToken=null' or one of its dependencies. The specified module could not be found.
07-16 00:15:49 > at UnifiedNetwork.OperationService.Service.Initialize[T](JobProcessor thread, IDictionary`2 typeConverters)
07-16 00:15:49 > at AdminClientServiceCore.AdminClientService.Initialize(JobProcessor thread)
07-16 00:15:49 > at ServiceCore.ServiceInvoker.StartService(String ip, String portstr, Service service, Boolean bUsePerfLog)
07-16 00:15:49 > at AdminClientServiceCore.AdminClientService.StartService(String ip, String portstr)
07-16 00:15:49 >
07-16 00:15:49 > == Begin RCClient Command Support ==
07-16 00:15:49 $AddCustomCommand 'Set Verbose Level|set-verboselevel [Level:string]'
07-16 00:15:49 > == End RCClient Command Support ==
 
Last edited:
Hi Im getting error Q.Q
After I rename RcServerconfig xmlthingy's HOSTNAME to DESKTOP-EJ3819 (something like this)
I see no services running in opclient. If I restart rccserver and rcclient thing from task manager
It simply resets back to HOSTNAME and same result. How do I make the change permanent?(I tried run notepad++ with admin btw)
Also im using xampp and really new to this. Do I need to turn on Apache or Mysql?? And what for the ports? Just xampp default?
Much thanks :D
 
Hi Im getting error Q.Q
After I rename RcServerconfig xmlthingy's HOSTNAME to DESKTOP-EJ3819 (something like this)
I see no services running in opclient. If I restart rccserver and rcclient thing from task manager
It simply resets back to HOSTNAME and same result. How do I make the change permanent?(I tried run notepad++ with admin btw)
Also im using xampp and really new to this. Do I need to turn on Apache or Mysql?? And what for the ports? Just xampp default?
Much thanks :D

Turn on apache and put the web folder contents in htdocs.
 
SOLUTION:
As i guessed right down there, it WAS a f******** small file in the Nexon Game Garbage they call "BlackCipher". If it will not load up for you just delete all files in the folder called "BlackCipher" EXCLUDING:
-- BlackCall.aes
-- BlackCipher.aes
-- BlackXchg.aes
-- config.bc
Those 4 must remain inside the Folder! After i did exactly that, the game launched again and i could see my server!

So i just started the Server and all was working fine until i took a step backwards i think.
I got it all working, fun part is that i was online on my server but then ....
I got this really annoying error:
Launcher Error Vin - [Tutorial] Mabinogi Heroes Setup - RaGEZONE Forums

I just went down and checked every damn config, hosts file even ports because it was running just fine few days ago. The Server is running on a Windows 7 VM Machine without any Problems, i was online on that thing few days ago!!! The Client was launching fine on Windows 10 until that error keeps destroying my day!

Did i oversee just a tiny small thing, a port blocked? Did not have Apple Sowtware Dongle, can also reach the "endpoint.txt" file just fine from the windows 10 machine. If anyone of you had this error, how do you fixed it?

Hosts file:
192.168.0.198 mhtwcheck.garenanow.com
192.168.0.198 hereospatch-gm.nexon.com
192.168.0.198 heroespatch-gm.nexon.com
192.168.0.198 shop.heroes.garena.tw
192.168.0.198 service.garena.tw
192.168.0.198 heroes.garena.tw
192.168.0.198 image.garena.tw
192.168.0.198 gamelog.heroes.nexon.com

Starting File:
vindictus.exe -stage -dev -lang zh-tw-x-gm -noupdate

Edit:
Found a Folder in the "My Documents Folder" with some Asian letters "新瑪奇英雄傳GM" inside there is a Reports folder with a file in it.

It is just this Message all over again and again in the file.
L 07/18/2016 - 00:56:19: @@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
L 07/18/2016 - 00:56:19: Log file started
L 07/18/2016 - 00:56:19: @@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
L 07/18/2016 - 00:56:19:
L 07/18/2016 - 00:56:19: GetModuleFileName - OK
L 07/18/2016 - 00:56:19: GetRootDir - OK
L 07/18/2016 - 00:56:20: LoadLibrary - OK
L 07/18/2016 - 00:56:20: GetProcAddress - OK
L 07/18/2016 - 00:56:21: Nexon Game Security Start - Failed, E1600301

It just seems to try to start that HShield Stuff but for some reason it can't but idk why?

I've just tried to start the other file "heroes11.exe". That worked untel i got the Error Message that the Server ist in Maintenance and on my Server Screen in the "NMServer.exe" i could see the tried attempts but there was an Opcode Error!

So i just tried different things, even deactivating the Local Network, but as u already guess, the client refused to start with the "Vindictus.exe". It seems there is just one small file created that locks the client because even without physical access to a network the error is still the same!
 
Last edited:
I'm stuck on trying to login to HeroesOpTool. I've already tried running InstallServices as an administrator and checked to see if I can enable Remote Control Client/Server Service (it's not located in my services).

When applying PAUSE to InstallServices, I found that all of the processes were either not recognized or invalid.
m2Yrlfc - [Tutorial] Mabinogi Heroes Setup - RaGEZONE Forums


Also, I was confused by the instructions to "Move everything from your webserver folder into your HTDOCS/www Folder" under the Configuring the Server spoiler as I couldn't find either of them.
 
I'm stuck on trying to login to HeroesOpTool. I've already tried running InstallServices as an administrator and checked to see if I can enable Remote Control Client/Server Service (it's not located in my services).

When applying PAUSE to InstallServices, I found that all of the processes were either not recognized or invalid.
m2Yrlfc - [Tutorial] Mabinogi Heroes Setup - RaGEZONE Forums


Also, I was confused by the instructions to "Move everything from your webserver folder into your HTDOCS/www Folder" under the Configuring the Server spoiler as I couldn't find either of them.

I used Xampp so my path is htdocs only (without /www), u must copy/pass all files in web to htdocs (htdocs/www in your case) and it must be like this:
0HrdtBn - [Tutorial] Mabinogi Heroes Setup - RaGEZONE Forums

And when you type 127.0.0.1 to your browser, it must be like this
3xCQwVM - [Tutorial] Mabinogi Heroes Setup - RaGEZONE Forums

About installing services errors, it was wrong path in .bat file, you must edit it to your own path to those services exe files. Some pictures to do it easy:
YTtYIus - [Tutorial] Mabinogi Heroes Setup - RaGEZONE Forums

WQzUzja - [Tutorial] Mabinogi Heroes Setup - RaGEZONE Forums

You can do the same for RCServer service.
Code:
RCClientService.exe -install
NET START "Remote Control Client Service"

RCServerService.exe -install
NET START "Remote Control Server Service"
 
Last edited:
Thank you very much for the reply! After activating my "hidden administrator account", I was finally able to shift+right click a command window as a true admin :$:

I also found the folder and moved the files, but I was unable to reproduce the same webpage when entering 127.0.0.1 into my browser

For the client, would I just group extract the Z01-Z09 files and place the files in client into the folder? Since so far, I have an error when starting the start.bat file that says
"Failed to read the sync file. The game must be reinstalled"
 
Last edited:
Thank you very much for the reply! After activating my "hidden administrator account", I was finally able to shift+right click a command window as a true admin :$:

I also found the folder and moved the files, but I was unable to reproduce the same webpage when entering 127.0.0.1 into my browser

For the client, would I just group extract the Z01-Z09 files and place the files in client into the folder? Since so far, I have an error when starting the start.bat file that says
"Failed to read the sync file. The game must be reinstalled"

For web, try with xampp then if you get errors on other web servers.
For client, you must have MHTW.zip and Z01-Z09 files. Open MHTW.zip and extract from there.
Then place all files in client folder to MHTW (client folder after extracting) .
Make sure your start.bat is
Code:
vindictus.exe -stage -dev -lang zh-tw-x-gm -noupdate



View attachment 157499

help me !!



TeamViewer를

Read the tutorial again, and english pls .
Make sure you edited RCSConfig.xml and ServiceCore.dll.config
 
SOLUTION:
As i guessed right down there, it WAS a f******** small file in the Nexon Game Garbage they call "BlackCipher". If it will not load up for you just delete all files in the folder called "BlackCipher" EXCLUDING:
-- BlackCall.aes
-- BlackCipher.aes
-- BlackXchg.aes
-- config.bc
Those 4 must remain inside the Folder! After i did exactly that, the game launched again and i could see my server!

So i just started the Server and all was working fine until i took a step backwards i think.
I got it all working, fun part is that i was online on my server but then ....
I got this really annoying error:
View attachment 157493

I just went down and checked every damn config, hosts file even ports because it was running just fine few days ago. The Server is running on a Windows 7 VM Machine without any Problems, i was online on that thing few days ago!!! The Client was launching fine on Windows 10 until that error keeps destroying my day!

Did i oversee just a tiny small thing, a port blocked? Did not have Apple Sowtware Dongle, can also reach the "endpoint.txt" file just fine from the windows 10 machine. If anyone of you had this error, how do you fixed it?

Hosts file:
192.168.0.198 mhtwcheck.garenanow.com
192.168.0.198 hereospatch-gm.nexon.com
192.168.0.198 heroespatch-gm.nexon.com
192.168.0.198 shop.heroes.garena.tw
192.168.0.198 service.garena.tw
192.168.0.198 heroes.garena.tw
192.168.0.198 image.garena.tw
192.168.0.198 gamelog.heroes.nexon.com

Starting File:
vindictus.exe -stage -dev -lang zh-tw-x-gm -noupdate

Edit:
Found a Folder in the "My Documents Folder" with some Asian letters "新瑪奇英雄傳GM" inside there is a Reports folder with a file in it.

It is just this Message all over again and again in the file.
L 07/18/2016 - 00:56:19: @@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
L 07/18/2016 - 00:56:19: Log file started
L 07/18/2016 - 00:56:19: @@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
L 07/18/2016 - 00:56:19:
L 07/18/2016 - 00:56:19: GetModuleFileName - OK
L 07/18/2016 - 00:56:19: GetRootDir - OK
L 07/18/2016 - 00:56:20: LoadLibrary - OK
L 07/18/2016 - 00:56:20: GetProcAddress - OK
L 07/18/2016 - 00:56:21: Nexon Game Security Start - Failed, E1600301

It just seems to try to start that HShield Stuff but for some reason it can't but idk why?

I've just tried to start the other file "heroes11.exe". That worked untel i got the Error Message that the Server ist in Maintenance and on my Server Screen in the "NMServer.exe" i could see the tried attempts but there was an Opcode Error!

So i just tried different things, even deactivating the Local Network, but as u already guess, the client refused to start with the "Vindictus.exe". It seems there is just one small file created that locks the client because even without physical access to a network the error is still the same!

disable antivirus program
 
Back