[Tutorial] Setting Up Gunbound Classic/Thor's Hammer Offline/LAN (With Pictures)

Luckily, I figured out how to solve it. To whom having same problem, try this VMsolution:
1. Run Command (Run as administrator).
2. If your GB_Serve is in C:\, copy sequentially these below command and press Enter for each (if not, change your respective address):
"C:\Gb_Serv\Server\BuddyCenter\BuddyCenter2.exe -install"
"C:\Gb_Serv\Server\BuddyServ\BuddyServ2.exe -install"
"C:\Gb_Serv\Server\Center\GunBoundCenter2.exe -install"
"C:\Gb_Serv\Server\Gunbound8360\GunBoundServ2.exe -install"
"C:\Gb_Serv\Server\Gunbound8361\GunBoundServ2.exe -install"
"pause"​
then close the Command window, run the start-sever.bat as the tutorial.

Hey Bro, i done what you say to do, but after this i try again to use the instal.services but continues that error, just do this in cmd manually is sufficient to instal?
 
If you guys need to host your servers online on linux server, you can check HostBarrel GunBound Private Server Hosting.
-
 
I did all like you and it appears this:
I cant get in any server

eu8DYrq - [Tutorial] Setting Up Gunbound Classic/Thor's Hammer Offline/LAN (With Pictures) - RaGEZONE Forums
 
This is a bit crazy but the link for gunbound admin is not working. can someone re upload it? also why does the xampp status is white instead of green, I'm using windows 10.
 
Gunbound Admin link dead ... can you reupload plese .. thank for the share.
 
a bit of a long shot but any manage to create an online server ?..TIA
 
can someone mirror the original Gb_Serv.rar because cannot download on mediafire its blocked
 
This guide was very well made but broken for a long time

A friend needed this and many other need this in the future

- I have fixed all broken image links, and replaced them with working ones
- I have fixed the mediafire link (server files) that was blocked for being "dangerous" and replaced it with the very same one but working

The images at the begin had to be linked differently and the images at the end had the be different too (normal links). This is because RaGEZONE changed the image limit since this guide was made and now, and even I can't bypass it

But at least all images and links should work again

If there's any error let me know
 
Last edited:
This guide was very well made but broken for a long time

A friend needed this and many other need this in the future

- I have fixed all broken image links, and replaced them with working ones
- I have fixed the mediafire link (server files) that was blocked for being "dangerous" and replaced it with the very same one but working

The images at the begin had to be linked differently and the images at the end had the be different too (normal links). This is because RaGEZONE changed the image limit since this guide was made and now, and even I can't bypass it

But at least all images and links should work again

If there's any error let me know
will you ever release the files for GB TH with Ex-Item? or maybe sell them?.
Regards.
 
This guide was very well made but broken for a long time

A friend needed this and many other need this in the future

- I have fixed all broken image links, and replaced them with working ones
- I have fixed the mediafire link (server files) that was blocked for being "dangerous" and replaced it with the very same one but working

The images at the begin had to be linked differently and the images at the end had the be different too (normal links). This is because RaGEZONE changed the image limit since this guide was made and now, and even I can't bypass it

But at least all images and links should work again

If there's any error let me know

Thanks for updating the guide so that everything is current!

Would you be able to please re-upload the gunbound admin link, it seems to have gone down again.

Thank you again!
 
Thanks for updating the guide so that everything is current!

Would you be able to please re-upload the gunbound admin link, it seems to have gone down again.

Thank you again!

Don't think I have it unfortunately. Reminder that this guide isn't mine

EDIT: Nevermind. This too is blocked for "Dangerous" let me try grab it.
 
1739943833004 - [Tutorial] Setting Up Gunbound Classic/Thor's Hammer Offline/LAN (With Pictures) - RaGEZONE Forums


I'm having a problem when trying to open this link (img1). I've check for folder www and www_v2 all of them having only this Splash img (img2). Should it be a HTML or some kind of PHP file??? or am I doing wrong at some step

1739943992603 - [Tutorial] Setting Up Gunbound Classic/Thor's Hammer Offline/LAN (With Pictures) - RaGEZONE Forums
 
When I try to start the server (after having followed the steps in this tutorial) I get this? Any ideas?
 

Attachments

  • Screenshot 2025-04-03 160201 - [Tutorial] Setting Up Gunbound Classic/Thor's Hammer Offline/LAN (With Pictures) - RaGEZONE Forums
    Screenshot 2025-04-03 160201.webp
    29.2 KB · Views: 61
i have question sorry for noob question.

1. is there possible to window type the client?
2. i saw this thread updated from nov 22, 2024 so this updated link fix ranking system?
3. i have trouble installing client on other PC. i test on 6 different computers and only 3 pc successfully working the game.

edited:
4. i get EXP/GP and reach the exact GP for the rank and the logo on ranking not changing still chicken logo.

thank you!
 
Hello yall, first of all, I want to thank for this awesome guide. I followed the steps and was able to play alone at my PC and my notebook. But when I tried to set up a LAN, i ran into a problem, and would like some help!
During SETTING UP WITH LAN CONNECTION, at step “c. while inside the conf folder, open extra folder and open httpd-vhosts.conf”, the instructions tell to delete from <VirtualHost *** up to </VirtualHost>, then add this code:

<VirtualHost 192.168.0.120:80>

ServerName gunbound.local

DocumentRoot C:/wamp/www

ErrorLog "C:/wamp/www/gblogs/error.log"

CustomLog "C:/wamp/www/gblogs/access.log" common

</VirtualHost>



The first problem is, inside httpd-vhosts.conf there are 2 “<VirtualHost *** up to </VirtualHost>”, like this:

<VirtualHost *:80>

ServerAdmin [email protected]

DocumentRoot "C:/Program Files/Apache Software Foundation/Apache2.2/docs/dummy-host.localhost"

ServerName dummy-host.localhost

ServerAlias

ErrorLog "logs/dummy-host.localhost-error.log"

CustomLog "logs/dummy-host.localhost-access.log" common

</VirtualHost>



<VirtualHost *:80>

ServerAdmin [email protected]

DocumentRoot "C:/Program Files/Apache Software Foundation/Apache2.2/docs/dummy-host2.localhost"

ServerName dummy-host2.localhost

ErrorLog "logs/dummy-host2.localhost-error.log"

CustomLog "logs/dummy-host2.localhost-access.log" common

</VirtualHost>



And the tutorial is not clear for me if I should delete both or just one of them. I tried deleting both, then only 1…but in both cases I keep getting the meter to stay yellow, never white when restarting wamp.

The other problem is, the tutorial tells to replace this code:

<VirtualHost (your LAN IP)>

ServerName (your domain name)

DocumentRoot C:/wamp/www

ErrorLog "C:/wamp/www/gblogs/error.log" <-- this is optional, you can replace gblogs with any folder name

CustomLog "C:/wamp/www/gblogs/access.log" common <-- this is optional, you can replace gblogs with any folder name

</VirtualHost>



But the code (codes, actually, since there are 2 of them) inside the httpd-vhosts.conf is different from the above (you can see up there, when I wrote them). So I’m not sure if I should just delete everything and keep the one posted with the instructions or if I should adapt with the lines that are the same. Well, I tried just copy and paste the code from the tutorial, changing my IP of course, but it didn’t work at all, the meter keeps yellow at all times.

Please, if somebody knows what am I doing wrong and could give me a hand, I would appreciate!
 
Back